Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 45 replies, has 2 voices.

Last updated by hooiC 11 months, 4 weeks ago.

Assigned support staff: Lauren.

Author Posts
February 20, 2019 at 12:12 pm #3221538

hooiC

I am trying to: i have completed pages/posts translated from English to French on our live site. however, noticed the Home page and a few posts are still in "translation in progress". i have gone back into these problematic page/posts to make sure its 100% fully translated, click on completed and status still in "translation in progress"

Link to a page where the issue can be seen: see images attached.

I expected to see: problematic page/posts status should be completed

Instead, I got: status in " translation in progress"

February 20, 2019 at 3:18 pm #3222512

hooiC

I went into wpml- Translation and click on Home page (English to Italy) , made some changes and the content was 100% complete. click complete and message said translation successful. but when it takes me back to the translation list, this page still has the status: "waiting for translator"! please can you advise how this can be fixed.

February 20, 2019 at 10:23 pm #3223978

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

If I understand correctly, you clicked "Translate" next to the homepage in WPML -> Translations and marked it as complete. But the translation still shows as in progress, is this correct?

What happens if you click 'resign' on the WPML -> Translations page? Also, did you at any point switch from the classic editor to the Advanced Translation editor? If so, try switching back to the classic editor and see if you can complete the translation from there.

February 21, 2019 at 7:20 am #3225189

hooiC

Hi Lauren

What happens if you click 'resign' on the WPML -> Translations page? I get " take and translate" button. see image. status said waiting for translator on translation management page. I clicked on the "take and translate" button and edit and saved 100% complete. the status still says "waiting for translator". I did not switch from classic to advanced. always used advanced. I am nervous about switching to classic editor. is there anything on troubleshooting page that I should do to fix this issue. I have the Italian home page and also 4 Posts also with the same problem. how do i check the id of the translation and id for translator? all other posts and pages translated to Italian and status changed to "complete". currently, the Home page is not appearing on the menu as it says on menu, its not translated!(see image 3)

February 21, 2019 at 4:42 pm #3228877

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

February 21, 2019 at 5:01 pm #3229006

hooiC

Hi Lauren I am not able to give you access yet, as another support member is accessing it . I rather he finished his troubleshooting first. on this issue regarding Home page of Italy, when i went in to edit, this time , I get a message its in classic editor mode(see image) but I don't want to edit in this mode as currently all my translations of the Home Page in Italian has disappeared in he classic editor mode. also see this message attached that appears above the Home Page of Italy. the translator(who is myself) has been given access to advanced editor already. how can I fix this issue ie to make the system know i have been given access to advanced editor.

February 21, 2019 at 5:15 pm #3229120

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Please let me know when it is possible for me to login and further troubleshoot. As for translation mode, please ask the translation manager to go to WPML -> Settings and in the editor section, click the button to synchronize translators. If that does not resolve the message, you may need to open a new ticket to address this particular issue.

When you first translated the page, which editor did you use? if you started in one and switched to another, this may be the reason for the problems. I suggest continuing to edit the page in the editor that it was created in to avoid problems.

February 21, 2019 at 5:27 pm #3229199

hooiC

please ask the translation manager to go to WPML -> Settings and in the editor section, click the button to synchronize translators. - reply: I am the translator manager and has synchronised translator. My name ( as the translator) appears on the list. but advanced editor still not available for me to use. in fact, I just tried to use it for translating a new page for Dutch and i get classic editor.(similar message appeared that I need authorisation to use advanced editor!) do you think i should remove myself as translator and then add myself again as a translator and see if it will synchronise me to use the advanced editor or you think i should raise this as a separate issue?
When you first translated the page, which editor did you use? Advanced editor as I bought words to translate automatically.

February 21, 2019 at 6:12 pm #3229431

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

You can certainly try removing/adding yourself as a translator, but I'm not sure if this will resolve it.

As for the homepage, let's try this. Once you click Resign, instead of clicking "Take and translate", go back to WPML -> Translation Management -> Translation Jobs and cancel the job. Then, go to Translation Management and try to send it again. After that, try taking it as the translator and marking it as complete. Does this then show the translation as still in progress?

February 21, 2019 at 6:26 pm #3229457

hooiC

Hi Lauren. I have tried what you said . The Home page - Italian is in classic editor mode and the content of the italian translation all disappeared , which I did on the 19th February using advanced editor and buying words for the translation. as I said i am currently not able to use the advanced editor. if we can fix this issue to allow me to use the advanced editor, then my problem is solved. currently i can't even translate a new page for Dutch using advanced editor

February 21, 2019 at 6:29 pm #3229473

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Please let me know when I can log in and take a look at the ATE settings, and I'll be happy to continue troubleshooting.

February 21, 2019 at 8:50 pm #3230024

hooiC

Hi Lauren

Please can you send me a private link so i can send you login details?

February 21, 2019 at 9:21 pm #3230071

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

The next reply has been marked as private, thank you.

February 22, 2019 at 9:18 am #3231467

hooiC

Hi Lauren are you still able to help me with the ATE issue? I can't progress with translation until I can use the ATE issue. Please can you escalate to 2nd tier team to help me to fix this issue asap as i have a deadline by weekend to complete all translations.
I noticed today if I went into a new page directly(not through wpml translation mgt send jobs) to translate in Dutch, i can see the page shown in ATE mode and after saving the 100% texts, I clicked on save and complete , the status of the page still says "edit dutch translation". when i went back in, the page is displayed in classic editor mode. any changes i made earlier under ATE mode has disappeared. so clearly the ATE is not working. thank you

February 22, 2019 at 2:30 pm #3232767

hooiC

Hi Lauren, please send me the private message so i can send you my email account where we have problem with ATE not working, so you can see on your side why I can't use ATE though it said I am enabled. also when request for activation , i didn't get any email to re-activate. I also tried what was suggested on this link but ATE still not working. https://wpml.org/forums/topic/ate-activation-email-not-recieved.
I am very worried about losing the content for each language site because of this issue.