This thread is resolved. Here is a description of the problem and solution.

Problem: translated pages appears as drafts

Solution: This is expected only if you select the option to be 'Draft' in WPML > Settings > Translated Documents Option : http://take.ms/EEfNO

In front end translation is visible - it may visible to you because you are logged in and admin. - this won't visible to others

Just publish the translation and change the setting in WPML > Settings > Translated Documents Option : http://take.ms/EEfNO

Everything will be fine.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by harrisD 2 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
April 5, 2020 at 2:25 pm #5841939

harrisD

Some translated pages appears as drafts in back end. In front end translation is visible. Is this normal?
See attached screen shot

April 6, 2020 at 10:05 am #5846593

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

This is expected only if you select the option to be 'Draft' in WPML > Settings > Translated Documents Option : hidden link

In front end translation is visible
- it may visible to you because you are logged in and admin.
- this won't visible to others

Just publish the translation and change the setting in WPML > Settings > Translated Documents Option : hidden link
Everything will be fine.

Let me know if you need anything else regarding this.

Regards,
Riffaz.

April 7, 2020 at 2:46 pm #5858451

harrisD

My settings are "same as original document".
Any way, i published them

April 8, 2020 at 6:33 am #5862823

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Ok, cool!

If you see the same issue again do not hesitate open new tickets.
We are happy to help.

Regards,

April 13, 2020 at 6:40 pm #5898601

harrisD

My issue is resolved now. Thank you!