This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Mihai Apetrei 2 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 30, 2019 at 6:53 pm

jonathanS-36

I am trying to: Duplicate an English blog page and create a French one.

Link to a page where the issue can be seen: hidden link

I expected to see: /fr/blog

Instead, I got: /fr/blog-1

I've done this several times for clients in the past but have run into several issues with this theme including posts not separating into the correct languages without filters on the blog page and the inability to create proper URL structures for the blog. I feel like this may be a theme issue but I thought I'd ask here as well.

July 31, 2019 at 6:19 am #4311751

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

WordPress has a rule where it will create that kind of link structure if there is any other existing link already (/blog). And it also takes into consideration the items in the trash, too.

So, for example:

1. These are the pages in the French trash:
hidden link

2. These are the pages in the English trash:
hidden link

What you have to do is:

1. delete all the Blog related items in the trash
2. then go to the French blog page edit page (hidden link) and rename the link from /blog-1 to /blog and save the page
3. then also go to Settings > Permalinks and re-save that page

Now please see if the issue (the redirect) is still happening.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 31, 2019 at 7:09 pm #4317321

jonathanS-36

Hi,

I tried that, even deleting the page and duplicating it again but it won't allow me to set the permalink back to /fr/blog from /blog-1. Any ideas why not?

August 1, 2019 at 2:31 pm #4322759

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi!

From what I can see, now this link loads fine (hidden link) and it does not redirect to hidden link

So, even if we are making progress, it feels that there is something either coming from the theme or from a plugin that is using that /blog URL (I guess there might be a blog page template or something like that).

Can you please try this and see if there is anything changing:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that goes.

I will be waiting for your response.

Kind regards,
Mihai

The topic ‘[Closed] Translated pages appending -1 instead of keeping url struture’ is closed to new replies.