This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Mihai Apetrei 5 months, 2 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 8, 2019 at 1:31 pm

klaasC-3

I am trying to: Translate pages in different langauges

Source page: hidden link
Translated page: hidden link & hidden link

I expected to see: the layout from the source page with translated contact.

Instead, I got: a blank page with header and nothing more.

May 8, 2019 at 2:38 pm #3767785

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

When I try to log into the site, I get the notification in the screenshot I attached below.

Can you please take a look?

Kind regards,
Mihai Apetrei

May 8, 2019 at 2:53 pm #3767935

klaasC-3

Dear Mihai,

my mistake; I have two factor authentication on on my sites per default. This should be off now.

thank you for looking in to this.

Klaas

May 8, 2019 at 4:19 pm #3768971

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the confirmation.

Now the login worked.

1. Can you please try the steps below:

- disable all plugins except WPML and its add-ons (leave the Divi builder enabled, too)
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated (leave the Divi builder enabled, too)
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

2. If the steps above didn't help, I will need you to please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

In order to do that, edit the wp-config.php file inside your WordPress directory and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Now please reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Paste the content (if any) on a site like pastebin.com and then share the link here with me. Please censor any sensitive information.

Please let me know how that goes.

I will be waiting for your response.

Kind regards,
Mihai

May 9, 2019 at 8:05 am #3773995

klaasC-3

Hello Mihai,

Thank you for looking in to it.

1) I have tried disabeling all plugins except wpml; as I'm using the divi theme, the divi builder is not a plugin anymore but is part of the theme, so this one did not need to be disabled. Unfortunately that did not change the outcome.

2) I tried switching to a standard theme. The only difference I noticed was that the base-page was now filled with divi code (as the standard theme does not have the divi interpretation). The other pages remained blank.

3) I reactivated the plugins needed to dispay the site correctly and then put on the debug log: result: - https://pastebin.com/GQgyuaJ6

To be noted: in the header of the page, as you can see yourself on:

hidden link and hidden link and hidden link the menu is changing correctly (language wise) it's just the content that is not being displayed.

you can try to recreate the above as you still have admin access; if I need to enable debug information, let me know.

Kind regards,

Klaas

May 10, 2019 at 8:56 am #3782403

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

It seems that the translations were not 100% saved, instead, it was showing the arrows in a circle. (attaching screenshot - it should show pencil-edit icon instead).

I just clicked on it and re-saved the translations for both languages and the content is now showing fine.

Can you please check on your side, too?

Kind regards,
Mihai