This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Jen 2 weeks, 1 day ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
October 3, 2019 at 12:50 pm #4687731

Jen

I am using Storefront theme and on my homepage I have the categories listed with names and images. I translated my website to 3 languages: German, Spanish and Russian. The categories and their images appear properly for Spanish but they do not appear properly for German and Russian although I created them just the same way I created the Spanish one. What might be the problem?

[EDITED]

October 3, 2019 at 8:18 pm #4691295

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Before a more detailed look can you check the following, please?

1 - Do you have all these categories translated for all the languages, exactly as you have with the spanish language? Just asking because you might have all of them translated into spanish but not in the other languages.

2 - Are there translated products assigned to all the translated categories?

3 - Do you have any cache mechanism? If so, can you please, try to access your website using the chrome incognito mode?

Please, let me know, so we can proceed with a more detailed look. Have a nice day.

October 4, 2019 at 7:39 pm #4698393

Jen

My issue is resolved now. Thank you!

October 4, 2019 at 7:43 pm #4698401

Jen

Could you please delete this ticket? Thanks.

October 4, 2019 at 8:28 pm #4698445

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Jen,

Thank you for the updates. I am closing this ticket and marking it as resolved. If you don't mind we need to make it in the forum content so other users can find answers for their questions when they face the same issue as yours. Is it okay for you? Thank you for your collaboration, have a nice day.

October 4, 2019 at 8:30 pm #4698449

Jen

Could you at least delete the screenshots (4 images) I shared there?

October 4, 2019 at 8:34 pm #4698469

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Sure, your initial message is now edited and the screenshots deleted. Thank you, have a nice day.

October 7, 2019 at 7:04 am #4704923

Jen

My issue is resolved.