This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Andreas W. 4 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
May 23, 2019 at 9:37 pm

jamesL-26

I have translated a couple pages and they do not display correctly when using the language switcher. All theme settings and navigation menu are not displaying.

Link to a page where the issue can be seen: hidden link (the English translation of an Italian page)

I expected to see: hidden link (but in English of course!)

May 26, 2019 at 11:35 pm #3892515

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Could you please increase your WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 1024M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

If this will not solve the issue please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', true );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to see errors on front end, backend and further find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know about the outcome.

Kind regards
Andreas

May 29, 2019 at 11:44 pm #3919039

jamesL-26

Hi Andreas,

Still going in circles with this issue. The issue is not so much the translation, which is working, but why my theme formatting breaks and reverts to a partial Avada theme but without navigation and the layout / color / image modifications I've made. You can see this if you go here and click from Italian to English translation: hidden link

I inserted the wp_memory_limit value and debug information you suggested and I'm not seeing any errors, nor is there an error log being created. Do I need to take this up with Avada support, or if I do, will I be in another circle of "it's not us, it's them"?

BTW, the PHP memory is 1GB, the highest I've ever worked with in a shared hosting environment. The mods to wp-config don't seem to change anything, and I'd think having 1GB would be much better than 256M.

Any more suggestions on getting the translated page to look the same as the base language (Italian)?

Jim Lawrence

May 30, 2019 at 2:40 am
May 30, 2019 at 2:42 am #3919917

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have just sent you a private message in order to migrate your site to our test server for further debugging.

Please leave me short notification once the migration progress has been completed.

Kind regards
Andreas

May 30, 2019 at 11:20 pm #3926545

jamesL-26

Hi Andreas,

Thank you for the extended assistance. I've completed the site migration. Unfortunately, the issue still exists in this environment. Click on the English translation icon of this page and you'll see the issue: hidden link

One thing I didn't mention before, and it may not have any consequence, but I'm running this site from a sub-directory in the public_html directory. Just wanted to get that info in the conversation in case it would have any contributing factor to the display problems.

Thanks, and looking forward to your investigation.

Jim

May 31, 2019 at 3:26 pm #3931655

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I wanted to let you knwo that I am still investigating the issue.

The debug.log was showing only one error so far which is realted to an Internal function to perform the mysql_query() call.
I then checked your debug information and realized that your server is running mySQL 5.5.5. but the minimum requierment for WPML is mySQL 5.6 or higher.

Could you please update mySQL and then update and retransalte the content.

I am currently taking a copy of the site to test it locally with a different version of mySQL and applying higher memory limits for PHP and WordPress.

Even though I did not receive any memory errors I would further advise you to set the PHP memory limit inside of the php.ini file for PHP 7.2.17 to 1024M. Afterwards change the WP Memory Limit to 512M as the PHP Memory Limit should always be higher than the WP Memory Limit.
hidden link

I will also try to recreate the issue on a new WordPress installtion. Once I have results I will be in contact.

Kind regards
Andreas

Let me know if this solved the issue.

May 31, 2019 at 4:42 pm #3932149

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have spottet an error on your backend when going to Fusion Builder -> Libraries. You can very it on your backend. This error might cause the issue and it still appears if WPML or any additional plugin is deactivated.

Please contact the Theme Fusion Support here in order to solve the issue:
hidden link

Once this issue is solved I am expecting that you will be able to translate the content as expected. In any different case please reach out to us again.

Kind regards
Andreas

May 31, 2019 at 8:57 pm #3933183

jamesL-26

Hi Andreas,

I deleted the template that had the error in the Fusion library. But, there is still an artifact in the database because it thinks there are more templates in the library than there actually are. I'll contact Avada support regarding this.

I'll have my client contact their host about upgrading to mySQL 5.6 . What is interesting is when I go to phpMyAdmin, it shows we're running Maria 10.2.24 . So, I don't know why Avada system report is showing MySQL 5.5 , but I'll ask.

Will be in contact next week as I wouldn't expect the host to make any changes over the weekend.

Thanks!

May 31, 2019 at 9:21 pm #3933343

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Thank you for the message.

Indeed theis is weird, as the WPML Debug information shows the info that you can see on the attached screenshot.

Further, when enabling the WP-Debug feature I was expecting more errors to come out, but there were not until I took a copy of the migrated website to run it on localhost.

Infact, I recieved a database error that is affecting WPML tables:

DATABASE ERROR: database error write WARNING: Database Table row count validation error DATABASE: table "wp_icl_string_pages" row count mismatch; expected "9117" in database"5791" DATABASE: table "wp_icl_string_urls" row count mismatch; expected "8" in database"7" DATABASE: table "wp_itsec_log" row count mismatch; expected "9" in database"8" DATABASE: table "wp_itsec_temp" row count mismatch; expected "6" in database"4"

It is alike for some reason rows from those tables disappeared, which might be caused to the migration process, but I am not sure. On the migrated site these errors did not show up.

The debug.log of the migrated website did in fact not show any errors related to WPML but there been issues with the Fusion Libraries. Please provide this info to Theme Fusion Support.

PHP Warning:  Error while sending QUERY packet. PID=8128 in /mnt/BLOCKSTORAGE/home/278662.cloudwaysapps.com/bbhqjjqrvj/public_html/wp-includes/wp-db.php on line 2007
PHP Warning:  sprintf(): Too few arguments in /mnt/BLOCKSTORAGE/home/278662.cloudwaysapps.com/bbhqjjqrvj/public_html/wp-content/plugins/fusion-builder/inc/class-fusion-builder-library-table.php on line 287

I tried to recreate the issue on the following test site and so far did not experience problems. Maybe it could server you for further investigation:
One Click Login: hidden link

Please let me know about Theme Fusion´s response and we will take further steps is necessary.

Kind regards
Andreas

June 3, 2019 at 9:01 pm #3946185

jamesL-26

Hi Andreas,

Avada support was very helpful and identified two issues:

1) I had created a container with a special character "%" in it and that was the reason for the DB and Library error.

2) They pointed out that each language can have unique theme options. I exported the theme options from the Italian settings and imported them into the English settings, and problem solved! No more broken formatting when switching languages.

I'm still going to followup on your suggestions for php and wp memory allocation, as well as upgrading MySQL.

At this point, I think you can close this ticket. Thanks again for your help and insight. I'll be in touch if I get stuck again, but for now things are looking much better.

Jim Lawrence

June 3, 2019 at 10:04 pm #3946305

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Jim,

Thank you for the notification.

Now that you mention it, I totally forgot that Avada offers to export and import theme options. Make sure to keep a backup of your default options and import then into the second language in case you run in further issues.

Make sure to change the limit anyways, as you might run into issues once the site grows.

Kind regards
Andreas