This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.55 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by Carlos Rojas 3 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 22, 2019 at 5:27 am

stueyP

HI Carlos,

Actually I have figured out the issue with the translated pages not showing but I do have another problem that needs sorting. I cannot get the main menu to sync correctly. I have translated the items missing from the menu sync page and they show up correctly in the Indonesian menu but the sync page shows the m as being a problem. Also there are 2 sub menus that haven't come across from the English version. You can see them in the attached screenshots. I have opened up your site and FTP access again with the same password as before. cheers.

June 22, 2019 at 5:45 am #4070391

stueyP

Oops, forgot the attachments.

June 24, 2019 at 12:27 pm #4077237

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I took a look at the site and the pages that doesn't appear in the menus need to be translated and finish those translations. I tried to do this with the Privacy Policy page but it seems there is a compatibility issue with a third party functionality that doesn't show the links in the code for the translation.

In this case I recommend you to follow this steps:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- Finish the translation of the Privacy Policy page.
- Sync the menu.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Kind regards,
Carlos

June 28, 2019 at 8:05 am #4105339

stueyP

Hi Carlos, I have now uploaded several translated pages from my service and they appear to display correctly. I have also been able to fix up the menu issue but the sync page still shows issues and errors that actually don't exist. Can you please check from your perspective to see if all operates correctly now?

Cheers

Stuart

June 28, 2019 at 2:31 pm #4108635

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Stuart,
I'm glad to hear that the main issue is solved 🙂

In this cases is recommendable to re-create the menu, this way we will avoid any issue contained in the menu entry in the database.

Could you confirm that the issue disappears after re-creating the menu?

Regards,
Carlos

July 1, 2019 at 3:06 pm #4120505

stueyP

Carlos, I believe that the last issue I have with the 2 menu items not syncing on the WP Menu Sync section is actually due to them being set up with no URL allocated. I did this to ensure that clicking on them simply opens the sub menu access and doesn't redirect anywhere. Both items display on the live site in both languages so all looks good for now. Thanks.

July 1, 2019 at 3:21 pm #4120729

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos