This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 29 replies, has 3 voices.

Last updated by Yvette 1 year ago.

Assigned support staff: Yvette.

Author Posts
September 5, 2018 at 8:58 am

Theo

Hi there,

I am using WPML and am currently adding playlists of MP3 files to posts.
When editing the german post I am giving the MP3 files names so that the payer shows "demo 1" instead of "demo-1.mp3". Then I save the german post and copy the [playlist ids="…"] to the english translation. Unfortunately the player on the translated posts still shows "demo-1.mp3" even tough the files now have the name "demo 1" in the media library.

Is this a bug or is there a setting where I can say WPML to use the MP3 name on the translated pages as well?

Thanks!

September 5, 2018 at 12:23 pm #2706866

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @theo, welcome to the WPML support Forum!

I need some answers before proceeding:
- What is the name of the plugin?
- It works on the original language, but not in the translation? Or the issue happens even on the default language with WPML active?
- Are you using the translation editor or the manual editor?

All the best,
Diego

September 5, 2018 at 3:02 pm #2707745

Theo

Hi Diego,
- I do not use any plugins but the default WordPress media player
- Yes it works on the original language but not in the translation
- I don't know what you mean by manual editor but I guess I am doing it manually.
Thanks!

September 5, 2018 at 7:57 pm #2708618

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Please go to WPML > Settings > Post Types Translation and check if the Media Post Type is set to "Translatable - only show translated items"

After that, please try the following:
- Go to the edit screen of the page (default language)
- Change the language using the Language Switcher at the top admin bar
- If it display a warning, click on "Edit Anyway"
- Add the shortcode here and save

Please let me know if it worked for you. If not, pĺease send us some screenshots.

Regards,
Diego

September 6, 2018 at 8:13 am #2709883

Theo

Hi Diego,
Yes, media post type is set to "translatable - only show translated items".

I followed your steps but this resulted in the media player only showing up at the translated language. Probably because I did not save the post in the default language before switching?

I then tried it again the way I used to but still have the same problem:

1. I went to the post in the default language (german) and added a playlist of mp3 files.
Since the title of all mp3 files is the filename I changed the title of the mp3 from "Oberheim-OB8-DEMO1" to "Demo 1" and added "OBERHEIM OB-8" as artist. I copied the playlist code (see picture) and saved the post.
2. I changed the language using the language switcher, pasted the playlist code and saved the post in english too.

The result is still the same (see pictures). The german version has the changed title but the english version still uses the "old" title of the file. I checked the media library and the new mp3 title is saved correctly (see picture).

Looking forward hearing from you. Thanks for your help!

September 6, 2018 at 8:24 am #2709975

Theo

…just to check I renamed the title of a mp3 directly in the media library with the same result.

The new title shows up in the default language correctly but not on the translated page.

September 6, 2018 at 5:27 pm #2711819

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

We need to isolate the issue to do some tests and notify our developers if necessary.

I created a test website with a clean WordPress install. This installation already has WPML configured. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please create a test page and reproduce the issue here. I will check and do some tests. Please note that we only need the related functionality to reproduce the issue, you don't need to setup a entire website or clone your existing site.

Regards,
Diego

September 6, 2018 at 8:31 pm #2712289

Theo

Hi Diego,
I created a new post on your link with a similar result.
The only difference is that on your page the track title is wrong instead of the author.
I hope this helped to narrow down the issue.
Please delete the mp3 file I uploaded when you are finished.
Thanks for your help!

September 7, 2018 at 9:36 am #2713911

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Diego is not available today and so I will be helping you with this issue. I hope this is okay with you.

I took a look at the sample page your prepared (thanks) and could see that you had not used the Media Translation to change the title. This means that the old title was still associated with the media (see image).

Once I completed the translation via WPML -> Media Translation, the new title appeared on the post.

Could you confirm that using Media Translation on your site will resolve the issue for you? Or perhaps you are able to prepare another example where the same problem is happening?

Thanks

September 8, 2018 at 7:49 am #2716592

Theo

Hi Yvette,

I have not yet looked at the media translator. I simply want to use the same file name and author in both languages. Since I have over 1000 mp3 files on my blog it is impossible to translate every file…

Thanks for your help!

September 8, 2018 at 2:06 pm #2716843

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

If you are using the same image text in all languages, then you should not need to "Translate" the media with the WPML Media Translator module.

However, you **do** need to duplicate the media to all languages and set these options for new media uploads. This means that you should execute the "Start" button with all options selected in the following config area:
WPML > Settings > Media Translation

You should also select the options for new media and select "Apply".

Did you do these steps previously?

September 10, 2018 at 9:10 am #2719300

Theo

Ah I see!
I was wondering why Diego not told me to uncheck the Media Post Type "Translatable - only show translated items".
I now switched to Media (attachment) not translatable.
Do I really need to duplicate all the media? I have more than 1000 audio files and even more than 3000 images…

September 10, 2018 at 9:54 am #2719498

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Duplicating the Media with WPML Media Translation does not mean duplciating the media physical files. It means that you will duplciate the entries for each media attchement post type in the wp-posts table.

It will then create corresponding entries in the icl_translations table.

So, in total, you will increase your database size with file "names"...not actual files.

Diego might have told you to set the post type as "Translatable - only show translated items". because for a short while, this was indeed the recommended case. However, it caused unforseen problems with related projects and the solution went back to duplicating the media as the default state.

September 10, 2018 at 2:03 pm #2720149

Theo

Hi Yvette,
unfortunately I get the error: Translate media: please try again (error) when I press Start.
I also noticed that WPML does not translate witget titles on my site that I translated with the string translation.

September 11, 2018 at 8:11 am #2722790

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. Translate media: please try again (error)
Is the Media post type set to "Translate"?

2. To move faster...Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

The topic ‘[Closed] Translated pages do not show the correct media name’ is closed to new replies.