This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
When translating pages built with the GoodLayers Page Builder, both the Classic and the Advanced Translation Editors seem to erase any content built with the page builder. Other content works fine.

This is due to a bug with one of the core GoodLayers plugins. The author has fixed this bug in some themes but not others.

Solution:
You can fix the behavior of the page builder during translations by adding the following WPML Config XML either as a file, or into the WPML -> Settings -> Custom XML Configuration field.

<wpml-config>
    <custom-fields>
        <custom-field action="translate">gdlr-core-page-builder</custom-field>
        <custom-field action="translate">gdlr-core-page-option</custom-field>
    </custom-fields>
 
    <custom-fields-texts>
        <key name="gdlr-core-page-option">
            <key name="page-caption"/>
            <key name="position"/>
            <key name="excerpt"/>
            <key name="social-shortcode"/>
        </key>
        <key name="gdlr-core-page-builder">
            <key name="*">
                <key name="items">
                    <key name="*">
                        <key name="items">
                            <key name="*">
                                <key name="value">
                                    <key name="title"/>
                                    <key name="content"/>
                                    <key name="caption"/>
                                    <key name="title-link"/>
                                    <key name="delicious"/>
                                    <key name="email"/>
                                    <key name="deviantart"/>
                                    <key name="digg"/>
                                    <key name="facebook"/>
                                    <key name="flickr"/>
                                    <key name="youtube"/>
                                    <key name="skype"/>
                                    <key name="heading-text"/>
                                    <key name="bar-text"/>
                                    <key name="tabs">
                                        <key name="*">
                                            <key name="heading-text"/>
                                            <key name="bar-text"/>
                                            <key name="title"/>
                                            <key name="content"/>
                                            <key name="data"/>
                                        </key>
                                    </key>
                                    <key name="port-info">
                                        <key name="*">
                                            <key name="key"/>
                                            <key name="value"/>
                                        </key>
                                    </key>
                                </key>
                            </key>
                        </key>
                    </key>
                </key>
            </key>
        </key>
    </custom-fields-texts>
    <custom-types>
        <custom-type translate="1">portfolio</custom-type>
        <custom-type translate="1">personnel</custom-type>
    </custom-types>
    <taxonomies>
        <taxonomy translate="1">portfolio_tag</taxonomy>
        <taxonomy translate="1">portfolio_category</taxonomy>
        <taxonomy translate="1">personnel_category</taxonomy>
        <taxonomy translate="1">page_category</taxonomy>
    </taxonomies>
    <admin-texts>
        <key name="gdlr_general">
            <key name="top-bar-left-text"/>
            <key name="top-bar-right-text"/>
            <key name="top-bar-social-delicious"/>
            <key name="top-bar-social-email"/>
            <key name="top-bar-social-deviantart"/>
            <key name="top-bar-social-digg"/>
            <key name="top-bar-social-facebook"/>
            <key name="top-bar-social-flickr"/>
            <key name="top-bar-social-google-plus"/>
            <key name="top-bar-social-lastfm"/>
            <key name="top-bar-social-linkedin"/>
            <key name="top-bar-social-pinterest"/>
            <key name="top-bar-social-rss"/>
            <key name="top-bar-social-skype"/>
            <key name="top-bar-social-stumbleupon"/>
            <key name="top-bar-social-tumblr"/>
            <key name="top-bar-social-twitter"/>
            <key name="top-bar-social-vimeo"/>
            <key name="top-bar-social-youtube"/>
            <key name="copyright-text"/>
            <key name="main-navigation-right-button-text"/>
        </key>
    </admin-texts>
</wpml-config>

This topic contains 11 replies, has 2 voices.

Last updated by yasuanQ 1 week, 4 days ago.

Assigned support staff: Izzi Hassan.

Author Posts
October 1, 2019 at 7:55 pm #4675137

yasuanQ

I am trying to: translate

Link to a page where the issue can be seen:hidden link

I expected to see: hidden link (That page in english)

Instead, I got:hidden link (nothing appears)

October 2, 2019 at 7:37 am #4677487

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for reaching out to WPML Support.

I took a look at the debugging information you provided and it appears that you are set up correctly to translate pages and posts.

Looking at the pages, I can see that the title is being translated and the correct translated page is being displayed without the rest of the page content. This suggests that WPML is unable to find a translation for that content.

Could you confirm how you translated that page, and that you provided translations for all content on the page?

If you are using our Classic or Advanced Translation Editor, were you asked to translate your page content, and did you click "Translation Complete" after completing all content on that page?

If you provide temporary access to your website, I can also take a look at the page in question. You can share access credentials securely using the fields below. I will not make any changes directly to your site, but it is always a good idea to keep a backup of your site before providing access.

October 2, 2019 at 10:55 am #4679365

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I took a look and there is something happening where the page builder content disappears when a page is translated using the Advanced Translation Editor. I'm looking into why this occurs.

In the meantime, if you open the English translation page and click "Edit Anyways", then click "Overwrite with Spanish content", you can manually edit the contents as you would if you were creating a new page. This seems to work just fine.

We will look into whether this is a bug in WPML or a compatibility issue with your theme and I will update you when I have some more information.

Let me know if that workaround works for you.

October 2, 2019 at 1:02 pm #4680347

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have confirmed that this is a known issue with the Kingster Theme. The same issue was fixed for the GoodLayers Infinite theme using a custom XML Configuration. Could you follow the steps below and let us know if that helps resolve the problem?

Please make sure you take a backup of your database or copy your site to a staging domain before trying this. It should not cause any loss of data, but since you are working on a live website, it is always a good idea to have a backup available.

- Go to WPML -> Settings
- Click on the Custom HTML Configuration tab
- Paste the following code into the box:

<wpml-config>
    <custom-fields>
        <custom-field action="translate">gdlr-core-page-builder</custom-field>
        <custom-field action="translate">gdlr-core-page-option</custom-field>
    </custom-fields>

    <custom-fields-texts>
        <key name="gdlr-core-page-option">
            <key name="page-caption"/>
            <key name="position"/>
            <key name="excerpt"/>
            <key name="social-shortcode"/>
        </key>
        <key name="gdlr-core-page-builder">
            <key name="*">
                <key name="items">
                    <key name="*">
                        <key name="items">
                            <key name="*">
                                <key name="value">
                                    <key name="title"/>
                                    <key name="content"/>
                                    <key name="caption"/>
                                    <key name="title-link"/>
                                    <key name="delicious"/>
                                    <key name="email"/>
                                    <key name="deviantart"/>
                                    <key name="digg"/>
                                    <key name="facebook"/>
                                    <key name="flickr"/>
                                    <key name="youtube"/>
                                    <key name="skype"/>
                                    <key name="heading-text"/>
                                    <key name="bar-text"/>
                                    <key name="tabs">
                                        <key name="*">
                                            <key name="heading-text"/>
                                            <key name="bar-text"/>
                                            <key name="title"/>
                                            <key name="content"/>
                                            <key name="data"/>
                                        </key>
                                    </key>
                                    <key name="port-info">
                                        <key name="*">
                                            <key name="key"/>
                                            <key name="value"/>
                                        </key>
                                    </key>
                                </key>
                            </key>
                        </key>
                    </key>
                </key>
            </key>
        </key>
    </custom-fields-texts>
    <custom-types>
        <custom-type translate="1">portfolio</custom-type>
        <custom-type translate="1">personnel</custom-type>
    </custom-types>
    <taxonomies>
        <taxonomy translate="1">portfolio_tag</taxonomy>
        <taxonomy translate="1">portfolio_category</taxonomy>
        <taxonomy translate="1">personnel_category</taxonomy>
        <taxonomy translate="1">page_category</taxonomy>
    </taxonomies>
    <admin-texts>
        <key name="gdlr_general">
            <key name="top-bar-left-text"/>
            <key name="top-bar-right-text"/>
            <key name="top-bar-social-delicious"/>
            <key name="top-bar-social-email"/>
            <key name="top-bar-social-deviantart"/>
            <key name="top-bar-social-digg"/>
            <key name="top-bar-social-facebook"/>
            <key name="top-bar-social-flickr"/>
            <key name="top-bar-social-google-plus"/>
            <key name="top-bar-social-lastfm"/>
            <key name="top-bar-social-linkedin"/>
            <key name="top-bar-social-pinterest"/>
            <key name="top-bar-social-rss"/>
            <key name="top-bar-social-skype"/>
            <key name="top-bar-social-stumbleupon"/>
            <key name="top-bar-social-tumblr"/>
            <key name="top-bar-social-twitter"/>
            <key name="top-bar-social-vimeo"/>
            <key name="top-bar-social-youtube"/>
            <key name="copyright-text"/>
            <key name="main-navigation-right-button-text"/>
        </key>
    </admin-texts>
</wpml-config>

- Click the "Save" button

Now try translating your page as your normally would with the Advanced Translation Editor. Your old translations will show up automatically when you translate the same page thanks to our Translation Memory feature.

Please do let me know if this solves your problem!

October 2, 2019 at 2:09 pm #4681299

yasuanQ

Hello,

thank you, I have done that, but is happening the same again; I've tried to open the English translation page and click "Edit Anyways" and the content doesn't appear (I overwrite the content) but nothing appears,... I'm really scared that is not going to work 🙁

thank you!
Esther

October 2, 2019 at 2:27 pm #4681489

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

So I think the custom code did resolve the issue. I simply had to delete the English translation page, then translate the Spanish one again. All the translations were automatically applied from memory and the new English page had the complete content!

You can see the new, working English page here:
hidden link

Please delete any other pages that have this issue in English, then click the "+" sign next to the Spanish page to translate them again. It will take you through the same steps with the Advanced Translation Editor, but this time, the page will show up correctly.

Let us know if you have further issues with this, otherwise please mark this ticket as resolved and we will be happy to assist with any different issues on a new ticket.

October 3, 2019 at 9:53 am #4686633

yasuanQ

Hello!

yes! deleting the english pages and doing the translation again works! 🙂 But there are several pages that appears in work in progress, with that gear icon. Those ones don't appear in 'english pages section' so I don't know how can I delete them... If I go to the advanced translator I don't know how to delete the pages. May be will be better to install WPML again?

October 3, 2019 at 10:03 am #4686677

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

You can definitely "Reset" WPML but that would clear any work you have done in translating pages currently. As you may have noticed, when you delete a page and re-translate it, your translations are still there and you just have to click "Complete".

What I would suggest is that you click on the "gear icon" for each page, complete the translations for it if necessary, check all the "Translation is Complete" boxes and once the page is 100% translated, click "Save and Close". This will make the page appear in the English section.

Then you can check if the page is broken, and delete and re-translate it. This time, you will just need to click "Save and Close" since you already translated in the previous step 🙂

This will save you some time as opposed to resetting WPML. Please note that if you deactivate or uninstall WPML and reinstall it, it will not "reset" and you will be back where you started. Instead, you need to actually use WPML's reset feature:
https://wpml.org/faq/how-wpml-reset-works/

Please do let me know if you need further assistance with this issue!

October 3, 2019 at 11:20 am #4687113
yasuanQ

Hello,
I reset all and copied again the code in the custom xml tab; is working know, I translate each page and is working!
The only thing was different before and I don't know how I was doing it before is the permalink: now in english is shown like this:
hidden link

and before I had hidden link;

How can be this /en/ added?

Thank you very much!

New threads created by Izzi Hassan and linked to this one are listed below:

https://wpml.org/forums/topic/how-to-change-the-language-url-format/

October 3, 2019 at 12:28 pm #4687613

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I'm going to close this ticket since it's resolved. I've opened a new ticket for your other issue.

Please find instructions on changing the URL format here:
https://wpml.org/forums/topic/how-to-change-the-language-url-format/

October 4, 2019 at 9:13 am #4694365
yasuanQ

Helo Izzi,

everything is working ok with the code; but there is a section know that have not got the option to translate; is the section 'courses'; I have added the strings in "Strings in the plugins" but nothing appears 🙁
Could you help me? thank you!

New threads created by Izzi Hassan and linked to this one are listed below:

https://wpml.org/forums/topic/string-translation-is-not-working-13/

October 7, 2019 at 4:30 pm #4709349
yasuanQ

Hello,
I have one doubt about the code I added: when I update WPML plugin, this code will be deleted?
Thank you

New threads created by Izzi Hassan and linked to this one are listed below:

https://wpml.org/forums/topic/split-translated-pages-dont-appear-in-the-front-end/