Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Fabio Fava 1 year, 6 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
December 18, 2018 at 3:04 pm #3012716

Fabio Fava

I am trying to: translate pages built using Cornerstone Page Builder.

Link to a page where the issue can be seen: It's on the Admin Dashboard, no link.

I expected to see: Pages that I translete should appear as "Translated" at the Translation Management Dashboard.

Instead, I got: The icon of non-translated. I also keep receiving anoying mesages of overdue translations, but the page is translated to all languages and they're all working fine.

Cornerstone mostly have an issue and can't show the preview. This doesn't happen with non-WPML sites.

December 18, 2018 at 7:56 pm #3013702

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

December 20, 2018 at 6:31 pm #3022143

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, try the following to change the translations status of the 'soon' page:

1 - In your WordPress Dashboard > WPML > Settings > How to translate posts and pages temporary switch to the 'Use the Classic Translation Editor'.

2 - Click to edit the translations for your page in your WordPress Dashboard > Pages review those translations, check them as translation complete in case there's still some missing translations and click the save button. The idea is that you review those translations then click to publish it, in this case the save button in the translation editor.

I followed these steps for the portuguese translation of the 'soon' page, you will see it now appears as translated in your translation management screen.

Please, let me know if you need any additional instructions. Have a nice day.

December 20, 2018 at 7:26 pm #3022277

Fabio Fava

Hey Marcos Vinicios, thanks for your reply.

I've looked and only the Brazilian Portuguese Translation shows as "Translated", all others still show the "Waiting Translation (I assume) Icon". By the way, go there and translate/save the page "Not Found", just the Brazilian Portuguese Translation. Then automatically all translations of "Soon" go back to "Waiting Translation", no matter what.

On the other hand, every time I've attempted Classic Translation Editor or the New Translation Editor, the Layout of the translated pages was lost. I don't know how did you manage to use one of them and the page layout is teh same. But most of them still "Waiting Translation" on the WPML Translation Management (that seems to be very buggy).

Also, I keep receiving e-mails twice a day about those "Wainting Translation", that I've never put on the Translation Basket and are still anoying me every day. Is there a way to disable Translation Management and do it "All by myself" duplicating & translating using Cornerstone?

December 21, 2018 at 1:46 pm #3024958

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Regarding your further questions:

1 - "...I've looked and only the Brazilian Portuguese Translation shows as "Translated", all others still show the "Waiting Translation..."

I repeated the steps I made for the PT-BR language for the other languages too and you will notice it works properly, all the translatios appears as complete now in your WordPress Dashboard > WPML > Translation Management.

2 - "...By the way, go there and translate/save the page "Not Found", just the Brazilian Portuguese Translation. Then automatically all translations of "Soon" go back to "Waiting Translation", no matter what..."

I couldn't replicate this issue, I resaved the translation portuguese for the 'Not found' page and the translations for the 'Soon' page still appears as complete.

3 - "...On the other hand, every time I've attempted Classic Translation Editor or the New Translation Editor, the Layout of the translated pages was lost..."

There's indeed a layout issue for the secondary langauges when using the translation editor, You can try the following:

3.1 - In your WordPress Dashboard > Pages click to edit a translation of your page, translate it, make sure all the fields are checked as 'translation complete' and save it.

3.2 - Now, click to edit your original (default language) page, change to the language you edited in the step above (3.1) using the language switcher in the WordPress top admin bar, if you are prompted with a message click the 'edit anyway' button, now click the update button and you should be done. This step will make sure while your translation is preserved your layout settings is also refreshed, so we can have a page translated using the layout of the original page.

4 - "...Also, I keep receiving e-mails twice a day about those 'Wainting Translation'..."

I happened because the translation status of your pages. Once they all have the 'complete translation' status you should stop receiving these emails.

5 - "... Is there a way to disable Translation Management and do it "All by myself" duplicating & translating using Cornerstone?..."

It should be possible, but not the prefered way to translate the Cornestone page builder content as you can read here: https://wpml.org/documentation/theme-compatibility/xtheme/. If you want to go ahead then you should:

5.1 - Create your original page, build your content.

5.2 - Create a translation for this page.

5.3 - Edit this translation using the native WordPress editor, you can click to edit the original page, switch to your translation using the admin top bar language switcher and build your translated content using the page builder, exactly as you did with your original page. It should be basically create your original page, then recreate it in the secondary languages.

Please, let me know if you need any clarifications regarding the steps above. Have a nice day.

December 25, 2018 at 7:46 am #3031966

Fabio Fava

Hello Marcos,

I'm currently in vacations and I'll get back in a few days. Thank you for your patience.

December 29, 2018 at 3:49 pm #3042350

Fabio Fava

Hello Marcos Vinicios,

I've attempted the suggested steps on reply #3022143 (see below), and it doesn't work. The layout is lost, images not show, as yo can compare hidden link with hidden link one page is different from the other.

1 - In your WordPress Dashboard > WPML > Settings > How to translate posts and pages temporary switch to the 'Use the Classic Translation Editor'.

2 - Click to edit the translations for your page in your WordPress Dashboard > Pages review those translations, check them as translation complete in case there's still some missing translations and click the save button. The idea is that you review those translations then click to publish it, in this case the save button in the translation editor.

I've also attempted the same using the Advnced Editor, with different (but also bad) results). Just as I've said you before everything else. Absolutely, exactly, as it happened before.

I will try the method suggested on reply #3024958 and keep you informed if I can make it work.

Happy 2019 if I don't come back before 31st. Cheers!

January 7, 2019 at 4:59 pm #3063847

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I am back, when you are ready, please, let me know if the suggested methods above work for you. Have a nice day and happy new year!

January 11, 2019 at 9:27 pm #3082008

Fabio Fava

Hello Marcos Vinicios,

Actually the suggested way (using the Classic Post Editor) doesn't apply because the pages were created with the Cornerstone Visual Page Builder. The only way I could manage to have the exact same visual of the original and translated pages was duplicating the page for every language and editing the text contents. But then, I keep receiving the (extremely annoying) dailly message about due tranlations (that are done and working just fine). Really anti-productive.

I would need the Translation Management to understand that those pages have their Translations Complete, and let me go for the next pages. Can't I "reset" the Translation Management System and make it understand the pages translations are complete? Can't believe it doesn't.

Please let me know how to proceed to stop those daily e-mails (overdue translations).

January 15, 2019 at 12:58 am #3090174

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Actually, there's an option to reset the translation process and stop those messages at WordPress Dashboard > WPML > Support > Troubleshooting > Reset professional translation state. Please, let me know if this option works for you. Have a nice day.

January 15, 2019 at 9:25 pm #3094822

Fabio Fava

Hey Marcos Vinicios,

I've done what you said, and it just disconnects my site from Cloudwords. The messages are arriving anyway. Hope we can make my translations appear as "Translated" at some point.

Cheers.

January 17, 2019 at 7:30 pm #3103613

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I am escalating your ticket for our second level support, so they can give a further look and provide you with a defintive solution for your issue.

I would ask you to keep the previous access details working, so we can get logged in case we need to perform some additional test or take a closer look into the settings. I will keep you update on the issue resolution. Thank you for your patience and understanding. Have a nice day.

January 22, 2019 at 12:51 am #3114391

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your patience while waiting for a solution. Can you please, make sure to provide working WordPress access details untill we have your issue sorted? I tried to log in to try the approaches mentioned by the second level support, however the previous provided access don't seem to be still working. Thank you for your continued patience and collaboration, have a nice day.

January 22, 2019 at 8:56 am #3115193

Fabio Fava

Hi there,

The previous Staging Environment was restablished - hidden link - with a fresh copy of the original. The Access Credentials stills the same for WPML.

Please let me know as you find a solution, cheers.

January 23, 2019 at 5:59 pm #3121968

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your patience while waiting for a solution. Regarding your issues, please, proceed this way:

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

1 - Update all the WPML related plugins from your WordPress Dashboard > Plugins menu to their latest versions, to leverage the latest improvements and bug fixes.

2 - Go to your pages where you still see them as pending translation status and resave their translations in order to make them with the complete translation option.

3 - Now, go to your WordPress Dashboard > WPML > Settings > Translation Notifications tab and adjust its settings to match your needs.

Please, let me know if the steps above work for you. Have a nice day.