This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Mihai Apetrei 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
September 26, 2018 at 2:16 pm

Tim Müller

I am trying to:
View the pages that have been translated from English to German.
Link to a page where the issue can be seen: hidden link (Select DE and you will see nothing is displayed. It is translated on the backend.

I expected to see: The page translated to German. The page displaying the exact same way as the English page

Instead, I got: No content displaying

September 27, 2018 at 2:38 pm #2770888

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I tried to log into your site's backend but the WP credentials do not work.

Can you please verify them once again and make sure they are accurate?

I am also enabling right now the private field once again.

Thank you!

September 28, 2018 at 2:16 pm
October 1, 2018 at 11:38 am #2777849

Tim Müller

Hi Mihai

Have you had any success logging into the site? Any idea why I am having this problem?

October 1, 2018 at 2:09 pm #2778385

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I was able to look into your site's backend and I see that you currently have the Advanced Translation Editor selected as your default translation editor but it has not been activated yet. I will attach a screenshot, too, with the error that I see in the backend, under WPML > Settings.

I also looked at the page you translated and I can see it was translated with the Advanced Translation Editor.

Here you can find more information about this editor:
https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

You can either activate that or choose the Classic Translation Editor if you don't really need the functionality that comes with the Advanced version.

Here is also some helpful documentation regarding the Standard WPML editor:
https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

Please let me know if this solved the issue or if you still need help.

October 1, 2018 at 2:55 pm #2778564

Tim Müller

Hi there,

I have changed to the classic translation editor but am still having the same problem. The problem is specifically visiable with my German content. (The english and GB content is the same). I suspect that the problem may be that the page builder content is not being pulled through from the page as I can't see anything on the page but on the backend it is 100% translated.

To test this, please look specifically at the "company > contact us" and "company > about us", "support > customer service" sections. These have been translated to German on the backend but on the front end nothing is showing up.

I have also contacted the theme to see if they have a solution. I look forward to hearing back from you.

Warm regards

October 2, 2018 at 12:17 pm #2781358

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

After some deeper analyzation, I found out that your theme is using the Unyson content builder.

Unyson is not in our compatibility list (so what might be causing this issue is that a specific shortcode is not translatable), however, this doesn't necessarily imply that it is not compatible with WPML.

There are 2 procedures we can try (starting the translation using the "duplication" method and using the manual translation method) and I will explain more about each of the two options below.

STEP1

The first thing we can try won't require any change in the WPML settings and that is to test the translation of one of the EN pages into another language by using the "Duplicate" feature when translating.

This means that you can go into the editor of the page/post you want to translate, use the "Duplicate" checkbox that you find on the right and try to translate the page (I will also attach a screenshot that might help).

STEP 2

The second thing we can go with is manual translation and will also require changes in the WPML settings.

Here you can find some great documentation regarding this process:
https://wpml.org/documentation/translating-your-contents/page-builders/translating-content-created-with-page-builders-using-manual-translation/

If the first one won't work, the second one should do the job.

Please let me know if any of these options solved your issue or if you still need help.