Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by francoisB 5 years, 10 months ago.

Assigned support staff: Andreas Neuber.

Author Posts
March 13, 2014 at 6:22 am #358050

francoisB

This is the problem.

I create a page in English (default language) - then when I want to create a translation in French I click on the + translate button and get to the French page where I do my edits BUT when I save the page and look at everything:

The English page keeps having the + translate button for French and keeps on offering to translate the page on and on no matter what I do - Even though I know for a fact that the translation is there.

When I try to even find the original in Translation management - it cannot be found

If I look at admin/pages/all pages - the page is there and the translation as well but when I select the English page - still the same - offering to translate the page.

I did notice a link that says: "Link with translations" but I then get an error message: no posts found

Any idea?

All my plugins are up to date for WPLM

I use:

WPML CMS Nav - not activated - Version 1.4.2

WPML Media - activated - Version 1.6

WPML Multilingual CMS - activated - Version 3.1.4

WPML Sticky Links - activated - Version 1.3.2

WPML Translation Management - activated - Version 1.9.3

And this is from the troubleshooting page:

Array
(
[hide_upgrade_notice] => 2.9.2
[interview_translators] => 1
[existing_content_language_verified] => 1
[language_negotiation_type] => 1
[theme_localization_type] => 2
[icl_lso_header] => 0
[icl_lso_link_empty] => 0
[icl_lso_flags] => 1
[icl_lso_native_lang] => 1
[icl_lso_display_lang] => 0
[sync_page_ordering] => 1
[sync_page_parent] => 1
[sync_page_template] => 1
[sync_ping_status] => 1
[sync_comment_status] => 1
[sync_sticky_flag] => 1
[sync_private_flag] => 1
[sync_post_format] => 1
[sync_delete] => 0
[sync_delete_tax] => 0
[sync_post_taxonomies] => 1
[sync_post_date] => 0
[sync_taxonomy_parents] => 0
[translation_pickup_method] => 0
[notify_complete] => 1
[translated_document_status] => 1
[remote_management] => 0
[auto_adjust_ids] => 1
[alert_delay] => 0
[promote_wpml] => 0
[troubleshooting_options] => Array
(
[http_communication] => 1
)

[automatic_redirect] => 1
[remember_language] => 48
[icl_lang_sel_type] => list
[icl_lang_sel_stype] => classic
[icl_lang_sel_orientation] => vertical
[icl_lang_sel_copy_parameters] =>
[icl_widget_title_show] => 0
[translated_document_page_url] => auto-generate
[sync_comments_on_duplicates ] => 0
[seo] => Array
(
[head_langs] => 1
[canonicalization_duplicates] => 1
)

[posts_slug_translation] => Array
(
[on] => 0
)

[languages_order] => Array
(
[0] => en
)

[urls] => Array
(
[directory_for_default_language] => 0
[show_on_root] => page
[root_html_file_path] =>
[root_page] => 166
[hide_language_switchers] => 0
)

[admin_default_language] => en
[ajx_health_checked] => 1
[setup_wizard_step] => 3
[default_categories] => Array
(
[en] => 113
[fr] => 114
[de] => 115
)

[default_language] => en
[dont_show_help_admin_notice] => 1
[icl_lang_sel_config] => Array
(
[font-current-normal] => #444444
[font-current-hover] => #000000
[background-current-normal] => #ffffff
[background-current-hover] => #eeeeee
[font-other-normal] => #444444
[font-other-hover] => #000000
[background-other-normal] => #ffffff
[background-other-hover] => #eeeeee
[border] => #cdcdcd
)

[icl_lang_sel_footer_config] => Array
(
[font-current-normal] => #444444
[font-current-hover] => #000000
[background-current-normal] => #ffffff
[background-current-hover] => #eeeeee
[font-other-normal] => #444444
[font-other-hover] => #000000
[background-other-normal] => #ffffff
[background-other-hover] => #eeeeee
[border] => #cdcdcd
[background] => #ffffff
)

[icl_language_switcher_sidebar] => 0
[icl_lang_sel_footer] => 1
[icl_post_availability] => 0
[icl_post_availability_position] => below
[icl_post_availability_text] => This post is also available in: %s
[language_selector_initialized] => 1
[translation-management] => Array
(
[notification] => Array
(
[new-job] => 1
[completed] => 1
[resigned] => 1
[dashboard] => 1
[purge-old] => 7
)

[custom_fields_translation] => Array
(
[title] => 2
[description] => 2
[keywords] => 2
[_yoast_wpseo_title] => 2
[_yoast_wpseo_bctitle] => 2
[_yoast_wpseo_metadesc] => 2
[_yoast_wpseo_metakeywords] => 2
[_yoast_wpseo_focuskw] => 2
[_yoast_wpseo_meta-robots-noindex] => 1
[_yoast_wpseo_meta-robots-nofollow] => 1
[_yoast_wpseo_meta-robots-adv] => 1
[_yoast_wpseo_canonical] => 0
[_yoast_wpseo_redirect] => 0
[_cms_nav_minihome] => 1
[_cms_nav_section] => 2
[_top_nav_excluded] => 1
[_aioseop_title] => 2
[_aioseop_description] => 2
[_aioseop_keywords] => 2
[_yoast_wpseo_linkdex] => 0
[_yoast_wpseo_sitemap-include] => 0
[_yoast_wpseo_sitemap-prio] => 0
[_yoast_wpseo_sitemap-html-include] => 0
[_yoast_wpseo_opengraph-description] => 2
[_yoast_wpseo_google-plus-description] => 2
[_post_restored_from] => 0
[vsw_pmvw_video_source] => 0
[vsw_pmvw_video_id] => 0
[vsw_pmvw_video_width] => 0
[vsw_pmvw_video_height] => 0
[vsw_pmvw_video_caption] => 0
[vsw_pmvw_video_autoplay] => 0
[_cs_replacements] => 0
[bwps_enable_ssl] => 0
[enablewpts] => 0
[_revision-control] => 0
[_yoast_wpseo_opengraph-image] => 0
)

[doc_translation_method] => 0
[__custom_types_readonly_config_prev] => Array
(
)

[custom_types_readonly_config] => Array
(
)

[__custom_fields_readonly_config_prev] => Array
(
[0] => title
[1] => description
[2] => keywords
[3] => _yoast_wpseo_title
[4] => _yoast_wpseo_bctitle
[5] => _yoast_wpseo_metadesc
[6] => _yoast_wpseo_metakeywords
[7] => _yoast_wpseo_focuskw
[8] => _yoast_wpseo_meta-robots-noindex
[9] => _yoast_wpseo_meta-robots-nofollow
[10] => _yoast_wpseo_meta-robots-adv
[11] => _yoast_wpseo_canonical
[12] => _yoast_wpseo_redirect
[13] => _cms_nav_minihome
[14] => _cms_nav_section
[15] => _top_nav_excluded
)

[custom_fields_readonly_config] => Array
(
[0] => title
[1] => description
[2] => keywords
[3] => _yoast_wpseo_title
[4] => _yoast_wpseo_bctitle
[5] => _yoast_wpseo_metadesc
[6] => _yoast_wpseo_metakeywords
[7] => _yoast_wpseo_focuskw
[8] => _yoast_wpseo_meta-robots-noindex
[9] => _yoast_wpseo_meta-robots-nofollow
[10] => _yoast_wpseo_meta-robots-adv
[11] => _yoast_wpseo_canonical
[12] => _yoast_wpseo_redirect
[13] => _yoast_wpseo_opengraph-description
[14] => _yoast_wpseo_google-plus-description
[15] => _cms_nav_minihome
[16] => _cms_nav_section
[17] => _top_nav_excluded
)

)

[setup_complete] => 1
[icl_additional_css] =>
[display_ls_in_menu] => 1
[menu_for_ls] => 2
[hide_how_to_translate] => 1
[icl_disable_reminders] => 0
[icl_notify_complete] => 0
[sync_comments_on_duplicates] => 0
[custom_posts_sync_option] => Array
(
[jobman_job] => 1
[jobman_joblist] => 0
[jobman_app_form] => 0
[jobman_app] => 0
[jobman_register] => 0
[jobman_email] => 0
[jobman_interview] => 0
[ml-slider] => 0
[attachment] => 0
[ditty_news_ticker] => 1
)

[taxonomies_sync_option] => Array
(
[jobman_category] => 0
[ml-slider] => 0
)

[hide_professional_translation_controls] => 1
[theme_localization_load_textdomain] => 0
[gettext_theme_domain_name] =>
[theme_language_folders] => Array
(
[parent] => /home/eurodive/public_html/wp-content/themes/gconverter/languages
)

[show_translations_flag] => 1
[show_untranslated_blog_posts] => 1
[icl_capabilities_verified] => 1
[just_reactivated] => 0
)

March 13, 2014 at 1:48 pm #358463

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Francois,

Sorry for the delay and thanks for the detailed version / config information!

Honestly, if I wouldn't see that you are using WPML 3.1.4 I would have told you to update.
Because we fixed recently a bug which fits exactly your description.

# Would you mind providing us with credentials for your website and we have a closer look at the settings? For this purpose you should see a protected webform all they way down here in this thread. (it asks first for "Backup + Legal disclaimer")

# Also, please mention again the page name for our developers to check

Thanks in advance!

March 14, 2014 at 3:09 am #358779

francoisB

Hello Andreas,

I created a draft for" test wplm en" and "test wplm fr" where you can see if you try to edit test wplm en it still offers to + french

And this is very strange: If you look at the Contact page - I did that yesterday and this morning it seems to work.

The only thing I cannot get to work is YOAST to expand on a page. It only does on Opera browser - but I think this might be a different problem.

Thank you for your help,

March 14, 2014 at 3:12 am #358780

francoisB

I just realize that I put up the credentials for all to see - so deleted - please contact me for the new one.

Thanks

March 14, 2014 at 10:48 am #359060

francoisB

Hello Andreas,

Sorry but I still need help on this.

Can you please send me another form so that I can send you the new login details so you can have a look.

Thank for your help.

March 14, 2014 at 12:53 pm #359204

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello francois,

Sorry for the delay on my end..
I think as an exception I better give you my email - andreas.n@onthegosystems.com

March 15, 2014 at 2:38 am #359581

francoisB

Greetings Andreas,

It could be that we are not in the same time zone, no problem for the delay.

I have sent you more information at the address you provided.

Thank you

March 17, 2014 at 8:37 am #360328

francoisB

I still need assistance - I really do

March 17, 2014 at 11:54 am #360522

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Francois,

Thanks for the credentials of the other site!

Regarding page "test wpml en":
This page works as expected, correct? The FR translation was added and we see a pencil - not a blue cross.
Shall I check another page?

March 18, 2014 at 4:02 am #361152

francoisB

Hello Andreas - I just created a page in English and French in drafts. Please look at this:

This is what is (still) happening:

Go to: dashboard/pages/all pages : yes, you see the pencil under the french flag - BUT as I explained:

Now simply click on the "18 march test wplm" (the original, English) and you will see that from there it still offers to + French

This is what I see: hidden link

March 18, 2014 at 9:47 am #361386

francoisB

Hello Andreas,

Please note that the credentials I sent you by email are for the LIVE website - if you need to have me re-do the test site I will.

March 19, 2014 at 3:28 am #362118

francoisB

I still need assistance – I really do (really)

March 19, 2014 at 10:52 am #362440

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Francois,

Got your email - thanks!
Sorry last 2 days I lost quite some time with difficult tickets where WPML settings were corrupted but will check your site as next now.

March 20, 2014 at 4:59 am #363170

francoisB

Hello Andreas,

I received a notice from my hosting company informing me that there was an emergency unscheduled maintenance of the server - I am happy to inform you that at the moment everything seems to be working as it should so I will close this ticket and come back to you if something happens as I start looking through everything.