This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Riffaz 1 year ago.

Assigned support staff: Riffaz.

Author Posts
October 11, 2018 at 6:56 am

didacG

I am trying to:
Switch to another language, but page does not load.

Link to a page where the issue can be seen:
All pages, just try switching to Spanish for instance.

I expected to see:
A translated page.

Instead, I got:
A timeout error.

I cannot create the duplicator package right now; but feel free to login.

October 11, 2018 at 4:12 pm #2809090

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I see your Spanish pages load fine in my side: hidden link

But, you may experience the issue you mentioned more often because your server PHP time limit is just 0 : hidden link
Please contact your hosting provider and ask them to increase it as much as you can.

And, you have many plugins. Your PHP Max Input Vars is not enough for all these plugins and site to run smoothly.
Even your current theme requires 4 times than you have now: hidden link
Please increase it as well.

Your site console has these errors: hidden link
Disable your plugins one by one and check which plugin causes this and correct it or contact the respective plugin support.

Also, it's better you have all your plugins, theme and core WordPress to update.
You have 11 update notifications as well.

So, obviously the WPML works fine but it is not always because of your server configurations and by other plugins.
Correct them all. Your WPML second language pages will work fine without any issue.

Before proceeding any of these please make a whole backup of our site and database.
It's always a good practice.

Let me know.

Regards,
Riffaz.

The topic ‘[Closed] Translated pages not loading’ is closed to new replies.