This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

The My Listing theme by 27collective is not showing the same selected theme options on the translated pages.

Solution:

This theme is not in our compatibility list here https://wpml.org/documentation/theme-compatibility/.

You can set the same setting on the other languages by switching the Language Switcher at the top admin bar to the other language and set the same options and save.

This topic contains 5 replies, has 2 voices.

Last updated by samanthaT 12 months ago.

Assigned support staff: Itamar.

Author Posts
October 8, 2018 at 7:21 pm #2797168

samanthaT

I am trying to: Get the headers of the translated pages to look the exact same on all languages.

Link to a page where the issue can be seen:
English (correct header): hidden link
Arabic (incorrect header): hidden link

I expected to see: The header on the translated (Arabic) page look the same as it does on the default (English) page.

Instead, I got: The Arabic page header is black instead of purple, it's not pulling in the logo and it is doing RTL instead of LTR.

I need to be able to change it so that the header stays LTR on all languages. As well it should be pulling in the color, logo, settings from the theme for the default page.

Thanks!

October 9, 2018 at 6:47 pm #2801582

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see the color and logo issue on the header part of your site. But I do not understand what is wrong with the direction. You said that you want it to be RTL and by inspecting the header element in the browser I can see that it is set to RTL.

Those are issues that are related to your theme and its ability to adjust to RTL languages and not so much a WPML issue. Nevertheless, I'll try to continue and help you with those issues.
Could you please let me have access to your site and explain to me where did you set the color of the header and where did you upload the logo?

If you need further help with this, please share the access details to your site with me or share with me a copy of your site. I'm enabling private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

October 10, 2018 at 7:58 pm #2805656

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

I've checked your site to find a solution to those issues.
A. I've managed to add the logo to the Arabic header.
I've done it by going to the theme options screen and switching the Language Switcher at the top admin bar to Arabic. Then I saw that none of the settings are set there. So I've copied the settings from the English theme options page. Please see the attached screenshot theme-op.jpg I've also run the media options in WPML -> Settings -> Media translation. Please see the attached screenshot media-op.jpg This way I could load the logo also on the Arabic page because it was missing from the Arabic media library. Now the logo is also showing on the Arabic page. Please see the attached screenshot logo-ar.jpg

B. Although that I've copied the options from the English settings the background color of the Arabic header is not the same as the English. The reason for that is unclear to me.

I think that the issue here is the theme that you are using, the My Listing theme by 27collective. This theme is not in our compatibility list here https://wpml.org/documentation/theme-compatibility/. Not being on this list does not mean that it is not compatible it just means we do not know yet if it is. But as it looks now, there are some compatibility issues. To check these issues further, we need to test the issue on a clean WordPress installation. For this, I created a test website. You can access it through this link: hidden link - Through this link, you will be automatically logged in. If nobody logs in the test site will be available for one week from today.
Could you please install the My Listing theme on this test site?
Please configures WPML to the default language that is configured on your site (English) and add Arabic as the second language.
Please also make sure that you are installing the latest version of the theme.

Then I'll be able to see if the problems are also occurring on a clean WordPress installation a and if needed consult our compatibility team about those issues.

Thanks,
Itamar.

October 17, 2018 at 5:44 pm #2825550
samanthaT

Thank you!

I have uploaded the clean install to the test site.

In addition, another thing, if I could have you check into is it doesn't look like it's connecting up with the Explore page (which is a directory page of all the business listings).

hidden link
hidden link

October 18, 2018 at 7:22 pm #2829334

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thank you for installing the theme on the test site.

When I set the header background color in the theme options to a certain color and then switch the admin language into Arabic and set the same color, it is showing the same color on the front-end.
English: hidden link
Arabic: hidden link
But when I check your site now, I can see that the issue is also solved on your site.
The background color of the header is the same.
English: hidden link
Arabic: hidden link
Have you fixed this issue already?
If so can you please mark this ticket as resolved?
I'll split this ticket to a new ticket with the other issue that you have.

Regards,
Itamar.

October 18, 2018 at 7:47 pm #2829422

samanthaT

Thank you for your help! I was able to get it fixed on mine after you pointed me in the right direction.