Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Marcel 4 months ago.

Assigned support staff: Marcel.

Author Posts
July 24, 2019 at 10:05 am

peterA-35

I am trying to: Access a translated page

Link to a page where the issue can be seen:

I expected to see: translated pages from English to Turkish which appear to have been translated according to the Translations Page.

Instead, I got:When I look for pages in Turkish there appear to be none

July 24, 2019 at 10:10 am
July 24, 2019 at 10:20 am #4273063

peterA-35

Not sure what happened here, I still have the problem. Thanks and Kind Regards

July 25, 2019 at 1:05 pm #4283353

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Peter,

I checked now your site and finished the translation of the "Contact us" page. I was able to see that after saving the translation, it changed the pencil icon again to “+”.

Can you confirm this, please? Do you may have a Staging/Testing environment where I can make further tests (Debugging, deactivating plugins.)

Please let me know.
Best Marcel

July 25, 2019 at 5:39 pm #4285395

peterA-35

Hi Marcel,

The translation process itself seems to work fine and it would appear that the translation is finished but when I come out of the translations dashboard the translated page cannot be found. You are welcome to use the environment itself for debugging. I have it fully backed up and the site is in the very early stages of going public. Please go ahead in the environment I have given you.

Thanks and Kind Regards,
Peter

July 26, 2019 at 1:09 pm #4289773

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Peter,

Thank you. I did some test and was able to get a PHP log. I consulted our 2nd Tier for an opinion about your case. I will update you ASAP as I receive feedback.

Best Marcel

July 29, 2019 at 4:16 pm #4301823

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Peter,

I duplicated the Contact us page using your installed "Duplicate Post" plugin. Now it seems to be working. Can you please check this and confirm it?

Best Marcel

July 30, 2019 at 7:23 am #4305217

peterA-35

Marcel,

I can confirm that there is a contact page showing under the Turkish flag menu dropdown. However it is not in Turkish but I am reluctant to do anything at all at the moment because I suspect you are still in the troubleshooting process.

There are plenty of pages showing in the translations dashboard that show as being translated but are not appearing when you look for Turkish pages. I assume you know this?

Also the site crashed due to an WPML error yesterday. I attach a screenshot.

Thanks you for your help in this matter, this seems to be a tricky problem, not sure why, my last site was a piece of cake, no problems at all.

Thanks and Kind Regards
Peter

July 30, 2019 at 9:23 am #4306081

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Peter,

yes, I also got the error, but it was gone when I removed the affected page. I think there was a conflict with the slug, as your contact page was using as slug an additional -3 like contact-us-3, which WP adds when a site is in use.

The Contact page self is in Turkish, as I duplicated the post: hidden link

Which other pages are affected? I checked some of them, but they where not finished translated.

Please let me know
Best Marcel

July 30, 2019 at 1:34 pm #4308031

peterA-35

Marcel,

If you look in the translations dashboard it would appear that many pages have been translated and this is so because I though I had translated them. However if you go into Pages on the main dashboard and look for Turkish Pages there is only one and that is the Contact Page which you achieved by duplicating it (so you told me).

So to my mind there is something fundamentally wrong here with the way WPML is working ie I translate a page, the translation management process says its been done and delivered, the translations dashboard is showing it as complete but I cannot find any of them.

If you look at the translations dashboard I think you will see what I mean. Just two examples which should have been a very straightforward translation are Homepage and HOLIDAY SERVICES on page 2 of the translations dashboard.

Thanks and Kind Regards
Peter

July 30, 2019 at 4:21 pm #4309627

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Thanks, Peter,

Yes, over the Translation Management Dashboard I see 9 Turkish pages, on Pages -> All Pages I see 7, in the translation selection I see "Turkish (9)".

I manually translated another page without any PHP error. But yes, it's not normal that the "+" icon is not changing to the pencil icon. We need to deeper analyze this.

I will let you know once I found something.

Best Marcel

July 31, 2019 at 9:17 am #4313245

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

(Internal Status change)

August 1, 2019 at 6:03 am #4318955

peterA-35

Can you please tell me what this message means.

I am now getting pretty desperate to get the translations working. It has been some weeks now since I started having problems (different tickets)

I would be most grateful for an early resolution.

Thank you for your continuing help and Kind Regards,
Peter

August 2, 2019 at 3:47 pm #4331281

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Peter,

it was only a status change that the ticket is marked as escalated to 2nd Tier.

I was not able to reproduce the error anymore that it's stuck with the "+" icon nor the PHP error. I tested it also with a site copy and a minimal environment on our Cloudways server.

Anyway, something is wrong on your page, and until we found the root problem I would recommend you to finish the translation manually using the above-mentioned method with the Duplicate post plugin. I was also able to make the "Homepage" viewable using this method on your site. It's not showing "Not found" anymore, but it's still missing under Pages -> All Pages .

Please also finish the translations showing the gearwheel icon with 100% that the icon is changing to the pencil.

Please let me know ho's going. I will update you ASAP when I get feedback.

Best Marcel

August 6, 2019 at 8:48 am #4345487

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi Peter,

I checked your pending translation jobs, and there were many duplicated, open jobs (like 2x Homepage). I finished all of them and redelivered the unfinished translations, so everything is now updated to the pencil icon.

Please open now all Turkish pages and finish the translations. Some notes:

- The pages like "Homepage" and "Holiday Services" were saved as Draft, so the Turkish language flag never appeared on the Frontend.
- The homepage was not missing on Pages -> All pages. The title is changed to Turkish (Ana sayfa — Front Page)
- Dashboard - Add Agent was duplicated with the same title but different permalink. I removed the empty copy.

I never got any PHP error while translating them. Now it looks OK.

Please let me know
Best Marcel