This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by jaydenA 1 year, 2 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 1, 2019 at 3:33 am #3715831



We have a single page website, we translated the pages into 5 languages and they work fine.
I did this by going into 'translation management' selecting the page and doing the 'duplicate content' option for the 5 languages. Then we went into each individual page and added out translations; clicking save would prompt the: "this is a duplicate page, adding new content will make it separate" or whatever message comes up which is fine. We saved a few times and made more additions and what not and it was all working fine.

However we have noticed that a few hours after, the translations for 3/5 languages reverted back to english. We looked under revisions and could see that around 3 hours after it would change everything back to blank and this would subsequently make the post a 'duplicate' page of the english version again. The gravity form on the page was unaffected.
So we reverted back to the finished version from the revision option and clicked save which brought up the "This is a duplicate, adding new content..." again, but got it back to normal.
This has happened twice so far.

It looks like it's reverting the page translations back to duplicates of the english rather than keeping them as separate ones.

Any help would be awesome,

Thank you!

May 1, 2019 at 7:31 am #3716663

Raja Mohammed

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue.

What you have explained is strange behavior, To make sure I understood the issue. You have duplicated the page to the second language and using Translate Independent option you have updated the translation but the translation reverts back to English content. Is that correct?

This needs to be debugged, Please check if you can reproduce the issue with just the WPML plugins active. If the issue still persists, please create a snapshot of your site and share the link with us. You can use the Duplicator plugin to create a snapshot of the site and share the package link with me I have enabled the private fields for you to share the details.

Kind regards

May 6, 2019 at 11:41 pm #3752879


The issue hasn't occurred again, if it happens again i'll let you know but either way it should be fine for now, thank you for your assistance.