Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by Gerard 7 years, 7 months ago.

Assigned support staff: Dat Hoang.

Author Posts
April 7, 2014 at 11:20 am #375219

Gerard

Dear Sirs,

Since days we are trying to figure out the problem we face: every translated page leads to a 404 error message. The URLs show correctly (as far as we can judge it).

For your easier reference, we have added some screenshots.

We have also re-set the perma links (common settings & product permalink base) to default and back to the current settings (post name & Shop base with category) again but we did not achieve any improvement.

What we have noted is the following;
Product permalink base
We try to set "Shop base with category" to "hidden link"
The setting however will change automatically to:"Custom Base" > "shop/%product_cat%"

Note:
1) translations are done and setting to "completed"
2) "Product category base" is set to "product-category"

We have also re-set the perma links (common settings & product permalink base) to default and back to the current settings (post name & Shop base with category) again but we did not achieve any improvement.

We have followed many (good!!) further advices by WPML given but they do not work for us. Here below we show you the information we took from the WPML troubleshooting page;

Array
(
[hide_upgrade_notice] => 2.7.1
[interview_translators] => 1
[existing_content_language_verified] => 1
[language_negotiation_type] => 1
[theme_localization_type] => 1
[icl_lso_header] => 0
[icl_lso_link_empty] => 0
[icl_lso_flags] => 0
[icl_lso_native_lang] => 1
[icl_lso_display_lang] => 1
[sync_page_ordering] => 1
[sync_page_parent] => 1
[sync_page_template] => 1
[sync_ping_status] => 1
[sync_comment_status] => 1
[sync_sticky_flag] => 1
[sync_private_flag] => 1
[sync_post_format] => 1
[sync_delete] => 0
[sync_delete_tax] => 1
[sync_post_taxonomies] => 1
[sync_post_date] => 0
[sync_taxonomy_parents] => 0
[translation_pickup_method] => 0
[notify_complete] => 1
[translated_document_status] => 1
[remote_management] => 0
[auto_adjust_ids] => 1
[alert_delay] => 0
[promote_wpml] => 0
[troubleshooting_options] => Array
(
[http_communication] => 1
)

[automatic_redirect] => 0
[remember_language] => 24
[icl_lang_sel_type] => dropdown
[icl_widget_title_show] => 0
[translated_document_page_url] => auto-generate
[sync_comments_on_duplicates ] => 0
[seo] => Array
(
[head_langs] => 1
[canonicalization_duplicates] => 1
)

[posts_slug_translation] => Array
(
[on] => 1
[types] => Array
(
[product] => 1
[attachment] => 0
)

)

[admin_default_language] => en
[ajx_health_checked] => 1
[dont_show_help_admin_notice] => 1
[setup_wizard_step] => 3
[default_categories] => Array
(
[en] => 1
[fr] => 29
[de] => 30
[it] => 31
)

[default_language] => de
[icl_lang_sel_config] => Array
(
[font-current-normal] => #444444
[font-current-hover] => #000000
[background-current-normal] => #ffffff
[background-current-hover] => #eeeeee
[font-other-normal] => #444444
[font-other-hover] => #000000
[background-other-normal] => #ffffff
[background-other-hover] => #eeeeee
[border] => #cdcdcd
)

[icl_lang_sel_footer_config] => Array
(
[font-current-normal] => #444444
[font-current-hover] => #000000
[background-current-normal] => #ffffff
[background-current-hover] => #eeeeee
[font-other-normal] => #444444
[font-other-hover] => #000000
[background-other-normal] => #ffffff
[background-other-hover] => #eeeeee
[border] => #cdcdcd
[background] => #ffffff
)

[icl_language_switcher_sidebar] => 0
[icl_lang_sel_footer] => 0
[icl_post_availability] => 0
[icl_post_availability_position] => below
[icl_post_availability_text] => This page/post is also available in: %s
[language_selector_initialized] => 1
[translation-management] => Array
(
[notification] => Array
(
[new-job] => 1
[completed] => 1
[resigned] => 1
[dashboard] => 1
[purge-old] => 7
)

[custom_fields_translation] => Array
(
[_product_attributes] => 2
[_product_image_gallery] => 2
[title] => 2
[description] => 2
[keywords] => 2
[_backorders] => 1
[_crosssell_ids] => 1
[_default_attributes] => 1
[_download_limit] => 1
[_downloadable] => 1
[_featured] => 1
[_file_path] => 1
[_manage_stock] => 1
[_sale_price_dates_from] => 1
[_sale_price_dates_to] => 1
[_sku] => 1
[_stock] => 1
[_stock_status] => 1
[_sold_individually] => 1
[_subscription_length] => 1
[_subscription_period] => 1
[_subscription_period_interval] => 1
[_subscription_price] => 1
[_subscription_sign_up_fee] => 1
[_subscription_trial_length] => 1
[_subscription_trial_period] => 1
[_tax_class] => 1
[_tax_status] => 1
[_upsell_ids] => 1
[_virtual] => 1
[_visibility] => 1
[_weight] => 1
[_width] => 1
[_height] => 1
[_length] => 1
[_woocommerce_exclude_image] => 1
[total_sales] => 1
[_product_url] => 2
[_button_text] => 2
[_purchase_note] => 2
[_override_tab_layout] => 1
[_product_tabs] => 2
[_wcml_custom_prices_status] => 0
[_yoast_wpseo_title] => 2
[_yoast_wpseo_bctitle] => 2
[_yoast_wpseo_metadesc] => 2
[_yoast_wpseo_metakeywords] => 2
[_yoast_wpseo_focuskw] => 2
[_yoast_wpseo_meta-robots-noindex] => 1
[_yoast_wpseo_meta-robots-nofollow] => 1
[_yoast_wpseo_meta-robots-adv] => 1
[_yoast_wpseo_canonical] => 0
[_yoast_wpseo_redirect] => 0
[_cms_nav_minihome] => 1
[_cms_nav_section] => 2
[_top_nav_excluded] => 1
[_regular_price] => 1
[_sale_price] => 1
[_price] => 1
[_min_variation_regular_price] => 1
[_min_variation_sale_price] => 1
[_min_variation_price] => 1
[_max_variation_regular_price] => 1
[_max_variation_sale_price] => 1
[_max_variation_price] => 1
[_wcml_schedule] => 1
[backorders] => 1
[downloadable] => 1
[featured] => 1
[price] => 1
[product_attributes] => 1
[regular_price] => 1
[sale_price] => 1
[sale_price_dates_from] => 1
[sale_price_dates_to] => 1
[seo_description] => 1
[seo_follow] => 1
[seo_keywords] => 1
[sku] => 1
[stock] => 1
[stock_status] => 1
[manage_stock] => 1
[tax_classes] => 1
[tax_status] => 1
[virtual] => 1
[visibility] => 1
[weight] => 1
[width] => 1
[length] => 1
[height] => 1
[_yoast_wpseo_opengraph-description] => 2
[_yoast_wpseo_google-plus-description] => 2
)

[doc_translation_method] => 0
[__custom_types_readonly_config_prev] => Array
(
[product] => 1
[product_variation] => 0
[shop_coupon] => 0
[shop_order] => 0
[wc_product_tab] => 1
[attachment] => 1
)

[custom_types_readonly_config] => Array
(
[product] => 1
[product_variation] => 0
[shop_coupon] => 0
[shop_order] => 0
[wc_product_tab] => 1
[attachment] => 1
)

[__custom_fields_readonly_config_prev] => Array
(
[0] => title
[1] => description
[2] => keywords
[3] => _backorders
[4] => _crosssell_ids
[5] => _default_attributes
[6] => _download_limit
[7] => _downloadable
[8] => _featured
[9] => _file_path
[10] => _manage_stock
[11] => _sale_price_dates_from
[12] => _sale_price_dates_to
[13] => _sku
[14] => _stock
[15] => _stock_status
[16] => _sold_individually
[17] => _subscription_length
[18] => _subscription_period
[19] => _subscription_period_interval
[20] => _subscription_price
[21] => _subscription_sign_up_fee
[22] => _subscription_trial_length
[23] => _subscription_trial_period
[24] => _tax_class
[25] => _tax_status
[26] => _upsell_ids
[27] => _virtual
[28] => _visibility
[29] => _weight
[30] => _width
[31] => _height
[32] => _length
[33] => _woocommerce_exclude_image
[34] => total_sales
[35] => _product_url
[36] => _button_text
[37] => _purchase_note
[38] => _override_tab_layout
[39] => _product_tabs
[40] => _wcml_custom_prices_status
[41] => _yoast_wpseo_title
[42] => _yoast_wpseo_bctitle
[43] => _yoast_wpseo_metadesc
[44] => _yoast_wpseo_metakeywords
[45] => _yoast_wpseo_focuskw
[46] => _yoast_wpseo_meta-robots-noindex
[47] => _yoast_wpseo_meta-robots-nofollow
[48] => _yoast_wpseo_meta-robots-adv
[49] => _yoast_wpseo_canonical
[50] => _yoast_wpseo_redirect
[51] => _yoast_wpseo_opengraph-description
[52] => _yoast_wpseo_google-plus-description
[53] => _cms_nav_minihome
[54] => _cms_nav_section
[55] => _top_nav_excluded
)

[custom_fields_readonly_config] => Array
(
[0] => title
[1] => description
[2] => keywords
[3] => _backorders
[4] => _crosssell_ids
[5] => _default_attributes
[6] => _download_limit
[7] => _downloadable
[8] => _featured
[9] => _file_path
[10] => _manage_stock
[11] => _sale_price_dates_from
[12] => _sale_price_dates_to
[13] => _sku
[14] => _stock
[15] => _stock_status
[16] => _sold_individually
[17] => _subscription_length
[18] => _subscription_period
[19] => _subscription_period_interval
[20] => _subscription_price
[21] => _subscription_sign_up_fee
[22] => _subscription_trial_length
[23] => _subscription_trial_period
[24] => _tax_class
[25] => _tax_status
[26] => _upsell_ids
[27] => _virtual
[28] => _visibility
[29] => _weight
[30] => _width
[31] => _height
[32] => _length
[33] => _woocommerce_exclude_image
[34] => total_sales
[35] => _product_url
[36] => _button_text
[37] => _purchase_note
[38] => _override_tab_layout
[39] => _product_tabs
[40] => _wcml_custom_prices_status
[41] => _yoast_wpseo_title
[42] => _yoast_wpseo_bctitle
[43] => _yoast_wpseo_metadesc
[44] => _yoast_wpseo_metakeywords
[45] => _yoast_wpseo_focuskw
[46] => _yoast_wpseo_meta-robots-noindex
[47] => _yoast_wpseo_meta-robots-nofollow
[48] => _yoast_wpseo_meta-robots-adv
[49] => _yoast_wpseo_canonical
[50] => _yoast_wpseo_redirect
[51] => _yoast_wpseo_opengraph-description
[52] => _yoast_wpseo_google-plus-description
[53] => _cms_nav_minihome
[54] => _cms_nav_section
[55] => _top_nav_excluded
)

[taxonomies_readonly_config] => Array
(
[product_cat] => 1
[product_tag] => 1
[product_type] => 0
[shop_order_status] => 0
[product_shipping_class] => 1
)

)

[setup_complete] => 1
[icl_additional_css] =>
[display_ls_in_menu] => 0
[menu_for_ls] => 0
[st] => Array
(
[sw] => Array
(
[strings_language] => en
)

[strings_per_page] => 100
[icl_st_auto_reg] => auto-always
[strings_language] => en
[auto_download_mo] => 1
[track_strings] => 1
[hl_color] => #FFFF00
[translated-users] => Array
(
)

[theme_localization_domains] => Array
(
[0] => Kallyas
)

)

[hide_professional_translation_controls] => 1
[show_translations_flag] => 1
[icl_lang_sel_stype] => classic
[icl_lang_sel_orientation] => vertical
[icl_lang_sel_copy_parameters] =>
[languages_order] => Array
(
[0] => de
[1] => en
[2] => fr
[3] => it
)

[urls] => Array
(
[directory_for_default_language] => 0
[show_on_root] =>
[root_html_file_path] =>
[root_page] => 0
[hide_language_switchers] => 1
)

[custom_posts_sync_option] => Array
(
[attachment] => 1
[product] => 1
[product_variation] => 0
[shop_coupon] => 0
[shop_order] => 0
[wc_product_tab] => 1
[un_feedback] => 0
[portfolio] => 0
[documentation] => 0
[event] => 1
[location] => 1
[sidebar] => 0
)

[taxonomies_sync_option] => Array
(
[product_cat] => 1
[product_tag] => 1
[feedback_type] => 1
[product_type] => 1
[shop_order_status] => 1
[project_category] => 1
[documentation_category] => 1
[product_shipping_class] => 1
[event-tags] => 1
[event-categories] => 1
)

[hide_how_to_translate] =>
[icl_capabilities_verified] => 1
[sync_comments_on_duplicates] => 0
[hidden_languages] => Array
(
[0] => en
[1] => fr
[2] => it
[3] => en
[4] => fr
[5] => it
)

)

Thanks a lot for your support on this issue.

Kindest regards,

Gérard

Bildschirmfoto 2014-04-07 um 13.18.08.png
Bildschirmfoto 2014-04-07 um 13.16.41.png
April 8, 2014 at 2:39 am #375719

Bruno

Hello,

WPML customer support service operates 18 hours per day, Monday to Friday.

Our next available supporter will answer your ticket in about 6 hours from now.

Thank you for your understanding,

WPML support team,
By OnTheGo System

April 8, 2014 at 8:16 am #375858

Dat Hoang

Hello,

It seems you are hiding some languages?
Please try to disable all WPML plugins and reactivate them again. How is your site now?

I'm seeing hidden link works well.

Thank you.

April 11, 2014 at 1:18 pm #378871

Gerard

Dear Mr. Dat Hoang,

Thank you very much for your feedback.

We hid some languages as to try to solve the said issues. The main language on our site is Germany, the secondary language is English. Italian and French are still hidden as not important at this stage.

I have followed your instruction (switching off all WPML plugins) and the following experiences I could make;
the operation of the back-end was extremely slow till I switched off all WPML plugins. Now it was back to the speed we know of other sites we operate using WordPress.
After we switched on all plugins again the speed was back to the very low speed.

The same problem still occurs;
hidden link >> the German page
hidden link >> the English page that leads to a 404 error. The URL shows correctly in the browser but the contents is a 404 error.

Although I set shop base with category the set keeps on automatically setting „custom base“ with /shop/%product_cat%/ which is not defined / entered by us but it can’t be deleted.

What work now (as you saw too) when going shop > category > product as a client would do:
hidden link (which is correct)
hidden link (here /shop/ is not included which is wrong)
hidden link (leads to a 404 error message. Also here /shop/ is not included which is wrong)

I would be happy to supply you with the credentials of WordPress and/or FTP so you could take an inside look.

Thanks a lot for your support.

Kindest regards,

Gérard

April 14, 2014 at 7:39 am #379870

Dat Hoang

Hello,

#1,
Please go to Settings -> Permalinks and save your setting at least one more time.

#2,
For the problem related to WooCommerce pages (shop, product, product category... pages), I recommend you follow this:

1. Confirm original String Translation language is set to English (go to WPML -> String Translation -> Original language of strings )

2. Insert manually 'product-category' & 'product-tag' in wp-admin -> Settings -> Permalinks or directly hidden link

3. Make sure that the base for shop URL is set English language (it's the same place in step 2)

4, You need to set options in step 2, then go to WPML->String Translation -> Translate slugs for product-category & product-tag

This guide will help you much: http://wpml.org/documentation/support/translating-woocommerce-sites-default-language-english/

Please let me know if you problem resolves or not? If not, I need your credentials to help you better.

Thank you.

April 14, 2014 at 9:34 am #380018

Gerard

Dear Mr. Dat Hoang,

Thank you very much for your detailed feedback. I have copies your feedback here below and added my comments to them.

We have followed your advices (please see our below comments). One things we have found for which we have no solution:
Configuration warnings
Some settings from the WooCommerce Multilingual wpml-config.xml file have been overwritten
• Custom taxonomy product_type configuration from wpml-config.xml file was altered!
• Custom taxonomy shop_order_status configuration from wpml-config.xml file was altered!

#1,
Please go to Settings -> Permalinks and save your setting at least one more time.
>>>>This was done with the by us required settings
>>>> hidden link (German) works, hidden link (English) leads to a 404 error.
>>>> „shop base with category“ was also set but it keep changing to „custom base“ „shop/%product_cat%“ and any product selected shows a 404 error. This we can overcome by changing the shop setting (permalinks) to „default“, than things work but that it is not as desired.

#2,
For the problem related to WooCommerce pages (shop, product, product category... pages), I recommend you follow this:
>>>> Thank you for the recommendations

1. Confirm original String Translation language is set to English (go to WPML -> String Translation -> Original language of strings )
>>>> was and is set to English.
>>>> nevertheless this message is shown (with a part missing) in “string translation” >> Because your default language is not English, you need to enter all strings in English and translate them to and Deutsch. Read more

2. Insert manually 'product-category' & 'product-tag' in wp-admin -> Settings -> Permalinks or directly hidden link
>>>> product category was set correctly. Product-tag was shown grey. Now we entered it manually. We tried again to set the value as stated here above under # 1 but it keeps setting itself to “custom base”.

3. Make sure that the base for shop URL is set English language (it's the same place in step 2)
>>>> The default site & shop language is German for our German speaking customers.

4, You need to set options in step 2, then go to WPML->String Translation -> Translate slugs for product-category & product-tag
>>>> This was done. Also the product categories are translated and synchronised.
>>>> hidden link >>> works. The same page in English >>>hidden link doesn’t work.

This guide will help you much: http://wpml.org/documentation/support/translating-woocommerce-sites-default-language-english/

Please let me know if you problem resolves or not? If not, I need your credentials to help you better.

>>>> Unfortunatelly not. Can you be so kind to let me know how I can get the credentials to you on a secure basis. Your further help is very much appreciated.

Kindest regards,

Gérard

April 14, 2014 at 9:41 am #380025

Gerard

Dear Dat Hoang,

Please note that we set back to default the "Product permalink base" as otherwsie the shop (German) does not work at all.

Thanks a lot for your support on this.

Kindest regards,

Gérard

April 14, 2014 at 11:10 am #380127

Dat Hoang

Hi Gérard,

#1,
This problem will be got back after #2 is resolved 🙂

#2,
At first, I see you have not not set the language of strings to 'English' and this may cause the problem.

In the step 3 of #2,

3. Make sure that the base for shop URL is set English language (it's the same place in step 2)
>>>> The default site & shop language is German for our German speaking customers.

Yes, I understand that your default site is German, but you still set it 'English', then translate in WPML -> String Translation. The reason is here: https://wpml.org/faq/string-translation-default-language-not-english/

Please strictly follow all my 4 steps again. And see how your problem is now? About 90% people followed this and their sites work well 🙂

For this

One things we have found for which we have no solution:
Configuration warnings
Some settings from the WooCommerce Multilingual wpml-config.xml file have been overwritten
•	Custom taxonomy product_type configuration from wpml-config.xml file was altered!
•	Custom taxonomy shop_order_status configuration from wpml-config.xml file was altered!

May I kindly ask you please to open a new ticket for your new question? This will also help other users with similar problems find solutions when searching the forum.

Thank you.

April 14, 2014 at 1:38 pm #380259

Gerard

Dear Mr. Dat Hoang,

Thank you very much for your appreciated feedback.

A: I have done several "save settings" at the perma links page. I also set default (nothing works anymore) for all and changed the settings back to the original settings (than only German works).
B: original string language was and is set to English. Please see the screen shot I have attached. I have done "save and rescan" >> screenshot 2.
C: When you look at the strings (sceernshot attached), although the error message says "...not set to Englsih", the languages to translate are German, French and Italian.
D: I read again (which I find a good advice!!!) https://wpml.org/faq/string-translation-default-language-not-english/ and I understand. I again checked that setting and it is done correctly.

I have also added some general screenshots that might be on interest to you.

The current status after I tried your points 1,2, 3 and 4:
- It seems that everything is messed-up and we can't back to things working anymore:
Especially strange is under "Translate Product Categories" that the first language appearing is German although the default is set to English. We have already deleted the German categories and added 2 English categories but they also do not show in that overview >>> "Translate Product Categories".

What can we do?

Thanks a lot for your support.

Kindest regards,

Gérard.

Bildschirmfoto 2014-04-14 um 15.35.39.png
Bildschirmfoto 2014-04-14 um 15.33.59.png
Bildschirmfoto 2014-04-14 um 14.54.37.png
Bildschirmfoto 2014-04-14 um 14.34.18.png
Bildschirmfoto 2014-04-14 um 14.33.37.png
Bildschirmfoto 2014-04-14 um 14.24.07.png
Bildschirmfoto 2014-04-14 um 14.23.18.png
Bildschirmfoto 2014-04-14 um 14.13.14.png
Bildschirmfoto 2014-04-14 um 14.09.49.png
April 15, 2014 at 5:57 am #380683

Dat Hoang

Hello Gérard,

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply.

Note that:
+ Backup your site before giving us your credentials
+ It would be better if you give me the test site rather than live site.

Thank you!

April 15, 2014 at 6:06 pm #381285

Gerard

Dear Sirs,

please find the details as required.

Thanks again for your support.

Kindest regards,

Gérard

April 16, 2014 at 4:34 am #381455

Dat Hoang

Hello,

Thanks for your credentials.
I'm seeing your site and get back to you soon.

April 16, 2014 at 7:00 am #381492

Dat Hoang

Hello,

I disable all plugins, keep only WPML 3.1.4, switch to the default language, the problem still persists.

I try to follow wpml.org/documentation/support/debugging-wpml/ to get the error, but I only get this

[16-Apr-2014 06:37:19 UTC] PHP Notice:  Trying to get property of non-object in /homepages/25/*****/htdocs/*****/wp-includes/nav-menu.php on line 597

It seems not related to the problem.

However, after I updated the current dev version of WPML, all things work well.

The old plugin of WPML (3.1.4) is moved to the directory: /wp-content

Thank you.

April 16, 2014 at 9:08 am #381637

Gerard

Dearest Mr. Dat Hoang,

First of all I would like to thank you for the fantastic support you have given us. We love WPML (we recommend WPML to anyone who is interested in multilingual site / shops) but this was something we were not able to fix.

The phenomena you described is something we know very well ourselves. Something (not always logic) is done and all of a sudden the problem is gone. Why? no one knows. MOST IMPORTANT NOW is that you solved it and for that we are grateful.

We here again thank you for helping on this issue.

This issue is resolved.

For anyone out there >> WPML is a great plugin (and, for those asking, we are not related to WPML, we are a buyer and user).

I wish you all at WPML a lot of success.

Kindest regards,

Gérard.