This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 65 replies, has 2 voices.

Last updated by Lauren 1 month, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
June 6, 2019 at 7:03 am #3966189

alexanderA

Hello. I have used WPML to translate my site into French and Chinese. My theme has a custom post type named "Agents." The archive page for one of these posts is here: hidden link Towards the bottom of that page is a section "My Listings" and it displays a list of several posts--all of these posts are of type "property," have have this particular Agent assigned to it.

My issue is that the French and Chinese versions of this page do not display the "My Listings" section at all. The PHP code governing the page seems to think there are no properties assigned to this agent. The French and Chinese pages are here:

hidden link
hidden link

How can I resolve this? I have already translated the "property" posts into French and Chinese. Do I somehow need to translate this "Agent" into French and Chinese?

Thanks.

June 6, 2019 at 1:51 pm #3969659

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I believe you will need to also translate the agents in order for this to display. Please go to WPML -> Settings and scroll down to the post types section. Here, you can set the Agents to Translatable. Please let me know if that resolves the issue.

June 9, 2019 at 12:48 pm #3983091

alexanderA

OK I opened WPML -> Settings -> post types and see that 'Agents' is already set to "Translatable - only show translated items." Thoughts?

June 10, 2019 at 1:48 pm #3987793

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Have you translated the agents and then assigned the translated properties to the translated agents?

June 10, 2019 at 2:20 pm #3988101

alexanderA

It looks like each of the Agent posts have been duplicated into both French and Chinese (the two languages on my site other than English). The French and Chinese versions are duplicates--they are not set to 'translate independently.' In light of that, what steps should I try?

Furthermore, I have already translated all of my properties into French. But when I open the French version of a property for editing, the assigned agent is not set. Rather, it is set to 'Disable agent.' My educated guess is that when I duplicated all of the properties into French, I may have done so *before* translating the agents. So the newly created French properties had their 'assigned agent' reverted to the default 'Disable agent,' rather than the correct agent. What do you think of that reasoning ? If it is sound, how can I best resolve it?

June 10, 2019 at 5:02 pm #3989005

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Let's try this. Please go to WPML -> Settings and in the custom field section, click "Show system fields". Now look for the field for the agent assignment. Try setting this to Translate or Copy, then save the original property and resave the translation. After that, does it assign the agent correctly? Another option is to use manual translation and assign the agent using the traditional WordPress editor.

Please let me know if that resolves the issue for you.

June 11, 2019 at 9:15 am #3993483

alexanderA

OK I partially followed your instructions. I opened WPML -> Settings and in the custom field section, clicked "Show system fields." I am now on the step,

> Now look for the field for the agent assignment.

Which field is this exactly? After I showed system fields, there were many many fields (17 pages worth). So in the search box, I typed 'agent.' It then filtered out most results, and left me with 11 choices (see attached screenshot). Would it be the 'ale_assigned_agent' field?

June 11, 2019 at 1:27 pm #3995713

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Yes, I believe that ale_assigned_agent would be the correct field. Please try setting that to Copy or Translate and let's see if that resolves the issue.

June 12, 2019 at 7:23 am #4001069

alexanderA

>> Please try setting that to Copy or Translate and let's see if that resolves the issue.

OK. It is already set to 'Copy.'

June 12, 2019 at 2:32 pm #4005327

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

June 13, 2019 at 1:49 pm #4013441

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks. I found that you will need to manually assign the agent in the translated property. This means that you need to click "Translate Independently" and then select the agent from the drop down. As you can see, I tested this on the following property and now it shows on the translated agent page: hidden link

I would suggest asking the author which field controls this, and perhaps the author can add in the next update the wpml-config.xml file that will automatically assign this for you.

Please let me know if you need any further assistance and I will be happy to help.

June 13, 2019 at 2:19 pm #4013681

alexanderA

OK thanks for the info. Here are my follow-ups.

>> You will need to manually assign the agent in the translated property. This means that you need to click "Translate Independently" and then select the agent from the drop down.

OK. But my site (my live site, not my dev site) already has ~500 properties translated independently into both French and Chinese. All of have 'Disable agent' set as the 'agent.' So manually changing each one at this point is a very tedious and time consuming task. Is there any way around that? To remind you, the English version of each property has the correct 'agent' assigned--it is the FR and CN versions that incorrectly have 'Disable agent' assigned.

>> I would suggest asking the author which field controls this, and perhaps the author can add in the next update the wpml-config.xml file that will automatically assign this for you.

The plugin authors are no longer in business, so it is unfortunately not possible to contact them 🙁

June 13, 2019 at 2:35 pm #4013929

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I'm afraid without knowing which field would need to be registered in the wpml-config.xml file, there is no way to determine how to set that field to copy. And without being able to set it to copy, I don't know of another way to automatically change the setting for the translated posts. I suppose you could try to find the value in the database and then run a sql query to change the settings for your secondary languages, but the details for that would be outside of the scope of WPML support.

If you need further assistance, I can suggest you consider contacting one of our certified partners from this link: http://wpml.org/documentation/support/wpml-contractors

June 13, 2019 at 3:00 pm #4014129

alexanderA

>> I'm afraid without knowing which field would need to be registered in the wpml-config.xml file, there is no way to determine how to set that field to copy.

Which 'field' are you referencing here? I thought we already determined that the 'ale_assigned_agent' field was set to 'copy?'

June 13, 2019 at 3:59 pm #4015291

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

That was my guess, but since it's not working, I don't know how the theme is handling that field or even if it is the correct field to set to copy. That's why unfortunately we would need the author's assistance. I scrolled through the Admin Texts looking for theme options that could be set, but I honestly don't know how the theme works, so I'm afraid we are stuck. We simply need to know where that option is stored and how it can be copied. I would have assumed that setting the assigned agent to copy or even translate would work, but I tested both and it doesn't.

If you would like to send me a copy of your theme, I will be happy to install it on a fresh site and try to reproduce, which will allow me to determine if it is the theme that is causing the issue, or perhaps a conflict or setting in your site particular.