This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Rajeeb Banstola 12 months ago.

Assigned support staff: Rajeeb Banstola.

Author Posts
July 16, 2019 at 8:21 pm #4223805



I have two language hotel website. Primary language is English, the secondary one - Georgian.

The problem is that all rooms, location and hotel are created and translated, but I can’t show translated rooms on secondary language page here hidden link at the same time you can go to the translated rooms directly from the language switcher.

Rooms on the primary language is ok – hidden link

July 16, 2019 at 9:54 pm #4224199

Rajeeb Banstola


Thank you for contacting WPML!

I reviewed your site and can confirm that all the rooms are indeed translated. I also found that the theme is listed as compatible with WPML.
hidden link

Before we can start debugging further, please make sure your server meets all the minimum requirements for running WPML:

I suggest you to increase WordPress Memory Limit to 256M or higher and check other requirements as well.

Once you have done that, please disable non-WPML plugins and see if you can see the rooms.

Let me know if this helps!

July 17, 2019 at 6:41 am #4226201


Thanks for your reply.

As I can see in Traveler theme's system status page, WordPress Memory Limit is 256M. I can't increase it because of Hostgator policy, but it's enough for theme's system requirement.

I disabled all non-WPML plugins, but nothing has changed.

July 17, 2019 at 11:51 am #4229689


Just duplicated this website to another server - Inmotion Hosting with WP Memory Limit: 512 MB

hidden link

And have the same problem. So, server's low resources can not be the reason.

July 18, 2019 at 6:11 am #4235165

Rajeeb Banstola


I would like to request your WordPress login details in order to debug further. Please provide your details on the form below.

I've marked your reply as private so that only you and I have access to it.

The topic ‘[Closed] Translated problem’ is closed to new replies.