Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bruno 6 months, 4 weeks ago.

Assigned support staff: Bruno.

Author Posts
April 12, 2019 at 4:10 pm #3600463

selimU-2

I am trying to:
Translate taxonomies (product categories) via WPML's taxonomy translation.
Until now it worked well, i was able to translate english taxonomies to French, Italian and Spanish.
Im doing this so that I can import products into taxonomy via WP All Import. Taxonomies has to be translated first.
However, when I am trying to translate the taxonomies in Swedish or Norwegian, it seems okay, until i leave the Taxonomy translation page. When I come back, the translation disappears since there is + icon instead of a pencil icon. However, the taxonomies do show up in Product categories in Swedish and Norwegian. So it seems like the taxonomies are being created, but not linked...

April 12, 2019 at 11:02 pm #3602361

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. I noticed you are using some old plugins. Please, you could update all your plugins and check if the problem persists.

If the problem persists, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

April 15, 2019 at 11:10 pm #3616871

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I did a copy of your site. I will install it on my test environment and soon I will contact you.

About your second question, may I kindly ask you please to open a new ticket for your new question? According to our guidelines, only one issue per topic is allowed. Also, this will also help other users with similar problems find solutions when searching the forum.

Thank you.

April 26, 2019 at 1:26 pm #3690975

selimU-2

Its been a while and I havent received any feedback?

April 26, 2019 at 5:54 pm #3692707

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

My sincere apologies for the delay. This is a small bug that is causing in WPML and it will be fixed in a future release.

As a workaround, please, inside the wp-config.php file, add this line:

define( 'WPML_TAXONOMY_TRANSLATION_MAX_TERMS_RESULTS_SET', 5000 );

E.g.

define( 'WPML_TAXONOMY_TRANSLATION_MAX_TERMS_RESULTS_SET', 5000 );

/* That's all, stop editing! Happy blogging. */

This bug only happens when there are many taxonomies (+1000). Our developers are already aware of this problem and this will be fixed in a future release.

Please, could you verify if following the above steps, the problem is fixed?

Thank you.