Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Mayer 3 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
August 21, 2020 at 9:41 am #6844559

Mayer

woocommerce translation works. Except for 1 single category that appears empty in the translated language. Everything else works, the products are available and all other categories are populated with translated products.
Original category: hidden link
translated category:
hidden link

August 21, 2020 at 10:40 am #6844815

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

As discussed on chat, Please send the link to the copy of the site uploaded to an file sharing service. Your next reply will be private to securely share the details.

Kind regards
Raja

August 22, 2020 at 6:03 pm #6851583

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sorry i could not access the database dump can you please share the Database dump file again uploaded to a file sharing service.

August 25, 2020 at 3:25 am #6864175

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Access requested to download from the link.

August 25, 2020 at 11:52 am #6868073

Mayer

granted

August 26, 2020 at 11:15 am #6876775

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I managed to get to the source of the issue you have the option "Show only products with custom prices in secondary currencies" Enabled in WooCommerce > WooCommerce multilingual > Multi-Currencies > Currencies, which displays only the products that has Custom prices for secondary currencies.

Disabling the options resolves the issue. I have already applied the changes on your site and can confirm the same.

August 26, 2020 at 12:51 pm #6877797

Mayer

My issue is resolved now. Thank you!