Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Otto 2 years, 3 months ago.

Assigned support staff: Otto.

Author Posts
October 7, 2017 at 1:01 am

michaelW-11

I am trying to: Translated Woocommerce english product into chinese

Link to a page where the issue can be seen:

Original :
hidden link

hidden link

I expected to see:
Product to show up

Instead, I got:

October 9, 2017 at 9:04 pm #1395945

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for contacting the WPML support!

Please apologize for the delay in answering. This is not usual in this forum. I'll take care of your ticket and reply time will be shorter from now.

Please try the following:
-Go to WPML > String Translation and search for the product slug and delete it.
-Go to Settings > Permalinks and save again the product slug
-Go to WPML > Translation Management > Multilingual content setup > Custom posts and translate the product slug again

Let me know your results, please.

Kind Regards,

Otto

October 12, 2017 at 4:24 am #1398737

michaelW-11

Hi,

Thanks for your reply, I've follow the steps you provided however there's no product slug in the translation. So I am not sure why and what caused the 404 erro

October 12, 2017 at 10:01 am #1399008

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

To investigate further, I would like to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

Kind Regards,

Otto

October 12, 2017 at 11:11 am #1399087

michaelW-11

Hi Otto,

Yes you have my permission to clone the site, please proceed

Thanks

October 12, 2017 at 4:07 pm #1399429

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks.

If you go to WPML > Translation Management > Multilingual content setup > Custom posts slug translation options and uncheck the option "Translate custom posts slugs (via WPML String Translation)." it works fine.

Can you please try it? Is this a solution for you or you need to translate the product slug or any other slug? (the slug is the "/product/" part of the URL)

Let me know your results, please.

Kind Regards,

Otto

The topic ‘[Closed] Translated product showing 404 error’ is closed to new replies.