This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Giulio 3 months, 1 week ago.

Assigned support staff: Marcel.

Author Posts
March 20, 2020 at 5:21 pm #5729765

Giulio

Hello,

I need an help with this product: hidden link, because it shows the category URL in Italian, also if the page is English. The others products works well, same category but english version: hidden link.

I tried to re-save permalinks and clean the cache, but it didn't work. It could be related to Litespeed plugin? The strange thing is that the product works just like the category is in english. But only the URL shows the italian version.

Someone could suggest me a fix?

Thanks a lot.

March 23, 2020 at 11:20 am #5740519

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Giulio,

Thank you for contacting WPML Support.

I can detect a 301 redirect to the English product category. It looks like it's coming from Litespeed. Please check if you may have other 301 redirects configured, for example in your .htaccess file.

>>> <em><u>hidden link</u></em>

> --------------------------------------------
> 301 Moved Permanently
> --------------------------------------------

Status:    301 Moved Permanently
Code:    301
Connection:    close
X-Powered-By:    PHP/7.2.25
Content-Type:    text/html; charset=UTF-8
Location:    <em><u>hidden link</u></em>
X-LiteSpeed-Cache-Control:    no-cache
Cache-Control:    public, max-age=0
Expires:    Mon, 23 Mar 2020 11:18:16 GMT
Content-Length:    0
Date:    Mon, 23 Mar 2020 11:18:16 GMT
Server:    LiteSpeed

Please let me know.

Best Regards
Marcel

March 23, 2020 at 11:26 am #5740533

Giulio

Dear Marcel,

wow, this morning magically it seems fixed automatically. Why it happen? Please help me to understand the mechanism. I can try to imagine that for a bit, Litespeed caused some issue to the cache, but how it can fix automatically?

March 23, 2020 at 11:50 am #5740647

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Giulio,

the above 301 track route is the state before it's displaying the English version.
So, when a visitor clicks the link, the request will be forced to redirect to "/en/shop/reed-diffusers"" which will output the user the correct version.

Best Regards
Marcel

March 23, 2020 at 11:55 am #5740667

Giulio

Thanks Marcel, it is clear. But I just was asking about the mechanism why the category name can have this issue during the creation of permalink. I'd like to try to avoid it in the future. You are surely more expert than me and you can imagine the real cause of the issue.

March 23, 2020 at 1:38 pm #5741619

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Something on your server is causing the redirect. Without knowing your exact server configuration, I can't give you any details why it's working now. The Litespeed Cache plugin could be the culprit, but I can confirm this only if we can reproduce this from scratch.

Best Regards
Marcel

March 23, 2020 at 3:32 pm #5743029

Giulio

I perfect understand what you mean. Do you know if is there some issue with LiteSpeed and Redis?

March 23, 2020 at 4:55 pm #5743947

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

I checked our forum and internal bug tracker and can't see any reported cases regarding Litespeed with Redis. The cache plugin itself is certified for use with WPML: https://wpml.org/de/plugin/litespeed-cache/

Did you try to contact the plugin author for known issues too?

Please let me know.

Best Regards
Marcel

March 25, 2020 at 11:41 am #5759887

Giulio

Litespeed support told me that they can't suggest me something because it's very hard to find the cause of the problem from their side. Probably only you know well how works WPML and how the cache could influence the WPML and the creation of the issue. So if you haven't any suggestion right now, we can't do anything. Only hope that the issue will not happen again.

March 26, 2020 at 12:28 pm #5769143
Giulio

Dear Marcel, the issue is again between us, here: hidden link

As you can see here the category for all these products should be PROFUMO, but in a pair of cases the permalinks show "PERFUME". When you click to the URL, it redirect you to the right one. But it have no-sense... can you help me? As you can see sometimes it happen to a category, then to another... I really don't know how can fix it.

New threads created by Marcel and linked to this one are listed below:

https://wpml.org/forums/topic/issue-with-category-permalink/