Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 35 replies, has 2 voices.

Last updated by nikolajW 1 month ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 16, 2019 at 10:56 am #4579353

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

In this case I suspect that we are facing a compatibility issue. I have created a test site with a fresh new WordPress install and WPML plugins installed and setup. I would like to ask you to install/setup the necessary plugins and try to reproduce the issue.

You can access the test site by following this link: hidden link

Could you tell me if you were able to reproduce the issue?
Regards,
Carlos

September 19, 2019 at 6:02 am #4601601

nikolajW

Hey, I'm trying today to reproduce the issue on the sandbox.
I'm currently very bussy, that's why it take a bit longer.
I'm sorry for that.

Regards

September 19, 2019 at 10:07 am #4603371

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

No problem, I will be waiting for your message.

Regards,
Carlos

September 20, 2019 at 4:15 am #4609727

nikolajW

Hey, it works on the sandbox, but not on my setup.
Why is that?

Regards

September 20, 2019 at 5:30 am #4609807

nikolajW

I had all plugins deactivated.
Only woocommerce, wc subscriptions and wpml was enabled and the base theme active and still didn't worked. :/

September 20, 2019 at 5:32 am #4609809

nikolajW

I think that wpml isn't translating everything need for the subscription.
Because on the sandbox it is translating the "Synchronise renewals" option, but not on my setup.
It may not translate other options as well.

September 20, 2019 at 6:09 am #4609937

nikolajW

Hey, I somehow reproduced the issue on the sandbox.
Check out this product. It has a running subscription. But not the german version.
hidden link

The only thing now I did differently is, that I created the product while the language was switched to german.

September 20, 2019 at 6:25 am #4609989

nikolajW

Hey, I could reproduce it again.
This time I created the product XYZ on the english side.

I did nothing special, just choose virtual subscription, synched on 1 day, add the price and limit the amount of active subscriptions to one.

September 20, 2019 at 10:25 am #4611411

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I visited this link hidden link while logged in and I got this message (see attached image).

Regards,
Carlos

September 20, 2019 at 12:27 pm #4612145

nikolajW

Yes, but on the other language it is still available for a "sign up".
hidden link

On the bottom you can switch between the languages.

September 20, 2019 at 2:27 pm #4613009

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I was able to reproduce the issue in the test site therefore I have escalated this ticket to our compatibility team, where our compatibility specialists will take a deeper look in order to isolate it's cause and find a solution.

I kindly ask you to let the authors know about this issue, this way they can get in touch with our compatibility team and work in a solution.

I will keep you updated about the evolution of this ticket.
Regards,
Carlos

September 21, 2019 at 8:40 am #4615589

nikolajW

Asking the authors will be difficult, because I'm using a GPL licence.

I thought that WPML is working closely with woocommerce developers in general. :/
Is it possible that the developer of WPML reach out to them?

The only thing I could do is to show the authos this thread, but than they also can't get access to the sandbox, without asking you. 🙂

September 23, 2019 at 9:18 am #4621913

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

The goal is that the authors know that our compatibility specialists will try to reach them in order to solve this issue.

Regards,
Carlos

September 24, 2019 at 12:12 am #4626863

nikolajW

Ok, I messeage the support already.
Hopefully they will understand the situation.

From now on I guess I must wait until there is the first clarification about this issue?
Will I get notified, when the fix will be implemented?

Regards

September 24, 2019 at 8:40 am #4629173

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

Our specialists are already working on solving this issue. I will keep you updated about the evolution of the ticket.

Regards,
Carlos