This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Translated Products Fail to Appear. I also get this error "Some taxonomies in your site are forced to be untranslatable. This is causing a problem when you're trying to run a multilingual WooCommerce site."

Solution:

The error you receive ("Some taxonomies in your site are forced to be untranslatable. This is causing a problem when you're trying to run a multilingual WooCommerce site.") is caused by the fact that all the taxonomies on your site are currently set as "Not Translatable".

They need to be set as "Translatable" and you can do that by following the steps below:

1. Go to your WP Dashboard 2. Go to WPML > Settings 3. Scroll down till you get to the section called "Taxonomies Translation" 4. Set the ones you want as "Translatable" and then click the blue "Save" button

You will also see by scrolling up that from this settings page you can set as "Translatable" many things like "Custom Fields", "Custom Term Meta" or "Post Types".

Relevant Documentation:

https://wpml.org/documentation/getting-started-guide/translating-post-categories-and-custom-taxonomies/ https://wpml.org/documentation/getting-started-guide/translating-custom-posts/

This topic contains 2 replies, has 2 voices.

Last updated by luizS-2 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
September 27, 2018 at 2:15 pm

luizS-2

I am trying to: Ensure the right courses appear in the right fields on the course listings page. I am currently using a staging site.

Link to a page where the issue can be seen: Can I provide access to our staging site?

I expected to see: Each course section is fully populated with the relevant products

Instead, I got: A no events found message appears instead. The following text reads in the builder above "Some taxonomies in your site are forced to be untranslatable. This is causing a problem when you're trying to run a multilingual WooCommerce site."

September 28, 2018 at 10:50 am #2773298

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

The error you receive ("Some taxonomies in your site are forced to be untranslatable. This is causing a problem when you're trying to run a multilingual WooCommerce site.") is caused by the fact that all the taxonomies on your site are currently set as "Not Translatable" (I will also attach a screenshot so that you will see what I mean).

They need to be set as "Translatable" and you can do that by following the steps below:

1. Go to your WP Dashboard
2. Go to WPML > Settings
3. Scroll down till you get to the section called "Taxonomies Translation"
4. Set the ones you want as "Translatable" and then click the blue "Save" button

You will also see by scrolling up that from this settings page you can set as "Translatable" many things like "Custom Fields", "Custom Term Meta" or "Post Types".

Here is also some very helpful documentation regarding the process of translating taxonomies and custom post types:
https://wpml.org/documentation/getting-started-guide/translating-post-categories-and-custom-taxonomies/
https://wpml.org/documentation/getting-started-guide/translating-custom-posts/

Let me know if this solved your issue.

October 1, 2018 at 12:56 pm #2778189

luizS-2

Thanks Mihai, that seems to have resolved it!