Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: After WPML update some strings were registered as English. Solution: Go To the WooCommerce settings and change the source language for the strings.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 4 voices.

Last updated by rolandd-5 9 months, 1 week ago.

Assigned support staff: Jamal.

Author Posts
October 30, 2019 at 12:56 pm #4855751

rolandd-5

I have updates all WPML plugins to the latest version.
I can see the products of the main language (dutch), but all translated products are not visible (German, French etc). Just no products.

When I switch back to the old WPML versions, all products are back off the translations. So it have to do something with the update.

What i did:
- Removed WPML cache

Please note: this is on a staging server not on the production server. Debug information is from production server.

October 30, 2019 at 6:15 pm #4858677

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @rolandd-5,

I think your issue has been solved with the latest version of WooCommerce Multilingual (4.7.2).
Please update your WPML plugins to the latest version. See https://wpml.org/faq/install-wpml/ how to proceed.

Let us know if this solves your issue.

Thanks,
Pierre

October 31, 2019 at 6:58 am #4860625

rolandd-5

Hi Pierre,

yes, the issue is resolved, but another translation problem raised up with the translation.

The completed order email to the customer is not correct translated. Not correct translated is:
1) Email subjet heading, completed customer email
2) Emails title, completed customer email
Those are in the site's default language and not in the translated language.

I've tested this before the update of the following plugins with their versions where the translation was correct:
- WPML Multilanguage CMS 4.2.8
- String translation 2.10.6
- Translation Management 2.8.7
- Media Translation 2.5.3
- WooCommerce Multilangual 4.6.7
- ACF Multilangual 1.4.0

After the update I had to update the strings:
- domein admin_text_woocommerce_customer_completed_order_settings
- name [woocommerce_customer_completed_order_setting] heading

After updating the strings, the translation was still not applied.

Regards,

Roland

October 31, 2019 at 10:31 am #4862543

rolandd-5

Hi Pierre

Some more items are not translated after the update:
1) Admin-order email ->subject (always in site's default language)
2) Admin-order email -> title (always in site's default language)

This was solved in V4.7.1, but is back in the release of yesterday 4.7.2.

Same applies for the email-translation:
1) Thank you for shopping with us.

In V4.7.1 it was translated as set in String Translation.

I vhecked String Translation and the string is translated but not applied bij WPML.

regards,

Roland

November 1, 2019 at 8:31 am #4868725

SergeyR
Supporter

Hello Rolandd,
what is you admin user language ( from wp-admin/profile.php page )? In our logic all admin emails are sent in admin language not in order one.

If you want use order language as language for admin emails as well please use new hook which was added since WCML 4.7.0 https://wpml.org/wcml-hook/wcml_new_order_admin_email_language/

Also there no fixes related to emails between 4.7.1 and 4.7.2 versions

Thanks!

November 1, 2019 at 8:48 am #4868899

rolandd-5

Hi SergeyR,

The site's default language and the Admin language is Dutch.

With the Hook you are referring to, the admin order email is in the correct language but not for:
1) Admin-order email ->subject (is in site's default language)
2) Admin-order email -> title (is in site's default language)

That's not true, there was a fix with the email languages. You can revert back to 4.7.1 and see yourself. But no product were listed in the shop except the products for the site's default language. V4.7.2 fixed that, but the problem with the language of the emails revert back.

Please see my other thread: https://wpml.org/forums/topic/woocommerce-admin-new-order-e-mail-language-2/

Regards,

Roland

November 1, 2019 at 8:55 am #4868923

SergeyR
Supporter

Ok Thanks for the reply, I'll use credentials from another ticket and will check today and get back to you with results

November 1, 2019 at 2:13 pm #4871431

SergeyR
Supporter

Hello Rolandd,
I have found a problem on your site - you have "English" language set for default email strings but have there string in "Dutch" entered.

There 2 ways to fix this:
- enter English strings in WC->Emails settings
- go to ST and change original string language and add translations to other languages

I did second fix on your staging site for "New Order" admin email strings

November 1, 2019 at 5:09 pm #4872529

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello @rolandd-5,

Please let us know if Sergey's suggestions are working for you.

Best regards,
Jamal

November 2, 2019 at 7:18 am #4873623

rolandd-5

Thanks for the fix, but I do not understand why this is a problem with some updates. Before the update it did worked perfectly. After the update it won't.
I want to understand so I can fix this myself with future updates.

My issue is resolved now. Thank you!