Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Andreas W. 1 week, 1 day ago.

Assigned support staff: Andreas W..

Author Posts
October 26, 2019 at 11:05 am #4831437

baselQ

ok i have multi-language woocommerce store the shop page don't show any product on the arabic version store, i did the translation throughout . wpml translation manager and all .MO files are updated i use wpocean theme and elemontor page builder

October 28, 2019 at 12:58 am #4835833

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Could you please verify if WPML and its add-ons are using the latest version and let us know if the issue persists?
Before doing it, please create a reliable backup of your site.

To help you faster, I've enabled a private message for submitting the debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

If the issue persists, try to run the site in minimal setup:

Please disable any additional plugin that is not related to WPML and its add-ons.

If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.
In this case, it might even be related to Elementor, as there have been some issues with page builders lately using our latest plugin versions.

If you can not determine anz plugin involved into the issue, please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

November 4, 2019 at 1:40 pm #4881593

baselQ

idid update the plugin and its stay the same

November 4, 2019 at 6:08 pm #4883921

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

November 5, 2019 at 5:58 pm #4892415

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The provided credentials are sadly not valid. Please verify the provided information and also make sure to add access to the server by FTP/SFTP.

Kind regards
Andreas

November 14, 2019 at 10:04 pm #4950455

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to point out three topics:

The shop page was marked with "appear as translated" inside of the page´s multilingual content setup, which can be found at the bottom of the page editor. I have adjusted it to "translatable".

Then, when translating pages, that have been created with Elementor please use the WPML Translation Editor.

Further, as this page uses an Elementor Template, this template will need to be translated in order for the page to show up.

I hope this will solve the issue.

Kind regards
Andreas

November 15, 2019 at 3:38 pm #4955323

baselQ

Hi Andreas,

I did your recommendation but still, nothing appear in translated shop page, even i copied the content from the English version

November 15, 2019 at 10:58 pm #4957129

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

It seems there is an error inside the theme. Did you take any changes to the theme code?

It works when changing to Twenty Twenty Theme.

Kind regards
Andreas

November 17, 2019 at 3:25 pm #4960481

baselQ

Hello,

No we didn't do any change on the theme files or codes, what do you think is the changed code,

November 18, 2019 at 3:02 pm #4966147

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

As mentioned that issue is solved when switching to the Twenty Twenty Theme, which clarifies that the error is related to the OceanWP Theme. I was only asking if any changes have been taken on the theme before trying to recreate the issue.

It might be that there is currently a compatibility issue between OceanWP and WPML.

Please install the OceanWP Theme on the following test site for further investigation:

One-Click Login:hidden link

Leave me a short notification once the theme is installed and I will test it for compatibility.

Kind regards
Andreas

November 24, 2019 at 5:58 pm #5007369

baselQ

Hi Man, sorry for taking too long to reply

the theme is installed in the staging website

November 26, 2019 at 5:28 am #5017977

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Until now, the issue does not occur on the test install, while I see another issue. The translated store appears as with the sidebar, while it should not.

Now, could you please add Elementor PRO in order to keep testing? It seems to me the issue could be linked to it.

Kind regards
Andreas

November 27, 2019 at 6:00 pm #5031769

baselQ

Hi Amigo,

we work on elementor the free version, not the pro one, I don't have the license for elementor pro.

so now what we can do to solve this problem.

i tried everything i could found online

November 27, 2019 at 9:20 pm #5032361

baselQ

hi Andrea,

didi you access the website and deactivated the current theme, and other plugins please confirm that we can't do this on this website this is a production site not stagged

November 27, 2019 at 9:22 pm #5032363

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The issue does not occur on a new install with the OceanWP Theme.

The issue seems to be related to changes that have been taken on OceanWP Theme. It seems you added or customizer code here, correct? I would advise you to create a Child Theme before a Theme Update will overwrite your changes, but please take note that our support policy does not cover any custom code solutions.
https://wpml.org/purchase/support-policy/

The issue disappears when switching the theme on your site.

I would suggest you reach out to one of our contractors in order to receive a customized solution.
https://wpml.org/contractors/

We hope for your understanding.

Kind regards
Andreas