Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by alessandraV-3 4 years, 9 months ago.

Assigned support staff: Mladen Andrejic.

Author Posts
November 8, 2015 at 7:51 pm #742102

alessandraV-3

I am trying to: See the slides translated (after having properly translated them with WPML)

URL of (my) website where problem appears: hidden link (original in ES), hidden link (EN) + hidden link (IT)

[ removed by WPML Support. Please do not post private details. This is a public area. ]

I don't have access to FTP

I expected to see: See the slides translated (after having properly translated them with WPML)

Instead, I got: I still see the slides in Spanish

Can you help me please? Thanks

November 8, 2015 at 7:52 pm #742103

alessandraV-3

I forgot to mention that I have contacted WooThemes about the problem, but they just told me to contact you. I therefore hope, that you will provide a real solution for this.

November 10, 2015 at 9:01 am #743205

Mladen Andrejic

Hello Alessandra,

I see that you are using very old versions of WPML. It would be good if you update them. As you are going to jump over many versions the best way to proceed will be to update plugins manually :

1. Frist update to 3.1.9.7
2. Then update to 3.2.7

Updating to 3.1.9.7 first will assure that database structure stays complete and proper database upgrades are done.

You can download latest versions from here https://wpml.org/account/downloads/ (to download 3.1.9.7 please open "Changelog" for WPML Multilingual CMS)

Then you should deactivate and delete all WPML plugins from your website, and follow the instructions here (Section : Updating WPML Manually) https://wpml.org/faq/install-wpml/

// NOTE : Please make a complete backup of your website, before updating. The update should go without problems, translations are saved in the database and won't get lost, but in case something goes wrong it is good to have a backup.

// IMPORTANT! : There is also one more thing that you should know. If you have set your default language of the strings to be Spanish and translated the strings from Spanish to other languages - that is not possible with WPML 3.2 (although your website does not have English as default language, language of the strings must be English), please check this here for full explanation : https://wpml.org/forums/topic/strings-are-assumed-in-en-and-not-the-default-language/#post-698787

Thanks.

December 6, 2015 at 12:09 am #762160

alessandraV-3

Thank you for your help, Mladen. I did update the plugin to the last version. However slides are still giving me problems (they are translated but the language change seems to ignore that).

December 7, 2015 at 9:57 am #762505

Mladen Andrejic

Hello,

1. If the problem still persist, please check it when

- All non WPML Plugins are disabled
- Theme is set to default Twenty Fourteen

2. Activate WordPress debug.log and see if there are any errors displayed? Here are the instructions for activating it : https://wpml.org/documentation/support/debugging-wpml/

3. You can also check the Chrome built-in JavaScript Console for errors. To open the console go to Menu (Three Bars) > Tools > JavaScript Console

Please paste here any errors that you see in the WordPress debug.log or in JS Console.

Thanks.

December 10, 2015 at 11:58 pm #766489

alessandraV-3

I finally found the problem, it was an issue with the php function theme.
https://wpml.org/forums/topic/woothemes-definition-slider-not-working/