This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 4 voices.

Last updated by Yvette 1 year ago.

Assigned support staff: Yvette.

Author Posts
September 2, 2018 at 4:19 pm

noamK-2

Hello,

Our website's main Language is English. Secondary is Hebrew - a right-to-left language.

We use Translation Editor for translating all our content, except when it is required to use string translation.

The issue:

1. We translated a Woocommerce string to Hebrew.

2. This string is the header of an automated email message sent to the a new user by Woocommerce after first registering to the website.
see attached marked screenshot of the Woocommerce New Account email settings, with the header text and the WPML translation button next to it.

Also, see attached screenshot of the string and its translation.

3. The problem is: in the automated Hebrew email message, the header is skewed - the space between the last Hebrew word and the English word next to it is gone, although it is in the translated string.

This phenomena doesn't happen with all mixed strings in the Hebrew email messages generated by Woocommerce which contain English and Hebrew. It happens with some of them, such as this one.

You can see for example on the WPML string translation page, that the related domain contains two strings, both of them mixed Hebrew-English, but the other one is not skewed. It keeps the spaces and the alignment correctly.

See attached marked screenshot of the Hebrew email message sent by Woocommerce to new registered users (the New Account email). You can see here both mixed strings, mentioned in my example. One is OK and the other one is skewed

Can you please fix it so that mixed email messages translated strings are not skewed?

Thank you,

Noam Kroll

September 3, 2018 at 9:24 pm #2700961

Amit
Supporter

Hi Noam,

Seems like an RTL/CSS small glitch, actually probably not related to WPML but coming from the theme/WooCommerce or even WordPress itself.

As a quick fix and before we take a deeper look can you please try changing the order in String Translation in that way -

ברוכים הבאים ל - Krollconsultants.com

Or try playing a bit with where the hyphen is (-), let me know if that help and if possible send a screen of how that string looks on front-end if you activate the inspector.

Good night,
Amit

September 4, 2018 at 1:50 am #2701263

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us.

This seems like a problem with your theme. It seems that even if you only have one language RTL, without WPML enabled and you set up WooCommerce, this problem happens.

Have you tried, as a test, to install a new WordPress, without WPML, just like your theme and set up your website to work with Hebrew (default language) to know how the email will be displayed?

Thank you.

September 4, 2018 at 6:32 am #2701851

noamK-2

Hello Bruno,

Yes we did, and lots of other tests. Nothing worked.

Thank you,

Noam Kroll

September 4, 2018 at 6:38 am #2701854

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Noam,

Thank you. If this did not work, even with WPML disabled, then you should contact the author of your theme and ask how you can make it compatible with RTL languages.

From the tests that I did, in fact, is the problem. The WooCommerce email does not seem to work correctly with RTL languages, even though WPML is enabled. This is usually related to the theme, but maybe some other option.

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

September 4, 2018 at 6:46 am #2701860

noamK-2

Hello Bruno,

It is not theme related. We have already verified this with the theme authors.

Please note: Our theme is on the list of your WPML compatible themes.

Noam Kroll

September 4, 2018 at 1:04 pm #2703432

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. In my first message, I asked you if you had already tested this with just your theme and with WooCommerce and if the problem persisted. From what I understand about your answer "Yes we did, and lots of other tests. Nothing worked.".

Have you tested this with your theme and WooCommerce, without WPML, using an RTL language such as Hebrew? By the tests I did, even without WPML enabled, the email header does not appear correctly, only the subject of the email.

If you have not already tested this, please could you test to see if this will work only with WooCommerce and with your theme, using Hebrew as the default language?

Thank you.

September 4, 2018 at 1:32 pm #2703543

noamK-2

Hello Bruno,

I am very disappointed by the way you handle this ticket.

I am not a professional developer or coder.

We have had many tickets filed before, and usually the tests and all the checks were done by your supporters.

That is the reason we provide you with full access and all other data and files you request.

If you don't feel like handling it properly, just let us know. We are exhausted by now.

Noam Kroll

September 6, 2018 at 1:46 am #2708992

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Noam,

I'm sorry about that. I just asked if you would have replicated this in a fresh installation.

I'm going to try to replicate the problem you're reporting to see what might be happening, though I do not think it's related to WPML. I'll contact you soon.

Thank you.

September 7, 2018 at 12:51 pm #2714694

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Bruno is not available so I will be helping you now.

I downloaded your duplciator site and attempted to install it on my local server, but the Accounts page would not work. I continuously got a "Refuse to connect" error on the localserver.

I then went into your site and created a sample case to confirm the error.
I include a snapshot of the email I received as a new user which confirms what you previously uploaded.

I went to check the String Trasnlation tables and could see that each string is appearing as follows
Subject
In String Translation: KrollConsultants.com חשבונך באתר
In Email received: חשבונך באתר KrollConsultants.com

Email Title:
In String Translation: KrollConsultants.com- ברוכים הבאים ל
In Email received: KrollConsultants.com- ברוכים הבאים ל

1, My understanding is that the Email recevied Title should be:
ברוכים הבאים ל - KrollConsultants.com

Is this a correct understanding of the problem?

2. Diagnostics
I understood that you had not yet tested if this was the same behaviour in a minimal environment as I did not see theme Twenty Seventeen installed.

I then installed Twenty Seventeen but did not activate
I changed your default system language to Hebrew.
I then deactivated the WPML CMS plugin
I then attempted to register a new user to see if the email problem still happened.

At this point, I lost contact with your site.

I am not sure if it was linked to the deactivation of WPML CMS or due to something else you were doing on your site at the same time.

If it was due to the deactivation of WPML CMS, I would need to manually reactivate the plugin. To do this, I would need access to your Cpanel PHPMyAdmin so I am opening the private area for these details.

If it is something else that caused the system to be inaccessible, please notify me when I can continue the basic diagnostic steps.

Thanks.

September 7, 2018 at 1:14 pm
September 7, 2018 at 1:21 pm #2714865

noamK-2

YOU SHOULDN'T HAVE DONE ALL THESE CHANGES ON OUR LIVE WEBSITE!!!!!

NOT WITHOUT OUR PERMISSION!!!

September 7, 2018 at 1:31 pm #2714888

noamK-2

We are now doing damage control with our host SiteGround support

September 7, 2018 at 1:43 pm #2714984

noamK-2

WHY CAN'T I CHANGE THE DEFAULT LANGUAGE TO ENGLISH US? IT DOESN'T LET ME NOW!!

URGENT!!!!!!!

September 7, 2018 at 1:43 pm #2714985

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I did not realise that this was an active site and I apologise. I have listed all the actions that I did which was primarily to deactivate the CMS plugin and to change the site language to Hebrew.

That is all that was done.

The topic ‘[Closed] Translated string with English and Hebrew words in it is skewed’ is closed to new replies.