Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 3 voices.

Last updated by Lauren 14 hours, 34 minutes ago.

Assigned support staff: Lauren.

Author Posts
November 8, 2019 at 2:58 pm #4914307

Nikita Nanos

I am trying to: translate the bootstrap slider and content boxes

Link to a page where the issue can be seen: hidden link

I expected to see: the translation of the website in Fr

Instead, I got: EN content in the FR version of page

November 10, 2019 at 10:50 pm #4921607

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

When creating Sliders with Slider Revolution you will find a WPML dedicated setting at
Slide Module -> General Settings -> WPML -> Use WPML Settings. Make sure it is enabled.

Afterwards you will be able to assign Sliders to different languages at Slide Options -> WPML -> Slide Lang.

This means that you will need to create independent Sliders for each language and assign them properly. Slider Revolution offers here the option to duplicate the first Slider and afterwards, you will only need to edit the text and assign the language to the new slider.

More information here:

https://wpml.org/documentation/plugins-compatibility/creating-multilingual-sliders-with-revolution-slider-and-wpml/

I hope this will solve the issue for you. Let me know if you need further assistance.

Kind regards
Andreas

November 12, 2019 at 7:41 pm #4934425

Nikita Nanos

I was looking to translate the Bootstrap slider, is that done through the slider revolution? Also, how do you translate content boxes?

November 13, 2019 at 5:13 pm #4941683

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Do I understand right, that this Slider is part of the Evolve Plus Theme?

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

November 19, 2019 at 5:43 pm #4974837

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I took a quick view on your site and received an error when trying to switch the language.

Further, I can see various plugins are not up-to-date.

In order to make a backup I would suggest you read the following article:
hidden link

Now, I sadly did not receive FTP access. I would like to ask you to enable the wp-debug feature in order to scan for PHP errors.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results. Take note that this log writes errors in real-time, which for I would suggest accessing hidden link as an issue occurs here.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know about the results. In case the debug-log is very long please add it to a web tool like pastebin.com and send me the link.

At last, about the slider, could you please provide me some more details? Are you referring to the Theme4Press Slider? Anyhow, we will first need to focus on the main issue before working on the switcher.

Kind regards,
Andreas

November 21, 2019 at 4:46 pm #4991123

Nikita Nanos

Our website now shows a fatal error has occured when I go to the FR version and this was not happening before I shared log-in details. Have you changed any settings on our website, if so, can you please put them back to how they were before?

November 21, 2019 at 4:55 pm #4991323

Nikita Nanos

Actually, when checking our website this morning, the FR version is not appearing anymore and WPML is now uninstalled from our website, which we did not do. Any idea why this is happening?

November 21, 2019 at 5:36 pm #4992027

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I did not make any changes to your site. The error was displayed when switching the language on Front-End.

I neither deleted the WPML Multilingual CMS plugin. I would suggest you delete all our plugins and start with a fresh install.

https://wpml.org/faq/install-wpml/

Further, make sure the wp-debug is enabled as explained early rand provide me results from the debug.log file.

Also, in regards to the slider, you did not answer my question.

Please provide detailed steps to how the slider has been created. Is it part of the Evolve Plus Theme (Theme4press Slider) or was it created in Slider Revolution?

Kind regards
Andreas

November 25, 2019 at 2:56 pm #5014811

Nikita Nanos

If I reinstall WPML, will I lose all the translations I have previously done?

Also, I believe the slider was created with Evolve Plus Theme, not slider Revolution.

November 25, 2019 at 7:02 pm #5016431

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

No worries, all settings and the content is saved inside of the database. There is not an issue with reinstalling WPML.

Further, please install the theme and the necessary plugin(s) to recreate the issue on the following test site. From there, our compatibility team can take care of the problem, if it also exists on a new install.

One-Click Login: hidden link

Leave me please a short notification once the test site is ready.

Kind regards
Andreas

November 26, 2019 at 8:38 pm #5025119

Nikita Nanos

When I follow the instructions to reinstall WPML, it doesn't work, it gives me this message:

Unpacking the package…

Installing the plugin…

Destination folder already exists. /var/www/wp-content/plugins/sitepress-multilingual-cms/

Plugin installation failed.

November 26, 2019 at 11:30 pm #5025549

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you, this is kind of odd, as as far I recall the plugin seemed not to be installed.

In case there is not any plugin available to be deleted inside of the Plugins section it might be a different issue and you should have a look on your server.

Please provide me FTP/SFTP access in order to debug your site. I have enabled the private reply.

Kind regards
Andreas

November 27, 2019 at 1:30 pm #5029529

Nikita Nanos

I do not know how to give you FTP/SFTP access. How would I do that?

November 27, 2019 at 8:40 pm #5032221

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

We will need the server credentials in order to use an FTP client to access the files saved on the server. As mentioned earlier I will need to enable wp-debug in order to check for errors and I would like to review the plugins folder.

Please consult your hosting provider and reach out to us again.

Kind regards
Andreas

November 28, 2019 at 6:10 pm #5038983

Nikita Nanos

I have the info for FTP access, can you enable a private response so I can share it with you.