This thread is resolved. Here is a description of the problem and solution.

Problem: Translated strings stopped working on the front end

Solution: Go to WPML->Themes & Plugin Localization and select the "Translate using string translation"

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/string-translation/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by nourD 3 years, 2 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
January 3, 2017 at 5:32 pm #1173710

nourD

I am trying to:
Figure out why the translated strings are not showing in the front end. They were working before.
URL of (my) website where problem appears:
hidden link
I expected to see:
Translations like Read More to read Ver mas, etc
Instead, I got:
Read more, etc
Steps to duplicate the issue:
I've been adding custom types made with Toolset into the functionality of the theme I'm using. Translations were showing up fine until some days ago but I can't tell when exactly did it stoped happening. Some words are still translated like "Busqueda" for Search in the top header and other ones in the footer widget. But the rest is not showing the translation: read more, leave a comment, reply, breaking news, etc.
Thank you in advance for your help.

January 4, 2017 at 8:05 am #1174005

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for contacting WPML support.

Have you gone to string translation and checked if the translated strings are there? as well as can you check if the "Translation is complete" checkbox is enabled?

As you mentioned some translation are not working and some are working it seems there is some PHP errors or conflicts with some plugin/themes is causing this error, would you mind following the below tests and let me know the result.

Minimal Setup
If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .

2. Repeat the action of creating the problem.

3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

I look forward to your reply.

Thanks

January 11, 2017 at 5:39 pm #1179879

nourD

Hi!

Thank you for helping me and thank you in advance for your reply.
The translations seem to still be there in the string translations. Someone is helping to find the debugging info. This is what he wrote:

"it seems there's a duplicate entry in the data base...

[09-Jan-2017 15:29:01 UTC] WordPress database error Duplicate entry '291ee57e6f148daac842fd7d12cc0c24' for key 'uc_domain_name_context_md5' for query UPDATE wp_icl_strings
SET name = 'group field-group-datos-comunes name',
domain_name_context_md5 = md5( CONCAT( context, name, gettext_context ) )
WHERE name = 'group 1389 name' made by include('wp-admin/edit-form-advanced.php'), do_action('add_meta_boxes'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, wpcf_admin_add_meta_boxes, wpcf_add_meta_boxes, Types_Wpml_Field_Group->translate_name, Types_Wpml_Field_Group_String->translate, Types_Wpml_Field_Group_String->translate_legacy, Types_Wpml_Field_Group_String->update_db_identifier"

I have the debug.log file. The content is really long. I tried pasting it here but the message would not go through. Shall I keep trying to just copy it or is there I way to send it as a file?
Thanks so much.

January 12, 2017 at 4:18 am #1180146

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Go to WPML -> Support -> Troubleshooting.

Look for 'Clean up' and click the following:
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Does this remove the error from your apache log?

Also, you can send the debug.log using pastebin.com

I look forward to your reply.

Thanks

January 12, 2017 at 2:55 pm #1180816

nourD

Hi!

I'm right now following the steps and I've click on all the items in the list, but the Remove ghost entries from the translation tables has been taking hours (more than 8 so far) to complete. Or so it seems, since the time cursor is still active and the other ones told me when the process was finished. Is that normal? Shall I leave it until it stop? Or should I refresh the page and try again? I don't want to screw the process by rushing something.

I tried using pastebin.com to send you the debug.log but it says I'm exceeding the size and need to upgrade to pro account. Any other free service I could use to send you the info?
Thank you so much for you help.

January 12, 2017 at 5:17 pm #1180973

nourD

Hi,

Just an update: I had to reload the page and did the process again through the Troubleshooting options again. The issue wasn't resolve. Anything else I can do?
Thank you tons

January 13, 2017 at 2:31 am #1181209

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

To further debug this issue, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

This info is private and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:
+ Backup (both files and database) your site before giving us your credentials
+ It would be better if you give me the test site rather than the live site.

We'd like to request the permission to disable, enable and install themes and plugins for this site. Please accept this?

I look forward to your reply.

Thanks

January 24, 2017 at 2:31 am #1188857

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

The login details are not working, could you please check it once?

I look forward to your reply.

Thanks

January 31, 2017 at 12:21 am #1194366

nourD

Hi and so sorry for the delay. Please use the same password but use user name: ricardo
Thank you 🙂

January 31, 2017 at 3:25 am #1194379

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Yes, I am able to login to your backend using the Roberto username now 🙂 but unfortunately, the FTP details are still not working, to find the error of database error and fix it I will need the FTP details so could you please check it and let me know if this helps?

Also, we have recently released new versions of plugins with further improvements and fixes, so would you mind updating the plugin to the latest version and let me know if this helps?

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

I look forward to your reply.

Thanks

February 1, 2017 at 7:06 am #1195596

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Could you please check the issue once, going to WPML->Themes & Plugin Localization and selecting the "Translate using string translation" solved the issue.

Let me know if you have further questions.

Thanks

February 1, 2017 at 3:01 pm #1196321

nourD

YOU ROCK!!! thank you thank you!