This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Translated string not visble in the front end

Solution: Goto WPML > Theme and plugin localization > Localization option, Select the option "Translate themes and plugins using WPML's String Translation only (don't load .mo files)"

This topic contains 3 replies, has 2 voices.

Last updated by Raja Mohammed 1 month, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
August 19, 2019 at 4:08 am

Faisal Hourani

We have translated strings from English to Spanish and they were working fine for a while

Recently some strings are showing up in English even though they are still translated to Spanish (see screenshots)

Link to a page where the issue can be seen: hidden link

August 19, 2019 at 10:54 am #4415393

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

It seems like you have selected not to use string translation from WPML setting changing the option to " Translate themes and plugins using WPML's String Translation only (don't load .mo files)" in WPML > Theme and plugin localization > Localization option, Resolved the issue.

Please verify the same

Kind regards
Raja

August 19, 2019 at 11:32 am #4415559

Faisal Hourani

Great, can you please delete the screenshots and the URLs from the original post?

Thank you

August 19, 2019 at 11:52 am #4415727

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Glad that solved the issue, Images removed, Any URL shared on this forum will be obfuscated and visible only to the client and the supporter, so need not worry about them

Have a great day 🙂