This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Bigul 2 weeks, 3 days ago.

Assigned support staff: Bigul.

Author Posts
September 13, 2019 at 10:25 pm #4570923

philippeL-20

I am trying to: translate a post with already translated tags

Link to a page where the issue can be seen:

I expected to see: the translated tags

Instead, I got: the tag_ID (178 in the image hereafter) are displayed (and also new tags labelled with tag_ID are created in the source language) ! Do you have an idea ? it was working fine with the previous WPML version !

September 15, 2019 at 12:39 pm #4574629

philippeL-20

Hi there,
There’s a problem in the WPML ´s translation editor ;
We have tags already translated from English to Chinese ;
When we use the WPML TE to translate a post from English to Chinese the tags are replaced by the Chinese tag_ID in the post in Chinese !
When we delete the tags in the English post , translate the post into Chinese and after that add the tags to the English post , the Chinese post have correct tags well translated;

The WPML TE seems to work incorrectly with the new recent version ( it works with the previous one )

Do you have an idea ?
Could you make the test in your environment ?
Thanks for your support
Kind regards

September 16, 2019 at 7:36 am #4576943

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Does it happen after upgrading to WPML 4.2.8? If so, before the upgrading which version of WPML you were using.

Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

September 16, 2019 at 8:27 am #4577391

philippeL-20

Hi Bigul, thank you for your support !

It happened when upgrading to 4.2.8 ; we were using WPML Multilingual CMS 4.2.7.1 before and it worked fine;
We use WPBakery Page Builder, it perhaps a compatibilty issue ?

I'll do the "cleanup" in a few moments ...

September 16, 2019 at 2:09 pm #4581083

philippeL-20

Hi Bigul,
We've made the cleanup ; there was no confirmation for "Fix WPML tables collation" ... is it a problem ?

after the cleanup, the problem stays the same :
- we've deleted all the tags of the English post (made with WPBakery Page Builder) and translated (with WPML TE) in Chinese -> no tags on both posts English and Chinese : OK
- we've added tags in the English post and translated in Chinese -> in the Chinese post, tags are named with the chinese tag_ID of each tag !!! and tags are created in English with name Chinese tag_ID !!! : KO
- we've deleted all the tags of the English post and translated (with WPML TE) in Chinese -> no tags on both posts English & Chinese : OK
- we've added tags in the English post without using the WPML TE -> all is OK in Chinese : OK

The post has been made with WPBakery Page Builder , we've made a test with the Gutenberg block Editor and it is OK -> tags are OK in Chinese ..
Perhaps a problem using WPBakery and WPML TE ?

Thanks for your support

September 16, 2019 at 3:10 pm #4581889

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. *Fix WPML tables collation* action of WPML Troubleshoot will not have confirmation message. It requires further checking. So please share with me the following information for tracking the issue.

1) Please let me know the exact steps to reproduce the issue on your site for a better understanding.

2) I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

September 20, 2019 at 10:13 pm #4614461

philippeL-20

Hi Bigul, thank you for your support
We can not give you access to our site that contains sensitive information ...

We've seen that somebody else reported today the same issue : https://wpml.org/forums/topic/the-translated-tag-converts-to-a-numerical-value/

in summary for us:
after translation with WPML TE (English to Chinese or Spanish), tags are replaced by numeric values in the translated post (which correspond to tags_IDs of translated tags) and new tags with those numeric values are also created in the source language (English here)

Do you have an idea ?
Are you planning a fix ?

September 23, 2019 at 8:44 am #4621735

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Now only two cases are reported with this bug. So it requires further debugging.

Therefore is it possible to share a copy of the site using the Duplicator plugin or All-in-One WP Migration plugin? We will delete the package just after fixing the issue.

--
Thanks!

Bigul

September 24, 2019 at 1:04 pm #4631787

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, we have released a new version of WPML 4.2.9 a few hours ago. It has included the fixes for similar issues. So please upgrade to the latest version after a full site backup and make sure the issue is existing or not.

--
Thanks!

Bigul

September 26, 2019 at 9:47 pm #4650481

philippeL-20

Hi Bigul, thank you for your support!
We've installed the new version of WPML 4.2.9 and the problem seems solved 🙂
We'll check again on our next posts with tags in the different languages we use ...

Thank again for this new version and for your good support
Kind regards
Phil

September 27, 2019 at 7:44 am #4652073

philippeL-20

Hi Bigul,
we still have the problem .. we've modified this morning a post with 2 tags in english ; we've translated with WTE in spanish and in the spanish post the tags are replaced by the tag_ID !!

September 27, 2019 at 2:38 pm #4655237

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please try the following steps and make sure you are getting the expected result or not. Because this workaround is working for the other clients.

a) Temporarily disable one of the plugins (WPBakery Page Builder or WPML Media)
b) Fix the tags using Quick Edit and save the changes
c) Enable the plugin again

--
Thanks!

Bigul

The topic ‘[Closed] Translated tags incorrectly displayed with new version 4.2.8’ is closed to new replies.