Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Mateus Getulio 7 months ago.

Assigned support staff: Mateus Getulio.

Author Posts
May 1, 2021 at 12:03 pm #8667769

muneerC

Tell us what you are trying to do?
I use toolset select field and translate the value from default english to arabic
In arabic website the select field value still show english not arabic

What is the link to your site?

hidden link

skmca.JPG
May 3, 2021 at 4:48 am #8672473

muneerC

Hi

any update

May 3, 2021 at 3:10 pm #8677649

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Welcome to our support forum. I'll be happy to assist you with this!

Please make sure you're following our documentation related to how to translate custom fields: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/, particularly the section "Indicating Which Custom Fields to Translate". Also, after a full site backup, try this procedure:

- Go to WPML -> String Translation
- Use the search box to find one of the strings that are not being translated
- Once you find one, change the language of the string by selecting it (by marking the checkbox) and use the "Change language of selected string" button at the bottom
- Change the language to the default language of your site
- Do the same procedure for the other problematic strings and check if they appear on the front-end

Let me know if that helps. If the problem persists, then we might be facing an interaction issue with a third-party functionality, in this case:

- Backup your website before proceeding
- Deactivate all the plugins that are not related to WPML
- Switch for a moment to a WordPress default theme like Twenty Twenty-one
- If the issue is gone, activate one by one to see with which one there is an interaction issue

At last, I'd appreciate your help attaching the Debug info. See how to retrieve and paste it here: https://wpml.org/faq/provide-debug-information-faster-support/.

In summary, these are the steps that you need to take to retrieve it:

- Go to WPML > Support > Debug Information
- Copy the Debug Information from there
- Find the "Additional Data" section below this chat
- Click on the "Debug Info" item to expand it

I'm enabling the Debug Info template for your next reply.

Thank you, please let us know,
Mateus.