This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 13 replies, has 2 voices.

Last updated by Bruno Kos 3 months ago.

Assigned support staff: Bruno Kos.

Author Posts
July 19, 2019 at 7:36 am #4244617

geoclimaS

Hello,
I've changed the Title and permalink of one page and done the same with all the other languages, but this seems to spoil my website. The english version looks ok but all other languages are a mess.

What I did is:
1) changed the old page "www.geoclima.com/mission/" into "www.geoclima.com/thinkforward/". I edited both title and permalink so my translated pages would be "www.geoclima.com/it/thinkforward/" etc.

But now if I try to reach on of them I get only the english version.
Plus, all the menus of those pages are messed up.

Now I have to hide all other translations, only english version is visible.

July 19, 2019 at 8:40 am #4244953

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup

Regards,
Bruno Kos

July 19, 2019 at 12:05 pm #4246213

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

From what I see, you have never used "WPML Translation Management", correct? As for the issue, can you tell me if you have some sort of redirect set?

Because I went to change "Language URL format" to "Language name added as a parameter (hidden link - German)", It worked. I was able to open "hidden link" page then ( not with the URL, of course). Each time if this option is not set, it takes me to the homepage, as if no other pages exist ( or that one).

Can you tell me if this is the only affected page, or if there are others? Perhaps deleting and translation and re-creating those installations anew would help if there is only one page effect.

However, can you please check if this issue appears when:

- only WPML plugins are activated, as it will tell us if there is an interaction issue with other plugin
- theme is set to a WordPress default like Twenty Nineteen as it will tell us if there is an interaction issue with your theme

Regards,
Bruno Kos

July 19, 2019 at 1:14 pm #4246681

geoclimaS

I'm not sure I understand what you mean as redirect set? I have Yoast installed and when I changed the title/permalink page it asked me to redirect it to the new url.
I started experiencing the issue only after editing title/permalink, before that everything was ok.
What about the messed up menus?
I try testing as you suggest.

July 19, 2019 at 1:26 pm #4246745

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Let us deal with the non-working URL first, we will focus on the menus after this. Because without having working pages, we cannot synchronize menus either, because WPML will have no correct data to synchronize original menu items and their translations.

Ok, let me know how it goes with the testing.

Regards,
Bruno Kos

July 19, 2019 at 1:52 pm #4246853

geoclimaS

I can reach pages on other languages but the menus are messed up. I had the same problem weeks ago when I restyled the website and deleted/added a few pages. So I had to delete menus and recreate them. I guess there's something wrong on WP Menu Sync.

Switching to Twenty Nineteen I lose the menus so I can't jump from one language to another. But writing the new url I keep getting to the homepage instead of reaching the page I want.

July 19, 2019 at 2:04 pm #4246921

geoclimaS

Maybe I've found something.
I remember I already had a hidden link page months ago but I deleted it. Maybe there's a trace in dB causing conflicts. In fact, if I change the url to hidden link the non-working url issue seems solved.

July 22, 2019 at 5:56 am #4254095

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you tell me what should I focus on now - is the issue with the "think forward" resolved, so should I have a look at the menus issue now? Perhaps you could provide me some information on what the issue is - are the menu items on translated menus not aligned with originals?

Regards,
Bruno Kos

July 22, 2019 at 6:22 am #4254171

geoclimaS

The slug issue has been solved using another word.
The menu issue remains.
Do I have to recreate them manually or is there a quicker fix?

July 22, 2019 at 9:20 am #4255385

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I went to:
WPML -> WP Menus Sync:

Have a look at what I'm seeing - it doesn't seem that many menu items needs to be added, but it does seem that most of them needs to change location. I checked the original menu and the reason for this seems to be that on translated menus, no parent item is set on translations, hence causing all menu items showing in the same row.
E.g.:
hidden link

Compare with:
hidden link

Syncing menus using that function should remedy this.

Regards,
Bruno Kos

July 22, 2019 at 9:48 am #4255571

geoclimaS

I've never used this tool.
What am I supposed to do?
Afrer clicking on Sync, should I thick all the items or what?
I've just applied changes and nothing happened.

July 22, 2019 at 1:06 pm #4257607

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

On the next step, I have chosen all the menu items and click the apply. After a few seconds, they got synced and from what I see on the German or Italian menu, it is properly synchronized.

When I checked Italian page, it seems to me that menu is properly handled now, while menu titles in the menu correspond to the translated page titles (see images).

Regards,
Bruno Kos

July 22, 2019 at 1:27 pm #4257901

geoclimaS

Actually, I keep on seeing issues on menu. I'm afraid I need to edit them manually.

July 22, 2019 at 1:50 pm #4258109

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I'm afraid I need to edit them manually.

Let me know what else can I assist you there with.

Regards,
Bruno Kos