Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:

Translating a page gives unexpected results

Solution:

Some of the Astra options (Astra settings on the editing screen of the page) were set to 'Don't translate' and this caused the issue. Here is what I did to solve it.

1. I scrolled down to the Multilingual Content Setup section

2. For the Custom Fields, I pressed the Show system Fields link.

3. Then more fields' settings are revealed.

4. I checked the 'Copy' option for all those fields and pressed the 'Apply' button.

5. Then I made a small change in the page (just added a dot or a comma) and updated the page.

6. Then I updated the translation to 100% complete.

And now the transparent header and other settings are showing correctly on the English page.

Relevant Documentation:

100% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by bengtR 1 year, 7 months ago.

Assigned support staff: Itamar.

Author Posts
January 28, 2020 at 2:43 pm #5378173

bengtR

Hi!

I was today trying to translate my first page. I am translating from Swedish to English. I use Astra Theme Pro and Elementor Pro, both the latest versions (as of today).

I got to Pages and click Edit for the page "Hem" (="Home").

On the Edit page I go to the setting Language and click on the "+" besides English.

It opens the the translation page where a translate all the strings until I get 100% complete.

When I look at the translated page, the header is not transparent (as the Swedish original) and it is also showing the "Home" heading below the menu which it shouldn't. I could not find how to change these issues. Suggestions?

So I decided to delete the translated page permanently. After that the home page looked trashed somehow when I looked at it while inside the admin interface. It showed only two blogs. Most of the sections on the page seemed gone. But if I looked at the home page anonymously it looked as normal. And if I tried to edit some other pages, I couldn't open them in edit mode - I got 403 errors.

I had to restore the site to an earlier backup to be able to edit the site again.

I then tried to do the same thing again, but with the same result.

Is there a known conflict between Astra and WPML? Are there some settings which I haven't set in the right way?

Please help!

Best,
Bengt

January 28, 2020 at 10:08 pm #5380655

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi Bengt.

According to what I can see in our internal documentation the issue that you have might be related to the Ultimate Addons for Gutenberg plugin that you are using.
https://wordpress.org/plugins/ultimate-addons-for-gutenberg/
Are you using this plugin on the pages where you have this problem?

Also please correct the following to make sure that it is not causing this issue.
By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform that procedure and see if it help?

Thanks,
Itamar.

January 29, 2020 at 8:48 am #5382461

bengtR

Hi!

Thanks for your answer! I have no possibility right now to test this. But I have disabled Ultimate Addons for Gutenberg plugin (as I don't use it).

But I need a clarification on WP_MEMORY_LIMIT. I am rather new to WordPress (I am more of a Drupal developer) and I understand that 40M is the default WP memory limit.

I sort of followed the instructions in this article: hidden link. It is from 2018 and it actually says that WPML defines WP_MEMORY_LIMIT in the wrong way. How do you comment that?

Anyway, I used this settings in my wp_config.php:

/** Memory Limit **/
define( 'WP_MEMORY_LIMIT', ini_get( 'memory_limit' ) );
define( 'WP_MAX_MEMORY_LIMIT', ini_get( 'memory_limit' ) );

In WPML's support info it now says below "WordPress":
Memory limit: 512M
Max memory limit: 512M

So have I defined it right?

I will report back how it works when I test.

Best,
Bengt

January 30, 2020 at 10:54 am #5391407

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Bengt.

I'm not familiar with the specific constant that you are using. More information about WP Memory can be found here.
https://wordpress.org/support/article/editing-wp-config-php/#increasing-memory-allocated-to-php
If you get the above setting (512M) in WPML -> Support then it looks like things worked for you and it's Ok now.

I'll wait to hear from you.

Regards,
Itamar.

February 2, 2020 at 4:50 am #5406305

bengtR

Hi!

Now I tested again. I have inactivated the Ultimate Addons for Gutenberg plugin and I have increased WP_MEMORY_LIMIT to 512M.

I did the exact same procedure as described in the first post and with the exact same unexpected results.

First, the header is not transparent on the English. Why? See attached image wpml-no-transparent-header-in-english-translation.jpg. My listings of books and blogs on the page does not show at all, but that I think is because they are not translated yet, right?

Then I throw the translated page into the Trash and no the weird things happens. When I look at the Swedish original it looks like in attached image wpml-swedish-page-after-trash.jpg. Most of the Swedish original seems to be gone. And the English page can still be seen (even after emptying the cache on both server and browser), but now only the header - yes, now you can see the transparent header, it seems!! - and footer. See attached image wpml-english-page-after-trash.png. Why this? And why is it still accessible after the trash?

After I permanently deleted the English translation, the Swedish original still looks wrong, but the English can't be accessed.

Before I permanently deleted the English translation, I opened the Swedish original inside Elementor, and it look fine and intact. See attached image wpml-swedish-page-after-trash-in-elementor.png.

After an UpdraftPlus database restore everything looked just fine again.

So why doesn't the translated page have a transparent header? Have I missed a setting somewhere? And why can't I delete a translation without weird results? I get no error messages inside the admin interface.

Best,
Bengt

wpml-swedish-page-after-trash-in-elementor.png
wpml-english-page-after-trash.png
wpml-swedish-page-after-trash.jpg
wpml-no-transparent-header-in-english-translation.jpg
February 3, 2020 at 8:43 am #5410011

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the screenshots.

When sending pages and posts to the trash you must also permanently delete them from the trash section. Otherwise, you can get unexpected results. If there are any uncomplete Translation Jobs you also need to cancel them from WPML -> Translation Management.

I want to check things on your site. Can you please give me access?
Please explain to me the exact steps that you are taking before the problem happens.
Write to me: "Do 1. 2. .3 and so on"

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

February 5, 2020 at 4:34 pm #5432475

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

Some of the Astra options (Astra settings on the editing screen of the page) were set to 'Don't translate' and this caused the issue. Here is what I did to solve it.

1. I scrolled down to the Multilingual Content Setup section
2. For the Custom Fields, I pressed the Show system Fields link.
3. Then more fields' settings are revealed.
4. I checked the 'Copy' option for all those fields and pressed the 'Apply' button. Please see the attached screenshot ast-op.jpg
5. Then I made a small change in the page (just added a dot or a comma) and updated the page.
6. Then I updated the translation to 100% complete.
And now the transparent header and other settings are showing correctly on the English page.
Please see the attached screenshot ast-ok.jpg

Can you please confirm that this is solved now?

Regards,
Itamar.

ast-op.jpg
ast-ok.jpg
February 5, 2020 at 7:38 pm #5433823
bengtR

Hi!

That sounds great!, thanks. But before I test, have you also tried to permanently delete the English translation of the page? Did it work without strange results for the Swedish original page? Of cours, I can test that, but I think it is better if you do that, in case of any problems (which I had).

Best,
Bengt

New threads created by Itamar and linked to this one are listed below:

https://wpml.org/forums/topic/split-when-deleting-the-translation-the-homepage-settings-change/

February 6, 2020 at 10:18 pm #5442719

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see the problem.

We'll continue to handle the other issue here.
https://wpml.org/forums/topic/split-when-deleting-the-translation-the-homepage-settings-change/

Please mark this ticket as resolved.

Thanks,
Itamar.

February 7, 2020 at 3:54 am #5443717

bengtR

My issue is resolved now. Thank you!