This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.51 hours from now. Thank you for your understanding.

This topic contains 15 replies, has 2 voices.

Last updated by Diego Pereira 6 months ago.

Assigned support staff: Diego Pereira.

Author Posts
April 2, 2019 at 12:49 pm

mardinS

Hi

April 2, 2019 at 1:40 pm
April 2, 2019 at 1:48 pm
April 2, 2019 at 1:49 pm #3518035

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I sent the instructions to replicate the website through a private message (previous answer).

Please let me know if it worked for you.

Kind regards,
Diego

April 2, 2019 at 2:36 pm #3518353

mardinS

Hi Diego, I did everything now and waiting for the site to migrate

April 2, 2019 at 3:53 pm #3518985

mardinS

It is finished now

April 3, 2019 at 11:39 am #3525549

mardinS

Any news?

April 3, 2019 at 4:45 pm #3528889

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thank you. The migration worked. I removed the sensitive user data and also deleted all orders on the copy. I will send you the credentials on a private message in case you want to check.

Now I will run some tests to investigate the issue and will send you a feedback soon.

Kind regards,
Diego

April 3, 2019 at 4:46 pm
April 4, 2019 at 8:12 pm #3538317

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

The issue seems related to the Advanced Translation Editor. I duplicated the product then translated using the Classic Translation Editor and it worked as expected: hidden link

I'm checking this issue with my team and will send you a feeedback soon.

Kind regards,
Diego

April 5, 2019 at 7:34 pm #3546595

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I fixed the issue using the steps below:
- Update WPML + All Extensions to the lastest version. You can download from here: https://wpml.org/account/downloads/ - If you need to update manually, you can use this plugin to speed-up the proccess: - Install this plugin (it will speed up the update process): https://wordpress.org/plugins/easy-theme-and-plugin-upgrades/
- Go to Products > All products
- Change the language to english using the language switcher at the top admin bar
- Delete the english version of the product
- Delete it from the trash as well
- Go back to Products > All Products and switch back to the default language
- Click on the "+" icon to create a new translation for the product
- It should open the Advanced Translation Editor. On my test the strings was already translate. So I just finished and delivered the translation

With these steps, the attributes are translated on the english version of this product: hidden link

IMPORTANT: Please backup your site first before making any change, this is important for security reasons.

Please let me know if it worked for you.

Kind regards,
Diego

April 10, 2019 at 12:22 pm #3575935

mardinS

Hi Diego,
So I need to delete the products from all languages and then add them all over again?

April 10, 2019 at 6:43 pm #3580407

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

You need to delete only the products with the issue (select attributes not translated), and only from the secondary languages (don't delete the original). There is no need to delete all products.

When creating the new translation, the Advanced Translation Editor will load the existing translated texts. so you will not need to translate the texts again (just create the new translation and save).

I suggest testing before with just one product and then apply to others. I also recommend doing a backup of the website before, so you can restore if anything goes wrong.

Please let me know if it worked for you.

Kind regards,
Diego

April 13, 2019 at 3:37 pm #3605041

mardinS

I followed your instructions and while the attribute title changes, the variations still appear in Swedish on every language.

April 15, 2019 at 5:56 pm #3615579

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Please send us access to your WordPress dashboard (website URL, login and password). I tried the credentials from the first post but it not worked. I'll check the website and do some tests. - Please use the private field to send the sensitive data - do not post if you do not see it.

Please also send us also a link to a product that I can run the test (delete the translation then translate it again).

>> IMPORTANT: Please backup a working copy of site files and database before.

Kind regards,
Diego