This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Michael 11 months, 4 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 4, 2019 at 9:52 am #4142099


I am trying to: translate the biography for my authors using the string translation section, but it doesn't do anything

Link to a page where the issue can be seen:
hidden link

I expected to see: the biography of "Tristan" in Spanish instead of English when looking at the Spanish version

Instead, I got: the English biography on the spanish page

I've alreayd applied what I read on a similar topic:
- access the left admin menu WPML > String translation
- on the bottom right of the page there will be a box with the title "More Options"
- click on the "edit" link and select the ckeckbox for "Author" and click "Apply".
- access the left admin menu WPML > Theme and plugins localization
- after the initial options and listing find the button "Scan the theme for strings" and click it
- access the left admin menu WPML > String Translation
- on the filter field "Select strings within domain" select "Authors". The page will then refresh itself

You can find some screenshot to see what I've done.
I've cleared the cache as well, and translations for other strings do work.

July 4, 2019 at 3:40 pm #4145149

Mihai Apetrei

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:


- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 8, 2019 at 4:32 pm #4164365

Mihai Apetrei

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that they work.

I will spend more time on this and I will get back to you as soon as I have more feedback.

I will currently leave the ticket assigned to myself, too.

Kind regards,

July 9, 2019 at 2:34 pm #4171883

Mihai Apetrei

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

I was also able to reproduce the issue on your site.

Can you please try this:

1. Create a full backup of the site first
2. Now:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that goes and if following any of these steps solves your issue or bring any change.

I will be waiting for your response.

Kind regards,

July 16, 2019 at 12:21 pm #4220105


I haven't tried the solution yet, but if it doesn't work I will let you know and open a new ticket.



July 16, 2019 at 12:22 pm #4220111


Will solve it later, it will take a long time to test.