This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by salvadorC 1 year, 5 months ago.

Assigned support staff: Bigul.

Author Posts
May 2, 2018 at 8:08 am #1924234

salvadorC

Tell us what you are trying to do? Translate subscription text

Is there any documentation that you are following? No

Is there a similar example that we can see? No

What is the link to your site? hidden link (to see the text you need to pre-purchase a product)

Hi there!
I´m using Mailchimp for WooCommerce (https://wordpress.org/plugins/mailchimp-for-woocommerce/) in my web site and want to translate the subscribe text which I´ve created in Opt-in Settings.

I go to translate text strings but can´t find it.

Any suggestions.
Thanks!

May 3, 2018 at 7:33 am #1948750

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

In some cases, it is possible that those strings have been recognized but not associated yet to the String Translation panel for the translation. Please try the following steps after a backup and let me know your feedback.

1) Please increase the *MaxInputVars* of PHP settings to *10000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

2) Visit WPML>>String Translation
3) Click on the blue link at the bottom of the page: "Translate texts in admin screens »"
4) Look for an option similar to "mailchimp_for_woocommerce", or something like that. Here you should find all strings associated with your plugin options.
5) Check the checkbox for your strings of interest.
6) Click on the button "Apply"(at the bottom of the page)
7) Now, all your selected strings should appear in the String Translation panel and you can translate those strings

Please check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/translating-theme-options/

https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

If you are still having the issue please share me few screenshots for a better understanding.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

May 3, 2018 at 8:44 am #1950821

salvadorC

Hi Bigul.
I have done all the things you told me, but I´m unable to find the string. I send you a couple screenshots

May 3, 2018 at 4:54 pm #1963461

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please fill the private details fields after a full site backup. I would like to access admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Also please let me know the steps reproduce the issue in the frontend. Becuase I am not able to find the string in the Checkout page here.

--
Thanks!

Bigul

May 4, 2018 at 6:23 pm #1980034

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. The *Quiero recibir vuestras novedades* string is registered for the translation. I choose it from *mailchimp-woocommerce* string domain. But still, it is not showing for translation. Please check the attached images for more details.

Maybe you are facing this issue because of compatibility issues. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

May 7, 2018 at 7:36 am #2003794

salvadorC

Hi Bigul.
I´m unable to do what you tell me because my site is on production.
Any other suggestion?
Thanks!

May 7, 2018 at 8:19 am #2005224

salvadorC

Hi Bigul.
I just make a local copy of the website and make all the things you tell me.
I deactivated all plugins except WPML Multilingual CMS, WPML Translation Management, WPML String Translation, WPML Media, WooCommerce Multilingual, WooCommerce and MailChimp for WooCommerce.
I also switch the theme to Storefront (2017 has no compatibility with WooCommerce).
The problem persists.
I also got and other error (see the attached image)

May 7, 2018 at 12:35 pm #2011526

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. I would like to debug further to track the issue. So please allow me to make a duplicator copy of your site using Duplicator plugin -https://wordpress.org/plugins/duplicator/ for debugging the issue on my local server.

--
Thanks!

Bigul

May 7, 2018 at 1:35 pm #2013138

salvadorC

Go ahead!

May 8, 2018 at 5:13 am #2023225

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the permission. I have tried to make a duplicator copy of your site. But it is showing *host build interrupt* error. Please check the attached images for more details.

Therefore now I am trying to replicate it in a fresh installation. Will get back to you soon. Please wait.

--
Thanks!

Bigul

May 8, 2018 at 7:24 am #2024400

salvadorC

Hi Bigul.
The website is to big and needs lots of time to make the package. The server always returns timeout error.
I await your comments

May 8, 2018 at 6:24 pm #2038249

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I have a request. Please share me the API Key you are using in MailChimp Settings. I have generated an API Key in Mailchimp. But it is always giving *API Key Invalid* message. Please check the attached images for more details.

--
Thanks!

Bigul

May 10, 2018 at 5:35 pm #2077852

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the API Key. I can reproduce the issue in a fresh installation and the issue is existing after the initial debugging procedures. Please check the attached images for more details.

Therefore I am escalating the ticket to our compatibility team for further debugging. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

May 24, 2018 at 6:15 am #2219839

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind information, we have a workaround to fix this issue. It is happening because String Translation is not been initialized when *MailChimp for WooCommerce* is initialized. It worked for us after the following steps. Please try it after a site backup and check you are getting the expected result or not.

1) Visit *wp-content/plugins/mailchimp-for-woocommerce/* folder
2) Open *mailchimp-woocommerce.php* file for edit
3) Scroll down to line 40 and do the following changes

From

add_action('plugins_loaded', 'mailchimp_on_all_plugins_loaded');

To

add_action( 'plugins_loaded', 'mailchimp_on_all_plugins_loaded', 12 );

4) Save the changes
5) Visit WPML>>Languages, scroll down to *Language filtering for AJAX operations* section
6) Choose *Store a language cookie to support language filtering for AJAX* option and save the settings
7) Then clear all types of caches

We have forwarded this details to *MailChimp for WooCommerce* author and hope they will include this fix in next release.

--
Thanks!

Bigul

May 24, 2018 at 9:04 am #2220767

salvadorC

It works!