This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
Translating contact form on home page for Zerif Lite using WPForms

Solution:
1) Copy the following code in WPML->Settings -> Custom XML configuration

<wpml-config>
    <admin-texts>
        <key name="theme_mods_zerif-lite">
            <key name="zerif_contactus_shortcode"/>
        </key>
    </admin-texts>
</wpml-config>

2) Once you place the code there, go to WPML-> Settings -> Multilingual content setup and refresh the page.

Once you have created language configuration files you need to go to WPML->String Translation and search the strings that you have inserted in the theme options and translate the shortcode or use the same shortcode for the secondary languages.

Relevant Documentation:
https://wpml.org/documentation/support/language-configuration-files/

This topic contains 7 replies, has 2 voices.

Last updated by Anders 11 months, 4 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
October 22, 2018 at 9:17 am #2837405

Anders

I've created separate WPForms forms as suggested elsewhere, yet Zerif Lite Customize will not care about active language setting, so I can't insert the right shortcode at Contact Form Shortcode per language.

How do I get around this?

October 23, 2018 at 4:55 am #2840732

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Can you please elaborate a little more so I can better understand? Are you adding the shortcode using Appereance->Customize?

Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Look forward to your reply.

Thanks

October 23, 2018 at 8:32 am #2841433

Anders

Yes, but the same shortcode applies to both languages. When I set for one language that applies also to any other language. There's simply only one setting.

Do I need to make a string translation for the shortcode?

See screenshot.

October 23, 2018 at 9:07 am #2841623

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I would like to view the settings of your site once, so, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues need some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

October 23, 2018 at 10:48 am #2841865

Anders

I can't give you such access. The site contains a lot of custom/proprietary code. Also, providing database content would violate GDPR etc. So no.

The form shortcode is not available via string translation, so I can't override it that way.

I'll try to find a workaround.

Thanks anyway,
Anders

October 23, 2018 at 11:19 am #2841945

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

It's ok if you can't provide the login details, usually, when login details are provided it's easy to debug the issue.

Could you please follow the below steps and let me know if this helps:

1) Copy the following code in WPML->Settings -> Custom XML configuration

<wpml-config>
	<admin-texts>
		<key name="theme_mods_zerif-lite">
			<key name="zerif_contactus_shortcode"/>
		</key>
	</admin-texts>
</wpml-config>

To understand how to find the key name, please follow the steps provided in the link: https://wpml.org/forums/topic/admin-string-translations/#post-1438841

2) Once you place the code there, go to WPML->Translation Management -> Multilingual content setup and refresh the page.

To find out more, https://wpml.org/documentation/support/language-configuration-files/

Once you have created language configuration files you need to go to WPML->String Translation and search the strings that you have inserted in the theme options and translate it for the secondary languages.

Look forward to your reply.

Thanks

October 23, 2018 at 12:01 pm #2842223

Anders

That worked, thanks.

Some of the information you provided was of no use, which confused me a bit:

"https://wpml.org/forums/topic/admin-string-translations/#post-1438841"
As the XML was correct there was nothing extra to do (no Inspect needed etc), so this page didn't provide any new information.

"Once you place the code there, go to WPML->Translation Management -> Multilingual content setup"
There's no "Multilingual content setup" on that page, but I refreshed the "Translation Management" page.

As seen in the picture the Name value looks a bit peculiar, but it does what it's supposed to do.

Shouldn't this normally be set up automatically?

Anyway, thanks again.

October 23, 2018 at 5:11 pm #2843629

Anders

My issue is resolved now. Thank you!