This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How can I translate the widgets included in my Flatsome theme options?

Solution: Go to WPML > String Translation and scroll down to the bottom of the page and click on the link "Translate texts in admin screens »". Then, scroll through that page and see if you find the the string. If so, tick the checkbox and click Apply to add it to the String Translation table. Now you can go back to WPML > String Translation and you should see the string added there.

This topic contains 9 replies, has 3 voices.

Last updated by robertop-5 1 year, 1 month ago.

Assigned support staff: Lauren.

Author Posts
August 31, 2018 at 12:43 pm #2693723

andreasm-26

Hi , i have this site hidden link and i try to translate it to polish language.

I use flatsome child and at parents theme top bar i have 3 widgets , one is html and the other two is flatsomes widget (contact us) where i have my shop phone.

( the right one , has a button , is costum made , html that has a text inside that i want to translate , is a click pop up button ) image*

The left one is widgets of flatsome (contact , and a newsletter pop up that i want to translate as well ) image*

So i cant make it with sting translations , once i used them and i saw my site broken so i had to recover it with a back up .

How can i translate this two parts easily ?

Thanks

August 31, 2018 at 2:04 pm #2693963

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

The only way to translate the content is by using String Translation. You mentioned that you tried this and something was broken - can you please explain what was broken?

Once you are able to activate String Translation, these strings should be found in the admin texts. Can you please go to WPML > String Translation and scroll down to the bottom of the page and click on the link "Translate texts in admin screens »". Then, scroll through that page and see if you find the the string. If so, tick the checkbox and click Apply to add it to the String Translation table. Now you can go back to WPML > String Translation and you should see the string added there.

Please let me know if you need any further assistance and I will be happy to help.

August 31, 2018 at 2:17 pm #2694118

andreasm-26

I am so sorry , i go to string translations to find what ? i dont understand , lets say that i will find something that i will recognise after what i am doing ? you said "Now you can go back to WPML > String Translation and you should see the string added there." after ? please remove my images later , i thought they were hidden

August 31, 2018 at 2:32 pm #2694188

andreasm-26

I saw a reply in a similar thread right now , you went to admin_texts_theme_mods_flatsome-child and you inserted this to string translations , after what i am supposed to do ? :/

August 31, 2018 at 5:10 pm #2694750

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Once you find the strings in the admin texts, tick the checkbox and click Apply to add the strings to the string translation table. The, go to WPML -> String Translation and add the translated strings. Check the box to mark it as complete and save your changes.

September 5, 2018 at 1:06 pm #2707185

andreasm-26

Hallo , i found the string translation and after a couple of hours i understood how it works , and i found also there some more things i wanted to do so thanks . But , i cant find the html text , and the pop up i want it to translate in the first place, i have looked like 10 times but nothing , the string that is my html , has only number values .

September 5, 2018 at 1:29 pm #2707339

andreasm-26

Hey , sorry i found it! i had to open the links there , and yes now i saw it . so what i did is to tick them and go to the admin translation . i translated it but it does not apear translated . should i do something more ? thanks

September 5, 2018 at 3:01 pm #2707743

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please make sure that the strings you added from the admin texts are from the correct theme. If you are using a child theme, check the admin texts to see if the same strings exist in the child theme and if so, make sure those are the ones you are translating. You can also try increasing the WP Memory. You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

If that does not resolve the issue, I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

September 12, 2018 at 7:14 am #2726332

andreasm-26

Thanks i found it finaly

July 26, 2019 at 9:09 am #4288591

robertop-5

Hi,
i have the similar problem but after translate the topbar on ENG pages i see ITA version again..
Here the print-screen:
1) hidden link
2) hidden link

any suggest?

thank you
regards