This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 3 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 16, 2019 at 1:12 pm #4220275

brianG-6

Hello,

I'm displaying address fields on my custom post type utilizing custom fields. I want to allow the translator to translate the address, but I still want it to show if they haven't got to it yet. Copy once won't let the translator translate it, but translate won't show the field if there's no translation? How can I make this happen?

July 17, 2019 at 1:40 pm #4230671

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. In this case I recommend using the 'Copy Once' options as it will be copied the first time but let you change it later, so using it, you will be able to translate it when it is convenient. See: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/. Please, let me know if you need any additional assistance, have a nice day.

July 18, 2019 at 4:10 pm #4240811

brianG-6

Thank you, but 'copy once' fields are not visible in the advanced translation editor, only 'translate' fields. Also, no custom fields are visible in the post edit screen even if I don't use the translation editor.

July 18, 2019 at 7:15 pm #4241995

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 19, 2019 at 8:21 pm #4248097

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. Can you please provide me with the details regarding which post type your custom fields are attached with and a sample post where I can see it? It will help me to perform some tests and understand the cause of your issue. Thank you for your collaboration, have a nice day.

July 19, 2019 at 9:33 pm #4248327

brianG-6

Sure! The post types you can test on are 'licensees', and the 'licensee' field group that goes along with it. If I add a link here, will it show as protected?

July 23, 2019 at 1:36 am #4261973

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details and sorry for the bit of waiting here due the weekend. I took a detailed look in your website and indeed only fields checked as 'translate' are visibile in the WPML Translation Editor and this is the expected behavior, when you choose the 'copy' or 'copy once' values, it is the expected behavior those values be copied from the default language to the secondary languages as your intention is to show them as it is, instead of showing a translated version of the value. So, the recommended workflow should be:

1 - Mark the fields you want the original value to be shown in all your website languanges as 'copy' if you want these values to be kept in syncrhonization with your default language, in other words if you change the value in the original language, all the other languages will show the updated value.

2 - Mark the fields you want the original value to be shown in all your website languanges as 'copy once' if you don't need these values to be kept in syncrhonization with your default language, in other words if you change the value in the original language the other languages won't reflect these changes and you can manually adjust the translated custom fields values later.

3 - Mark the fields as 'translate' if you need to show a translated version of your default language custom fields in your secondary languages.

When using the WPML Translation Editor only those fields marked as 'translate' will be shown in the editor for a good reason (you actually want to translate them).

See: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/.

At the other hand, if you want to keep control of all the custom fields in all your languages, be it marked as 'translate' or 'copy' and 'copy once', then, I recommend you to duplicate the page and edit these pages using the default WordPress page/post editor.

See: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Please, let me know if you need any additional clarifications. Have a nice day.