This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
Translate Select options and Radio options of the Divi Form

Solution:
Add the following code to WPML > Settings > Custom XML configuration

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>et_pb_contact_field</tag>
            <attributes>
                <attribute>field_title</attribute>
                <attribute>checkbox_options</attribute>
                <attribute>radio_options</attribute>
                <attribute>select_options</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

50% of people find this useful.

This topic contains 7 replies, has 3 voices.

Last updated by claudiaS-18 1 year, 3 months ago.

Assigned support staff: Diego Pereira.

Author Posts
June 22, 2018 at 7:39 am #2428641

dr.-lenkaK

I am trying to translate contact form fields (German > English) in the booking form on this page hidden link but unfortunately they are not appearing in the translation editor.

We have tried directly editing the English page version within the page builder without success and have not been able to find the fields within the String Translation section to translate them there.

Any guidance on how to do this would be greatly appreciated.

Thanks

James

June 22, 2018 at 1:20 pm #2429594

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @dr.-lenkaK, welcome to the WPML support Forum!

Usually this happens when some configuration is missing from the wpml-config.xml file.

Could you send us access to your WordPress dashboard (website URL, login and password) I'll check and do some tests. Please use the private field to send the sensitive data.

It would be better if you give me a test site rather than the live site.

IMPORTANT We always recommend to backup a working copy of site files and database before.

All the best,
Diego

June 22, 2018 at 7:15 pm #2430172

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello James,

I added the following code to WPML > Settings > Custom XML configuration

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>et_pb_contact_field</tag>
            <attributes>
                <attribute>field_title</attribute>
                <attribute>checkbox_options</attribute>
                <attribute>radio_options</attribute>
                <attribute>select_options</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

Now the Form options are displayed in the Translation Editor. It is not working smoothly because they're all encoded characters in the string. These characters do not show on the front-end. In the middle of the string with the characters, you will see the option that you need to translate so change only the option. I've attached a screenshot with an example.

If you do not see the fields, try modifying the original page (by adding a comma or space) and save it.

Please let me know if it worked for you.

All the best,
Diego

June 23, 2018 at 8:34 am #2430476

dr.-lenkaK

Hi Diego

Thanks for your reply - after re-saving the original page I can now see several of the fields in the translations editor but unfortunately most of them are still missing. Of the options fields, only two appear where there are actually 32 in total (please see screenshot). Will it be possible to make the remainder of the fields translatable?

Best regards

James

June 25, 2018 at 2:44 pm #2433043

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi James,

Actually all the options are available in the same input, but because the text is bigger than the field, they do not appear at first. You need to select and move the cursor to the side to see the rest of the content.

You can use these steps to translate them:
- Select all content of the input and copy
- Paste it to a text editor (i used notepad)
- Translate the Strings (see screenshot)
- Copy the content of the text editor, paste on the input and save

If you need more help just let me know.

Regards,
Diego

June 26, 2018 at 8:48 am #2434625

dr.-lenkaK

Thanks Diego - I have now been able to translate all the strings 🙂
James

June 26, 2018 at 11:50 am #2435089

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there, I'm glad to hear that the issue is solved ?

Please contact us if you need our help in the future with WPML. We will be more than happy to help.

Cheers,
Diego

October 30, 2018 at 5:06 pm #2862949

claudiaS-18

I have the exact same problem, but adding the code didn't do it for me… hidden link