This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem:
Translate WC MSRP plugin price prefix field content

Solution:
add the below custom xml configuration,in WPML > Settings > Custom XML Configuration tab

 <wpml-config> 
  <admin-texts>
    <key name="woocommerce_msrp_description">
     </key>
  </admin-texts>
</wpml-config>

This topic contains 4 replies, has 2 voices.

Last updated by Dennis van Essen 3 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 16, 2019 at 11:21 am #4219595

Dennis van Essen

Tell us what you are trying to do?
I am using the WC MSRP plugin. The price prefix field contents does not show in the string translation.
I have contacted the developer of the plugin and they say that the field content sis in the options table under "woocommerce_msrp_description"
How can I translate the field contents?

Is there any documentation that you are following?
I cannot find any.

Is there a similar example that we can see?
NA

What is the link to your site?
hidden link

July 16, 2019 at 12:12 pm #4220085

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello Dennis,

I will help you with your issue.

The strings stored in the options table are considered as admin_texts in WPML > String translation.

To register the strings from the options table
- Goto WPML > String translation, Scroll down to the bottom click "Translate texts in admin screens"
- A page with all the admin texts will open up, Search for the key "woocommerce_msrp_description" and add the selection to string translation

Reference : https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

Alternatively, You can also add the below custom xml configuration,in WPML > Settings > Custom XML Configuration tab

<wpml-config> 
  <admin-texts>
    <key name="woocommerce_msrp_description">
     </key>
  </admin-texts>
</wpml-config>

You can read more about the WPML XML config here: https://wpml.org/documentation/support/language-configuration-files/

Once added the string will appear in WPML > String translation under the domain admin_texts_woocommerce_msrp_description

I hope this helps you better, Let me know if you need further assistance.

Kind regards
Raja

July 16, 2019 at 12:23 pm #4220115

Dennis van Essen

Hi Raja,
Thank you for the swift reply.
I have tried your option 1 solution. I can find the admin text "woocommerce_msrp_description" and add the selection to string translation by ticking the checkbox. I then hit save. BUT: the selection does not save. When I refresh the page it is un-ticked again.. What could be the reason of this?

July 16, 2019 at 1:04 pm #4220243

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for trying out the solution,

If the string is not registering, then it could be due to site cache or PHP max input vars limitation.

- Try clearing the site and server cache check if that solves your issue.
- Increase PHP max input vars to 3000 your current value is 1000, You might need to check with your hosting provider if you don't have access to these settings.
hidden link

Kind regards
Raja

July 19, 2019 at 7:31 am #4244573

Dennis van Essen

My issue is resolved now. Thank you!