This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by Alejandro 3 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
June 29, 2019 at 3:24 pm

gustavsG

I am trying to: translate fusion slider

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: I got a blank slider. One thing that might have cause it was that I changed slider settings and now the slider settings have disappeared from the slider completely (see the picture attached and how it is different from the normal slider)

June 30, 2019 at 5:48 am #4113411

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Please follow the steps provided here : https://wpml.org/forums/topic/avada-fusion-sliders-2/#post-2933537

Let me know how it goes.

Regards,
Riffaz.

June 30, 2019 at 7:34 am #4113581

gustavsG

That doesn't really help me, sorry! Could you please tell me what I need to do?

June 30, 2019 at 12:35 pm #4114141

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I checked your site and yes, it does not work as expected.

After spending an hour I found out the in your second language the slider selection is not saved even if I select and save many times: hidden link

This could be because of the WP Memory limit: hidden link

Please increase is to 768 as your hosting allows you to use up to 768

Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');

If that does not help:

Debugging
1. Please follow the debugging information provided here: https://wpml.org/documentation/support/debugging-wpml/#enabling-the-built-in-debugging-feature-in-wordpress.
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know.

Regards,
Riffaz.

July 2, 2019 at 11:29 am #4126343

gustavsG

I already have the memory limit set to 768 (see the screenshot)

July 2, 2019 at 11:45 am #4126419

gustavsG

Not only that none of my slides are working now , except home.

July 2, 2019 at 12:00 pm #4126531

gustavsG

I fixed it now but the Latvian version sliders still dont work

July 2, 2019 at 12:06 pm #4126607

gustavsG

I deleted all Latvian sliders and tried to create one again and not I get the original error

July 2, 2019 at 12:49 pm #4127073

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

As you see this error does not come from WPML : hidden link
This comes from Fusion Slider.
Please show this to fusion slider / avada support.
they will be able to fix this fast.

Let me know how it goes.

Regards,

July 3, 2019 at 1:23 pm #4136809

gustavsG

Ok, they helped me with that issue but I still have another smaller issue.

Basically when I edit the English slider (Home) - when I change the title from left to center position, I want to automatically sync it to the Latvian translation as well but it doesn't happen and I have to edit it manually.

When I change the settings in the English version, the arrowed circle appears which I then press to update the translation but it only updates the words and not styling.

Am I doing something wrong?

July 5, 2019 at 6:59 am #4147969

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, my name is Alejandro.

Since Riffaz currently has a few days off, I will replace him here in the forum.
I hope this is OK with you.

I checked your home slider, and as you said, the changes are not going hrough. i'm asking advice to our developers and i'll let you know as soon as i have an answer from them.

Regards.

July 5, 2019 at 7:08 am #4148239

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Nevermind, i found the solution.

Turns out that avada authors set the WPML alignment settings as "copy once" which means they would be copied only once and then you'd have to change them manually.

To fix that you had to go to WPML > Settings > Custom Fields Translation > Find "pyre_content_alignment" > Set it to "Copy" instead of "Copy Once" (you might find it locked, that means Avada Authors set it. you can unlock it by clicking the lock button) i already set it for you and changed the alignment from left to center in the "Home" slider.

You can do the same if you find other elements that are not behaving as you wish, i noted that Avada set a lot of elements as "Copy Once" for some reason so they will be copied only the first time you translate them.

Regards.