This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bigul 1 year, 1 month ago.

Assigned support staff: Bigul.

Author Posts
April 4, 2019 at 4:01 pm #3536805

karenG-5

I am trying to translate the title and text of the Global Tab Content in WooCommerce's Shop Settings page and cannot get it to work.

I've gone to the Admin Strings and added them per the post here:

https://wpml.org/forums/topic/cannot-translate-global-product-tab-on-flatsome-theme/

but the text doesn't show up in String Translation, at least not when I search for it. Only the Admin Text shows up and when I paste the text in there it doesn't show up on the live site - because I think that's just the translation for the Admin Screen text. I can't find the Translation Strings for the content boxes themselves.

April 5, 2019 at 8:57 am #3542351

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

In some cases, it is possible that those strings have been recognized but not associated yet to the String Translation panel for the translation. Please try the following steps after a backup and let me know your feedback.

1) Please increase the *MaxInputVars* of PHP settings to *5000* or more. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

2) Visit WPML>>String Translation
3) Click on the blue link at the bottom of the page: "Translate texts in admin screens »"
4) Check the checkbox for your strings of interest.
5) Click on the button "Apply"(at the bottom of the page)
6) Now, all your selected strings should appear in the String Translation panel and you can translate those strings

Please check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/translating-theme-options/

https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

--
Thanks!

Bigul

April 5, 2019 at 5:40 pm #3546201

karenG-5

Bigul,

That worked perfectly, thanks! Should I remove that line of code from my .htaccess file now?

-Kent

April 5, 2019 at 6:58 pm #3546447

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Kent,

Thank you for the feedback. Happy to know the issue is resolved for you. You can keep a higher configuration for *MaxInputVars*(like 5000). Especially for an E-commerce site. Because it will support you better while dealing with many input variables.

--
Thanks!

Bigul