Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.61 hours from now. Thank you for your understanding.

This topic contains 38 replies, has 2 voices.

Last updated by Andreas W. 1 year, 1 month ago.

Assigned support staff: Andreas W..

Author Posts
June 21, 2019 at 9:38 pm #4069311

yvonneS-4

I do not see the Permalinks under settings. Can you send screenshot?

June 21, 2019 at 11:43 pm #4069485

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The issue with the homepage translation using the Advanced Trasnlation Editor might be caused due to the the Icon List string which is not diaplayed correclty. Please hold on until I receive feedback from our compatilbity team in regards to this issue.

Further, you can change the Translation Editor at WPML -> Settings -> How to translate posts and pages but it is not advisable to change back to the Classic Translation editor once a translation has been created with the Advanced Translation Editor, as you could loose translated content.

About the forms I would like you to take a look at the screenshot. I can see that there are froms properly created and translated. It seesm to be the case that each form for each language will need to be created individually on the WP Forms front end editor. You will afterwards only need to place the repective shortcode for each form on the repesective pages by using the default WordPress Editor.

You could also try to translate the pages manually for now. In order to do so go to the homepage on the WordPress page editor. In the right sidebar you should see a section call "Language". Here you should see the option (switch= on -> off) for enabling the WPML Translation Editor. Disable it and you will be able to edit pages manually using the default WordPress Editor.

Simply change the admin language in the top admin bar in order to change to the translated page respectively.

I hope this will solve the issue for now and I will get back to you as soon I receive feedback from our compatiblity team.

Kind regards
Andreas

June 25, 2019 at 12:47 am #4080215

yvonneS-4

If I disable WPML do I lose my translations and what will happen with the main navigation menus?

June 25, 2019 at 2:38 am #4080659

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

There is not any problem about deactivating WPML. All settings and translations are saved in the repective database tables.

We are still working on a solutions for the issues on the site. I will be be in contact tomorrow.

Kind regards
Andreas

June 25, 2019 at 6:13 pm #4086651

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I do have updates in regards of the provided issues.

The "Apply Online" plugin causes the issue that appears when it comes to change the default language of string on String Translation.

The issue can only be solved by modifying one of the plugins files but such changes would be overwritten with the next plugin update.

I would advise you to contact the plugin author and ask him to include the following fix into his plugin:

In wp-content/plugins/apply-online/admin/class-applyonline-admin.php:642 change from:

wp_enqueue_style('jquery-ui-css', '<em><u>hidden link</u></em>');to:
$screen = get_current_screen();
if ($screen->id !== 'wpml-string-translation/menu/string-translation') {
    wp_enqueue_style('jquery-ui-css', '<em><u>hidden link</u></em>');
}

The fix has been applied for now but take note that a plugin update will overwrite these changes.

Further, we were able to provide a fix for the item list widget issue on Enagage Core Plugin with WPBakery 6.

Here the respective documentation:
https://wpml.org/documentation/support/translating-urlencoded-shortcodes/

I have procceded as followed:

The respective section inside of the custom XML config has been replaced with:

<shortcode>
            <tag>vntd_icon_list</tag>
            <attributes>
                <attribute type="area" encoding="urlencoded_json">elements</attribute>
            </attributes>
        </shortcode>

Then the code from the above mentioned documentation under point 2. was added to the themes functions.php file.

At last I had to give the list icon widgets a small update and save the page again. Now you are able to translate the icon list strings.

Kind regards
Andreas

June 25, 2019 at 10:16 pm #4087327

yvonneS-4

Hi,

1. The "Apply online" plugin is deactivated fo a while. Can it still cause any problems even though? I can delete it.

2. Regarding the problems for the list and the "special headline" they still persist.

I went to the translation editor and pasted the English translation in the respective listings and saved. The English Version in the translation editor turns into the German Version in the front end. ( see screenshots)

Another issue is that whenever I make changes to the German website, for example I am still working on a carousel that wasn't there before the translation management shows the English and French version as "needs update". When I go to update the already by hand translated text into French will disappear and it will draw the German text versions into the page again.

This effects all parts of the page where the translation editor doesn't work— the list items, the "special header" and the forms, and the "team" shortcode.( where the management is placed) I mentioned before that I already redid those pages several times and always it replaces the German version.

I am at the point just trying to get this finished - with or without the WMPL.

My question is: How do I get this finished the best way with the problems persisting?
Should I turn off WMPL translation as you suggested before?

Or how should I act when the English and French versions ask for "needs update". Not update or update somewhere else maybe? Avoiding the old German text to be placed in the areas mentioned above.

Thank you!

June 25, 2019 at 11:15 pm #4087475

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The issue between String Translation and the plugin "Apply Online" has been solved. I have applied a fix for this. You can reactivate the plugin now.

I further applied fixes for the WPBakery page builder content of the page home and as far I can see now all strings show up correclty on the Advanced Translation Editor (ATE). The special heading is translated and the icon list element is waiting for you translation.

On pages which still show issues proceed as followed:

1) Go to the page editor and give a small update top the page builder elements that is not showing up correctly (for example with a tip on the "spacebar" at the end of the icon list ext) and save the page builder element.

2) Then update the page and translate it again. This should solve the issue and the string swill show up on the ATE.

I applied this to the About us page and the icon list strings are now showing up correclty inside the ATE. You can now complete the translation.

Kind regards
Andreas

June 26, 2019 at 2:53 pm #4093387

yvonneS-4

The screenshots are from the "about us" page.

I was able to translate the icon list.

The team and the Special header still do not show up in the ATE. And converted again to the German version. I had translated the text and buttons already.
See screenshots.

I went in the page builder and edited with what I understand you mentioned here

"1) Go to the page editor and give a small update top the page builder elements that is not showing up correctly (for example with a tip on the "spacebar" at the end of the icon list ext) and save the page builder element."

I hit of the space bar in the Special Header text and then saved it. It still does not show up in the ATE.

Or what do you mean with "small update top the page builder"?

Thank you.

June 26, 2019 at 3:35 pm #4093685

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Indeed there are signbificant compatibility issues when it comes to use dthe modified WPBakery Version of the Engagae Theme and I want to thank you very much for your patience.

I was now able to add the strings for employees and for the call to action element from your screenshots by enhancing the custom config at WPML -> Settings -> Custom XML Configuration. Make sure to leave this markup code as it is. If you would like to know how I achived this please feel free to ask, but otherwise reach out to us again, in order to help you to apply the changes.

All text strings inclusive button URLs are now showing up on the Advanced Translation Editor.

Kind regards
Andreas