This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Jamal 8 months ago.

Assigned support staff: Jamal.

Author Posts
January 25, 2019 at 8:35 pm

Dan

When going in to edit an existing translation or create a new one we can only see the Title field, and a Translation Priorities field everything else seems to be missing. This showed up about a week ago, it seemed to be working well prior to that. I believe we pushed through the latest plugin updates at that time, including the latest version of WPML.

I have run through several different support threads ie:
https://wpml.org/forums/topic/when-translating-home-page-it-shows-only-the-title/#bbp-new-topic

January 28, 2019 at 11:17 am #3135111

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

As far as i can tell page related data is stored in custom fields. Read more about it in this article
https://wpml.org/documentation/getting-started-guide/translating-custom-fields/
These custom fields were created using the ACF plugin, to translate these fields please use our
Advanced Custom Fields Multilingual (ACFML) plugin that you can download in your account page. https://wpml.org/account/downloads/

And follow this article on how to translate website built with ACF.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Let me know if this helps.

Best regards,
Jamal
WPML Support

January 29, 2019 at 8:10 pm #3141537

Dan

Jamal,

there are ACF fields that are not showing up, but as well the majority of the fields are from the installed Enfold Theme. Is there something else that we could check?

January 29, 2019 at 10:46 pm #3141793

Dan

If needed I can provide a dump of the site/db if that would make it easier...

January 30, 2019 at 9:28 am #3142842

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback,i checked again your website, with this information in mind, i found the wpml-config.xml in the enfold theme missing some part from our Enfold configuration that you can find here
hidden link

I copied the configuration in the WPML->Settings following this article.
https://wpml.org/documentation/support/language-configuration-files/overriding-language-configuration-files/

I wanted to make a small update to the page to see if it will be reflected, but the new Gutenberg editor is blocking me from scrolling the page, i tried the page provided in the first screenshot "Business Excellence".
hidden link

I wonder if you are using Gutenberg, if not, i would like to install Classic Editor plugin to disable Gutenberg.
https://wordpress.org/plugins/classic-editor/

Would you like to install the plugin, would you allow me to do so.
Please make sure to have a backup

Best regards,
Jamal
WPML Support

January 30, 2019 at 8:46 pm #3145636

Dan

Feel free to add what you need to test, just let me know what you add/remove. The Classic Editor Plugin has been installed.

With the Enfold theme you shouldn't see the Gutenberg editor... not sure why that would be blocking you from scrolling on the page. I have made a small edit to the page (adding a space to the hero content), saved the page and then checked the translations and they still look the same...

This site is our staging site, and is backed up regularly.

January 31, 2019 at 9:10 am #3146828

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I might have resolved this issue, i have to update the translation mode for custom fields as shown in this article
https://wpml.org/documentation/getting-started-guide/translating-custom-fields/
I could not scroll down to see the "Multilingual Content Setup" metabox, i guess because of Gutenberg, now that i was able to do so, i went edit the page Business excellence and the custom fields were not configured to get translated see attached image (Screen Shot 2019-01-31 at 08.47.16.png).

I set the hero_title and hero_content as "Translate"(See image Screen Shot 2019-01-31 at 08.53.10.png), click on "Apply", then save the page to push changes to translations, i did the same to the repeater field according to this article.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#making-acf-fields-translatable
But the repeater field was not visible until i did a small change to one of its subfields(changed "Customer Experience" to "Customer Experiences") and saved the page.
Then the fields were visible on the Translation Editor.

Check image (Screen Shot 2019-01-31 at 09.00.27.png) from WPML->Settings, when i set the repeater field as "Translate" all its subfields were set as translate.

Now it is only 12% of the page which is translated. See attached image (Screen Shot 2019-01-31 at 09.08.20.png)

I did purge the cache a couple of time to be sure it will not block something.

I hope this answers your request. I remain at your disposal.

Best regards,
Jamal
WPML Support

February 4, 2019 at 7:59 pm #3159286

Dan

Jamal, thank you for your help on this.
Going through the steps above does help with ACF custom fields. But we are still having issues with the fields in the Advanced Layout Builder for the Enfold Theme that we use, or it's shortcodes. It was working fine up until things broke. Do you have any thoughts in that regard?

Thanks

February 5, 2019 at 8:17 am #3160672

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Sure, we have a couple of articles about Enflod theme compatibility and the Avia Layout Builder, i assume it is what you are using.
https://wpml.org/documentation/theme-compatibility/enfold/
https://wpml.org/documentation/support/maintaining-avia-layout-builder-enfold-compatibility-wpml/

There is a section in the second article that covers shortcodes, if you have any doubts implementing this, please give me more details so i can look it up, what page ? what are you using in the shortcode or what shortcode ?

Let me know what you get.

Best regards,
Jamal
WPML Support

February 12, 2019 at 6:58 am #3186731

Dan

Jamal,

Thanks for your continued help with this issue. In the instructions that you linked here they indicate that I should be able to go to WPML > Translation Management and select the "Multilingual Content Setup" tab to enable the translation editor. But as you can see from the attached image the "Multilingual Content Setup" tab as well as other tabs are not visible.

Also the instructions mention the Avia Shortcodes which are used for the translation management tool, but when switching from the Advanced Layout Builder to the classic editor there are no shortcodes visible even after adding several elements in the builder. So I am not sure if the issue is something with the theme, or something with WPML or both...

Thanks again

February 12, 2019 at 8:52 am #3187308

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Translation Editor can be activated in WPML->Settings. I am not sure where did you find this instruction, maybe it has to be updated, please let me where it is like that, so we can correct it.

When you switch to the classic editor, most shortcodes will not be visible, unless it is unsupported/misconfigured, but their translatable content will be visible for translation.

To better investigate this, would you specify and example of content, from Avia(Advanced Layout Builder), that is missing in the translation. Screenshots may help.

Best regards,
Jamal
WPML Support

February 12, 2019 at 9:44 pm #3191038

Dan

The Translation editor activation was referenced in both of the links you sent over previously, both in text of: https://wpml.org/documentation/support/maintaining-avia-layout-builder-enfold-compatibility-wpml/ and the attached video in: https://wpml.org/documentation/theme-compatibility/enfold/

So looks like they both need to be updated. I went into WPML-> Settings and played with some of the Translation Editor settings, but it didn't appear to make any difference.

The attached screenshots show a page that was setup specifically for testing this. Feel free to add/remove any content to the page that you would like...

February 13, 2019 at 11:03 am #3193479

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I have tried several manipulations to test on that page without luck. Adding my user as a translator, updating the original page and saving. I can see two possibilities of this, even this is a new bug, or that there is a conflict with another plugin/theme.

To exclude the second possibility, can you debug any conflict issue with any other plugin using the Health Check plugin. See this video on how to debug conflicts.
hidden link
https://wordpress.org/plugins/health-check/

To verify it is a bug, i have created a clean server, please user credentials in the private message to upload your theme, configure WPML with a secondary language, then try to reproduce this error. If reproduced, i will push it to our compatibility team for further investigations.

Looking forward to your reply.

Best regards,
Jamal
WPML Support

February 13, 2019 at 11:27 pm #3196441

Dan

HI Jamal, I'm not seeing the private message with the credentials to your server, can you please resend?

Thanks!
Dan

February 14, 2019 at 10:04 am #3198598

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Dan,

My apologies, now i reactivated the private area.

Best regards,
Jamal
WPML Support

The topic ‘[Closed] Translating page or using XLIFF files only shows the title’ is closed to new replies.