Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: In my gravity forms, I am having trouble translating the paging string ("1 of 3"). I've found the string in string translations, but nothing that I add there is reflected on the translated form.

Solution: We've followed these steps:

- Went to WPML -> Theme and Plugin localization and re-scanned GravityForms - Then, in WPML -> String Translation, we searched exactly for the word "of" in the gravityforms domain

After entering the translation, it could be seen on the front end.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by normanL-3 4 weeks, 1 day ago.

Assigned support staff: Mateus Getulio.

Author Posts
May 6, 2021 at 6:44 pm #8708293

normanL-3

In my gravity forms, I am having trouble translating the paging string ("1 of 3"). I've found the string in string translations, but nothing that I add there is reflected on the translated form.

As an example, please see the first form on this page:

hidden link

Paging2.PNG
Paging.PNG
May 7, 2021 at 3:26 pm #8715437

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Norman,

Welcome to the WPML support forum!

In our documentation, we recommend translating Gravity Forms strings via the Translation Management Dashboard (in a proper translation job). Please check https://wpml.org/documentation/related-projects/gravity-forms-multilingual/. Have you done it?

In WPML 4.3.0, we filtered out those package strings in WPML -> String Translation because it was not supposed to be edited there, and it was bloating the string list.

We noticed that several users had a different workflow like you. Please check this errata https://wpml.org/errata/translating-layout-with-wpml/ (it applies to all package strings like the Gravity Form ones).

So, in summary, you can follow these steps in order to make the string translation available on the front-end again:

- Please go to WPML -> String Translation, select the problematic string and then click on the button "Add to translation basket"
- Go to WPML -> Translation Management -> Translation basket
- Send the jobs to translation and try to translate it again
- Check if the issue persists

Let us know if this helps. Moreover, by looking at your debug info, it is possible to see that the WP Memory Limit is set to 128M, which is good but the recommended is 256. Changing it can avoid this and other future problems. Please follow these instructions:

- Find your wp-config.php file in the root directory of your WordPress installation
- Open the wp-config.php file with a text editor, then locate the line that includes: define('WP_DEBUG', false)
- Then add after it, the below line of code: define ('WP_MEMORY_LIMIT', '256M');
- Save the wp-config.php file, then refresh your website

Give those steps a try and check if the problem remains. We're looking forward to your reply.

Kind regards,
Mateus.

May 10, 2021 at 4:02 pm #8731827

normanL-3

Thank you for replying Mateus.

Yes, I've tried translating the string by submitting to the translation basket, and just tried again to no effect. I've tried setting the VI translation through both string translation and the advanced editor, neither is working for me.

Our live site does have the memory set at 256M, we still have the same problem there.

Paging3.PNG
May 10, 2021 at 6:12 pm #8732511

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

May 10, 2021 at 8:45 pm #8733245

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Norman,

Thanks for the credentials. The website is restricted with additional protection. Please check: hidden link

Could you give us this login information? I'm marking your next reply as private so that you can put the new data.

Thanks,
Mateus.

May 11, 2021 at 4:28 pm #8742075

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

I checked this out but so far I couldn't find a fix for it.

I asked my colleagues to have a look at this issue in order to see if there's anything I'm missing.

I'll come back here as soon as one of my colleagues reply back to me (which it shouldn't take long).

Thanks,
Mateus.

May 13, 2021 at 1:12 pm #8757611

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I have escalated this ticket to our 2nd tier of support where our 2nd tier specialists will take a deeper look at this issue and will try to find a solution.

I will get back to you as soon as I get an answer from them.

Best regards,
Mateus.

May 14, 2021 at 1:37 pm #8766091

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Norman,

Thanks for your patience.

Upon further inspection, our team has found a solution for the issue. We've followed these steps:

- Went to WPML -> Theme and Plugin localization and re-scanned GravityForms
- Then, in WPML -> String Translation, we searched exactly for the word "of" in the gravityforms domain

After entering the translation, it could be seen on the front end. Please check the text "TEST": hidden link

Now you can do the same for the other languages. Could you please verify it once more and confirm that the problem is resolved?

Regards,
Mateus.

May 14, 2021 at 7:48 pm #8768069

normanL-3

My issue is resolved now. Thank you!