Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by bernardL-9 1 year, 5 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
March 20, 2019 at 3:23 pm #3389775

bernardL-9

Hi, I am trying to translate the Title set in Yuzo Related Post plugin.
My site is French, translated to English.
The title is set to "Oeuvres similaires"

The way I use it is by adding the shortcode [yuzo_related] on each of my posts.
The translation of that shortcode remains the same. I still see "Oeuvres similaires" on the translated post.

I browsed the WPML forum and found that the available Related Posts plug-ins may not be compatible. I also found that there may be a way to add some XML code to allow the translation of text associated with shortcodes.
I also tried to translate the admin text for the Yuzo plug-in with no luck.

Could you please help me find a solution? See attached pictures.

French post: hidden link
English post: hidden link

March 21, 2019 at 12:27 am #3394135

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

March 21, 2019 at 8:00 pm #3420613

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. The plugin option is set to be translated properly with the String Translation under the text domain 'admin_texts_yuzo_related_post_options' so the cause of this issue seems to be a conflict with your theme/plugin or cache settings, in order to confirm it, please, try the following:

1 - Disable all the plugins, except WPML and the Related Posts plugin from your WordPress Dashboard > Plugins settings. Test your page again, if it works, activate one plugin at a time untill the culprit one is found.

2 - If the issue persists, change to a default WordPress theme in your WordPress Dashboard > Appearance > Themes settings and test your page again.

3 - Also, remember to clear any browser cache you might have.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know the results. Have a nice day.

March 21, 2019 at 9:48 pm #3424985

bernardL-9

Hi Marcos,
I have made a copy of my site with Duplicator. I have installed my site locally on my PC with Local by Flywheel. On my local setup, I deactivated all plugins but WPML and Related Post. The problem is sill there.
I changed the theme from Divi to WP 2017, the problem is still there.
I realized that the text domain 'admin_texts_yuzo_related_post_options' only change the display on the Related Post admin menu (Top Title).

Any other ideas?
Thanks,
Bernard

March 22, 2019 at 7:12 pm #3443895

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks.

March 22, 2019 at 7:23 pm #3443931

bernardL-9

OK will do. I will let you know the outcome.

In the meantime, I was able to find a workaround while we are investigating this.
I managed to add some CSS code and test the current language before inserting a title.
See attached pictures.

Thanks,
Bernard

March 22, 2019 at 7:35 pm #3443993

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, let me know when you are ready, have a nice day.

March 22, 2019 at 9:14 pm #3444277

bernardL-9

Hi Marcos,
I have just finished installing my setup in the sandbox.

The steps are simple:
-Get to any of the 3 posts I created
-You will see the title of the Related Post plugin
-You can switch the language at the top right
-In French it should be "Articles similaires"
-In English it should be "Related Posts" but it stays "Articles similaires"

Let me know the outcome.
Thanks,
Bernard

March 26, 2019 at 6:16 pm #3465475

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I have forwarded your ticket to our compatibility team, I will update you here as soon as I get some more details. Have a nice day.

March 28, 2019 at 9:11 pm #3485657

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your continued patience while waiting for a solution. Please, try the following:

1 - In your wp-content/plugins/yuzo-related-post/ directory open the file: yuzo_related_post.php

2 - Replace the line 814 with:

$_html .= "<div class='yuzo_clearfixed yuzo__title'>". get_option('yuzo_related_post_options')['yuzo_related_post_top_text'] ."</div>"

3 - Enter your related post title without HTML tags.

5 - Place your post related shortcode wrapped in HMTL tags such as: <h3>[yuzo_related]</h3>

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if it helps, have a nice day.

March 29, 2019 at 1:38 pm #3491783

bernardL-9

Hi Marcos,
Your solution works. Thank you very much!
This means to me that this plugin is not compatible with WPML and I would need to contact the plugin's author for him to make proper adjustments.
Also, any updates of the plugin would force me to apply the fix to the php file again.
This also means that WPML cannot do anything on their side.

Could you please advise and tell me if I am right before we close the ticket?
Appreciated,
Bernard

March 29, 2019 at 3:09 pm #3492491

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Yes, you should contact the plugin author and update him regarding the incompatibility issue and the work around for that. Also, you would have to enter the code again on every plugin update. Unfortunately, there's nothing we can do regarding it. Thank you for your understanding, have a nice day.

March 29, 2019 at 7:07 pm #3494193

bernardL-9

My issue is resolved now. Thank you!